By particlewave_delta


2015-05-18 02:33:33 8 Comments

i'm new here, so i apologize in advance if this is a n00bish question:

how could one remount /system (or any partition, for that matter) in rw and allow suid on a booted system via ADB wifi? here's some particulars:

  • hardware=custom, no exterior ports
  • bootloader=unknown
  • kernel=loop device and module enabled
  • ro.secure=1
  • recovery=OEM
  • version=4.3
  • root=temp
  • busybox=yes, custom
  • mount=ext4; ro; relatime; barrier=1; nosuid

thnx

2 comments

@D. Gibbs 2015-05-18 14:38:52

Try running everything from the ADB shell.

adb shell
su
mount -o remount,rw /system

If you install something as root "su" you can use chown to change the owner of the file. It's not quite like using suid but at least you can change the owner.

It also looks likes Busybox has suid built in, if you have the right version.

Check out this website for more info.

@particlewave_delta 2015-05-18 16:13:22

tried from the shell and from term emu installed via [adb install]. I have an su binary in /sdcard/Download, as well as one in /data/local, but can't execute the one in /sdcard. i'll try [chown] on the /sdcard/Download binary. thnx for the link. updates to come.

@D. Gibbs 2015-05-18 18:13:39

What error are you getting when trying to execute the binary under /sdcard? You might need to change the permissions chmod 6774 su of the binary.

@particlewave_delta 2015-05-18 20:46:32

"system/bin/sh: ./su: can't execute: Permission denied"

@D. Gibbs 2015-05-18 21:25:37

And your tablet is rooted, correct?

@particlewave_delta 2015-05-18 21:35:09

temp root from a binary pushed to /data/local/ and executed.

@D. Gibbs 2015-05-18 21:37:29

Then try running /data/loca/temp_root <root command to execute> to run it as root and you shouldn't get a permission denied error. where temp_ root is the name of your root program and <root command to execute> is the command to be executed as root. I've never heard of a temp root before though..

@particlewave_delta 2015-05-18 22:49:24

ok. i haven't tried it that way yet. i'll give it a go tomorrow.

@particlewave_delta 2015-05-18 22:51:45

temp rooting is when you push an su binary thru adb to a directory you can execute from. in my case, /data/local. the root shell is temporary because it doesn't survive reboot.

@aureljared 2015-05-19 11:45:29

@D.Gibbs Isn't it /data/local/temp_root -c <command>? Oh, and the su binary is given 06755 permissions in some Android ROMs, so there's that.

@D. Gibbs 2015-05-19 19:18:33

@aureljared, thanks for the permissions. The command might have -c on some ROM's but I don't remember using it. But that's not to say that I'm mistaken :) @particlewave_delta: why not just root the tablet permanently?

@Paul Ratazzi 2015-05-18 09:31:40

Once your debug bridge is connected, get it running as root with adb root. Then remount the partition read/write using adb shell mount -o rw,remount /system.

Not sure what you mean by the suid part of your question, but if you can elaborate, I will try to answer that as well.

@particlewave_delta 2015-05-18 10:21:39

i suppose the suid portion might be redundant, so nvm that. i have tried that one, no luck with it.

@Paul Ratazzi 2015-05-18 11:33:26

Are you getting an error on either or both of the 'adb' commands? If you are remounting rw and still unable to modify the partition, you may have a bios protection. Some phones, like HTC call this S-ON. This must be changed to S-OFF before the 'mount' command will do anything. It can be difficult to get S-OFF, depending on the model of phone.

@particlewave_delta 2015-05-18 12:26:21

adb root returns no error and build.prop shows adb running as root. i get the error when I pass the mount cmd to the shell.

@aureljared 2015-05-19 11:42:58

What exactly is the error you're getting?

Related Questions

Sponsored Content

6 Answered Questions

[SOLVED] Can't remount /system in rw

1 Answered Questions

[SOLVED] SELinux and chroot system call

1 Answered Questions

remount file system with "adb remount" in production builds Marshmallow 6.0

0 Answered Questions

why I cannot remount the /system as rw?

  • 2016-10-20 21:54:26
  • Wang
  • 366 View
  • 0 Score
  • 0 Answer
  • Tags:   root-access

1 Answered Questions

1 Answered Questions

[SOLVED] remount /mnt as read-write

1 Answered Questions

[SOLVED] Getting mount's usage suggestion when attempting /system remount

  • 2015-10-09 11:32:30
  • Robert S. Barnes
  • 7619 View
  • 0 Score
  • 1 Answer
  • Tags:   mount command-line

0 Answered Questions

Shell with su cannot remount /sytstem. adb can.

1 Answered Questions

[SOLVED] Can almost empty system partitions be shrinked?

  • 2015-03-11 07:20:19
  • Aleksandar Stefanović
  • 168 View
  • 1 Score
  • 1 Answer
  • Tags:   root-access partitions

0 Answered Questions

Remount writable by all users?

Sponsored Content