By Arielle


2015-07-24 10:30:02 8 Comments

Because of my external SD card issue, I thought I should factory reset my phone then reinstall the firmware on it. Before I'd do that though, I'd have to back up my apps and their data so that I can restore it afterwards. For that purpose, I had been relying on Titanium Backup Pro, so I entered the app, changed the backup directory to /storage/emulated/legacy/TitaniumBackup (as the external SD card was unavailable) and attempted to backup all user apps and system data. A progress dialogue appeared and was stuck at 0% for about 30 seconds until it close and Titanium Backup displayed the notification 'Batch backup interrupted: Insufficient free storage space' despite having 7 gigabytes left on /storage/emulated/legacy.

I tried searching on Google for a solution - the only one that came up was to remove /data/app/com.keramidas.TitaniumBackup-1.odex but the file did not exist on my end. How can I fix this issue?

Clarification: My copy of Titanium Backup is a Pro version activated by a Pro key obtained from the Google Play store. There is no need for any external patchers, cracks or keygens.

10 comments

@aalaap 2016-02-03 17:20:10

This is due to the 'Mount namespace separation' setting in SuperSU being turned on (by default). Untick that, reboot and try your Titanium Backup operation again.

This happens because the permissions to app-created folders are restricted in newer Android versions, I believe. Ironically, I didn't have this issue on Marshmallow-based CM13, but I did face it in the Lollipop-based OxygenOS for the OnePlus One.

@number5 2016-03-06 16:34:01

This works like a charm on my Lollipop 5.1.1 based DU ROM for HTC One m7, thanks!

@Kiran Jonnalagadda 2016-05-14 13:03:04

Worked for me as well. I had missed backups for weeks thinking I really was out of space.

@Cerberus 2016-05-28 17:35:33

Thank you very much! This works for me on Kitkat 4.4.2. It's stupid of SuperSU to silently introduce this, as it entirely disables some other apps without warning, and without any hint about the cause. Or is it really Titanium's fault?

@aalaap 2016-06-15 05:29:19

@Cerberus It's Google's fault :-)

@aalaap 2016-06-15 05:29:39

@KiranJonnalagadda Good to know! Btw, we should reconnect! :-)

@Celeritas 2016-10-01 02:21:02

Where is the option to disable name space separation? CM 12.1 doesn't use SuperSU.

@aalaap 2017-03-14 10:22:32

@Celeritas Good question. Even I'd like to find this out. Anyone?

@subtleseeker 2018-06-26 03:48:07

If you are using Magisk as your superuser manager, go to settings > mount namespace mode and select isolated namespace. Hope this helps someone!

@Dalvik 2015-07-24 11:11:24

I have also faced this weird situation. I don't know whether it will work or not. But for me it works.

Install lucky patcher. It will automatically remove the odex file and you will be able to install Titanium Backup.

@Firelord 2015-07-24 11:12:24

But there doesn't seem to be any .odex file. And it doesn't seem to be hidden considering its tutorials around the web. // And TitaniumBackup is already installed!

@Dalvik 2015-07-24 11:13:42

In my case same scenario is there. I also not able to view the file. Please install this apk and open . just wait for 5-10 sec it will automatically scan and remove. You will se a notification when its done

@Dalvik 2015-07-24 11:15:07

@lord-ralf-adolf 2015-07-24 11:15:46

there is not odex file ,only if you odex the app your self ,like applying a patch from lucky patcher ,if you do lucky patcher will apply patch to an odex file and put it in the same directory as the apk (I think the use of lucky patcher is illegal -just saying- )

@Arielle 2015-07-24 11:18:10

I don't need to use Lucky Patcher as I've already bought the Pro version of Titanium Backup on Google Play. I should have been more clear about that.

@Dalvik 2015-07-24 11:18:37

@lord-ralf-adolf i dont know about odex in deep. But Lucky patcher solve my problem. I was stuck for months. IT is not illegal it is just the power of open source

@Dalvik 2015-07-24 11:19:52

@Arielle I am not saying you to use it. You just install it. and open it. You have to do nothing. It will automatically remove the odex file. then you can uninstall the app

@Firelord 2015-07-24 11:23:24

@Dalvik Thanks for the help but you're missing the basic point. We can't seem to find that odex file and that patcher is certainly no magical thingie which would create that file on its own, delete it, and then tell us that it did the job! Right!

@lord-ralf-adolf 2015-07-24 11:26:10

@Dalvik not the power of open source (the power of open source can be seen in many project like linux kernel ,xbmc ,chromium ect ) ,it emulates in-app purchases! patch free to make pro versions ,I know it has a set of useful tools but still there more illegal and legal stuff

@Dalvik 2015-07-24 11:27:15

@Firelord I am not supporting lucky patcher. I am sharing my experience and how it solved my issue . If it works for someone then its good

@Firelord 2015-07-24 11:29:32

@Dalvik OK, I got the point. Now it's up to the community users to decide the usefulness of this answer. Good luck! (and I didn't down-vote).

@Dalvik 2015-07-24 11:31:18

@Firelord its ok

@lord-ralf-adolf 2015-07-24 11:33:22

for more info about odex files I recommend reading this forum.xda-developers.com/showthread.php?t=2336411

@Arielle 2015-07-24 11:34:19

I have just tried opening Lucky Patcher, then closing it and reinstalling Titanium Backup. It still doesn't work as intended.

@Dalvik 2015-07-24 11:37:53

@Arielle Have you waited for some time after opening lucky patcher ?

@Arielle 2015-07-24 11:40:01

@Dalvik I waited until the progress dialogue disappeared. Was I supposed to wait for longer?

@Dalvik 2015-07-24 11:42:14

yes ... for 5-10 sec.. give it time to scan all the apps .... and wait for a while

@ody 2015-12-11 05:19:49

This happens due to some service change in kitkat. Some research on google showed that there is an app available to modify the platform.xml file. The app once run, prompts the user to allow it to go ahead and make the modifications to the above file. Everything works fine after this.

NextApp SDFix

@kaedinger 2016-02-26 05:22:31

At TB's startup it always displayed a warning that SuperSU's namespace separation feature "might not work reliably on some platforms".

Well, I never faced any problems until a recent SuperSU update...

So disabling that option in SuperSU and rebooting solved the "insufficient space" on my OnePlus One/CM12.1.

This was the obvious solution before fiddling around with permissions etc.

@abhis4u 2016-01-06 18:46:54

just go to super user-settings-untick "mount namespace separation" and reboot done!!

@Firelord 2016-01-06 20:36:21

And the reasoning behind it?

@mix3d 2016-03-09 19:20:25

Same answer as highest rated. Titanium Backup now pops a warning if Namespace separation is enabled, which separates the superuser commands in some way. Titanium backup can't access the right things if namespaces are separated.

@zak 2015-11-08 17:49:45

(Titanium Backup)batch backup interrupted: insufficient storage space this solution work for me any one can try see if it work. I have a fix. I did a little research and found that you can edit /etc/permissions/platform.xml and add a group to WRITE_EXTERNAL_STORAGE

Original:

Add the media_rw group:

Done. Doing a TiBU right now to my external card. This may fix other apps that have issues writing to the card, I personally didn't find any.

Suggest that you do an adb pull of the file for safekeeping before doing this. If you pull the file, edit it, and push it back make sure the permissions are set to 644.

@Berend de Boer 2017-01-07 07:04:36

I didn't have this group on Android 6, but had it on Android 5. Just adding it fixed the insufficient storage space message for me. So add this above the "WRITE_MEDIA_STORAGE" entry: <permission name="android.permission.WRITE_EXTERNAL_STORAGE" > <group gid="sdcard_r" /> <group gid="sdcard_rw" /> <group gid="media_rw" /> </permission>

@vishalbiswas 2015-07-24 17:14:15

Open Preferences of your Titanium Backup. Then look for an option called Backup app external data in Backup Settings. Make sure it is NOT Enabled. Rather set it to 'Enabled if smaller than a chosen size' and set the size to 35 MB.

(Click image to enlarge)

IMG: Backup external data

Some apps have a hefty amount of external data (stored in /sdcard/Android/data), particularly games which may span over several gigs. This option disables backing them up as they can be downloaded again.

@Arielle 2015-07-24 17:41:50

Sorry, but that solution didn't really work on my end. 'Backup app external data' was already set to 'Enabled if it's smaller than a chosen size' and the size was set to 32 MB, so I tried setting it to 'Disabled (Always)' and retrying the backup... which didn't work.

@vishalbiswas 2015-07-25 04:00:41

@Arielle Try turning on Compression (setting it to BZIP2). Make sure you're just backing up the user apps and NOT any system apps.

@Arielle 2015-07-25 07:25:00

I tried changing Compression from GZIP to BZIP2, and backing up the user apps only. Still doesn't work. Even though I have 7 GB of space left.

@vishalbiswas 2015-07-25 13:28:14

Last resort: Run logcat as root. It will give you an idea at least.

@Arielle 2015-07-26 09:35:26

As @Izzy said, this was an XY problem - I could have looked for another backup solution instead of insisting on using Titanium Backup. And I did - I used the adb backup feature (which worked when I rebooted my phone). In the end, I didn't have to restore the backup at all, but that's a different story altogether.

@Trebor Rude 2015-07-25 08:53:43

In recent versions of Android, paths under /storage/emulated/legacy only work for the apps that created them. If the OS doesn't know that TB created /storage/emulated/legacy/TitaniumBackup, then you'll get this error.

Try using TB to create a directory, then use that for your backups. Alternatively, use a path that doesn't start with /storage/emulated/legacy, like /data/media/0/TitaniumBackup. Either should work.

@Arielle 2015-07-25 09:11:09

Either should work... but neither did. I tried creating another directory on /storage/emulated/legacy, and using that for the backups - didn't work. I tried using a path that did not start with /storage/emulated/legacy - /mnt/sdcard (/data was not accessible to Titanium Backup at all) and it still didn't work as intended.

@Trebor Rude 2015-07-25 10:09:19

Hmm, I know I solved this exact problem on my TF700T after installing a new ROM. But I had similar issues in a number of apps. I must have used the /data trick in a different one. I assume you used TB to create the other directory in /storage/emulated/legacy? Won't work otherwise.

Related Questions

Sponsored Content

0 Answered Questions

Titanium Backup installation error

0 Answered Questions

1 Answered Questions

Insufficient SD storage space error!

0 Answered Questions

Why are apps excluded from Titanium Backup?

  • 2016-08-16 06:05:45
  • beeshyams
  • 96 View
  • 0 Score
  • 0 Answer
  • Tags:   titanium-backup

1 Answered Questions

2 Answered Questions

[SOLVED] Free Alternatives to "Titanium Backup Pro"

  • 2012-08-21 05:52:34
  • user16112
  • 3618 View
  • 7 Score
  • 2 Answer
  • Tags:   titanium-backup

1 Answered Questions

Insufficient Storage Space problem

1 Answered Questions

Sponsored Content