By galacticninja


2016-05-29 11:13:35 8 Comments

I'm always getting this error message when trying to download another language pack in SwiftKey:

Insufficient storage - The device does not have enough space to download [language]. Consider deleting apps or content that you no longer need and try again. [Screenshot 1]

However, I have 3.33 GB of available space in internal storage [Screenshot 2] and 3.68 GB in the SD card [Screenshot 3]. This error never occurs in any other app, even those installed after SwiftKey. And it only happens when installing another language pack within SwiftKey. It does not happen when reinstalling SwiftKey or when changing the theme in SwiftKey. I've already tried:

  • Uninstalling even more apps
  • Moving apps to SD card (for those apps that allow moving to SD card)
  • Clearing the cache and data of SwiftKey and retrying the language pack download
  • Uninstalling and reinstalling SwiftKey (also tried clearing cache and data before uninstalling)
  • Running the SD Maid app's AppControl and CorpseFinder cleaning modes after uninstalling
  • Searching for files with 'SwiftKey' in their names in SD Maid to ensure that no SwiftKey files are left behind after uninstalling SwiftKey. Also tried searching with the Amaze file manager app (root mode). No files are found in both searching methods.
  • Used the Delete old messages app to delete many of my old messages

Solutions suggested by answers in other related posts:

I've restarted the phone after doing the above-mentioned attempts, but they haven't fixed the issue. The error message still appears when I attempt to download another language.

Is there anything else I could try to resolve the issue?

Details:
Device: Huawei Honor 3C H30-U10
Android version: 4.2.2 Jelly Bean
The device is rooted. Superuser management app: SuperSU.

1 comments

@galacticninja 2016-06-25 06:13:44

Turns out this was a bug with SwiftKey and was fixed in version 6.3.6:

Fixed: ‘Insufficient storage’ error message will not appear when downloading languages

Before that version, I did a workaround by restoring a backup of SwiftKey's data using Titanium Backup (requires root) from another device with SwiftKey and the language pack already downloaded and installed. This will however, keep the settings and logged-in user data of the source device, so you'll to log-out the existing user and edit the settings after you have restored the SwiftKey data.

Related Questions

Sponsored Content

2 Answered Questions

3 Answered Questions

[SOLVED] Can SwiftKey be moved to the system partition?

Sponsored Content