By steampowered


2016-06-03 21:55:19 8 Comments

I recently upgraded to 6.0.1 Marshmallow on my Galaxy S5 and I would like to adopt an SD card as internal storage. However, there is no option to do this.

When I format the SD card, there is no "Internal" option, only a "Portable" option.

screenshot screenshot screenshot

I am using this SD card:

Samsung 64 PRO Micro SD XC

I have tried formatting the SD card in windows, deleting the partition in windows, and even wiping the parition in windows. But Android always wants to add it was portable storage.

How can I force Android to add this as internal storage?

EDIT: According to this article, the Galaxy S7 doesn't support adoptable storage. So it's likely the S5 doesn't support adoptable storage either. I'm looking for a way to enable it using the adb command line if possible now.

2 comments

@Thomas Vos 2016-06-04 05:37:13

Samsung (and some other manufacturers') devices don't support Adoptable Storage by default. However, there are some workarounds how you can enable it. Some devices will require root, and others don't. If you have a Galaxy A5, J5, J7, On5, choose method 2 (root required).

Before proceeding, make sure you have a backup as this will format your SD card.


Method 1 (NO ROOT | Galaxy S7)

Some Samsung phones (e.g. Galaxy S7) and other Android devices do not require root. You will need to execute the following commands using ADB:

adb shell
sm list-disks
sm partition <DISK> private
reboot

Replace <DISK> with the output of the previous command. (example: sm partition disk:179,64 private). If you don't want to convert the whole disk, then use this command instead: sm partition <DISK> mixed <VALUE>. Replace <VALUE> with the percentage (0-100) to keep as external storage. (Example: sm partition disk:179,64 mixed 50, for 50%).

If you do have root access, you can use my app Root Essentials instead. Root Essentials will execute all the commands for you, without the need of a PC.


Method 2 (ROOT | Galaxy A5, J5, J7)

If the above method didn't work for you, then it is not possible to get adoptable storage without root. (e.g. Galaxy A5, J5, J7, On5).

If you have rooted your device, you will need to download my app Root Essentials. After you have downloaded it, go to "Adoptable Storage". Then click the button "Adopt".

Root Essentials will ask you to flash a plugin using a custom recovery. (e.g TWRP). It is not possible to flash the plugin without a custom recovery. After you have flashed the plugin, reboot your device and open Root Essentials again. Now try adopting your SD card again and it should work.


I have adopted my SD card successfully, what do I need to do next?

After you have adopted your SD card, you will need to migrate your existing data to the SD card. This is to free up space on the internal storage.

To migrate your data:

  1. Open (Android) Settings
  2. Tap "Storage". (or "Device maintenance" > "Storage").
  3. Select your SD card.
  4. Open the menu (3 dots at top right), and tap "Migrate data".
  5. Now your data will be migrated to the SD card.

@steampowered 2016-06-04 13:25:34

Thanks, this worked to make it internal storage! The result seems to be a little buggy, as the OS doesn't always display the extra capacity. Not available for file transfers either. However, this is the best answer so I am marking it correct.

@Thomas Vos 2016-06-04 14:48:47

@steampowered Yeah, the total storage size is messed up. But the individual ones should be correct.

@rory 2016-07-13 14:51:36

@SuperThomasLab Is your advice Samsung specific? I'm having trouble formatting my class 10 San Disc SD card as internal memory on a Zopo ZP700. I tried your method but it still shows up as corrupted. I tested my card on a different phone and it worked so my card is ok.

@user177938 2016-07-22 20:31:04

After performing the ADB commands on 2 different sd cards, my Samsung Galaxy S5 is still not recognizing it as internal storage. I tried to run updates on my apps and keep getting messages that there is not enough storage. Will this even work on the Samsung Galaxy S5? Would rooting it help?

@Thomas Vos 2016-07-24 15:17:46

@KathleenPanek What does Settings > Storage show? (In the settings app). Rooting shouldn't make a difference.

@Jörn Berkefeld 2016-09-04 07:59:21

Hi, I managed to use your commands on a Galaxy S5 and it's actually moving my data as I type this (you forgot to mention that one should click on the newly integrated storage and EXPORT to it to free up space on the real internal memory). Anyways, I then tried to do the same on a Galaxy A5 which now also has Android 6 and while the commands go thru in the console, nothing changes under Settings>Storage. Any ideas?

@Varun Bhatia 2016-12-11 05:15:51

Not working for Samsung J5 as well.

@Thomas Vos 2016-12-11 11:07:10

@VarunBhatia On a Galaxy J5 it requires root. You'll need to flash a zip file through a custom recovery. You can find this file when you use my app Root Essentials.

@Thomas Vos 2016-12-11 11:07:22

@JörnBerkefeld Please see comment above

@Varun Bhatia 2016-12-15 09:27:00

@SuperThomasLab If some devices require root, I feel it is worth mentioning in the answer itself. I am unable to root my Samsung J5 and hence can't verify if your solution really works or not.

@Bing 2017-01-06 15:57:19

Am I supposed to be running these commands with the SD card in? Or out? I had a 32GB SD I'm replacing with a 200GB on my S5, but when I plug it in I never see the "Use as Internal Storage" that I'm expecting to (per this page: gadgetguideonline.com/android/android-marshmallow-guide/…). The specs for my S5 are: Verizon, Android 6.0.1, build MMB29M.G900VVRS2DPL1, Android security patch level December 1, 2016, KNOX version 2.6, NOT rooted (sadly--wish I knew how for this version!).

@Thomas Vos 2017-01-06 15:59:22

@Bing you needs to execute these commands with the SD card inserted. This is because the use as internal storage option is gone.

@Bing 2017-01-06 16:28:25

@SuperThomasLab I re-ran the commands again, after the reboot I went into Storage and I see "74.12 GB used out of 256 GB" - Internal storage shows 15.42 GB used of 16.00 GB and SD card shows 1.35GB used of 183 GB. Shouldn't these show as a single drive? When I run an app like DiskUsage to check file sizes it only gives me one drive to select (internal storage) and only shows 16 GB of capacity. It looks like my 200 GB isn't being used as internal.

@jarno 2017-06-24 11:59:07

Would this work on Samsung S5 Mini as well?

@Thomas Vos 2017-06-24 12:07:06

@jarno I don't see any reason why it wouldn't work. It should work on any device running Marshmallow or later.

@jarno 2017-06-24 13:17:50

I do not have ADB installed and I do not know how to install it. I also miss instructions on how to undo i.e. switch back to portable stroage.

@Hatoru Hansou 2017-06-30 04:03:34

At least for me, some apps still refuse to go to external storage. Situation has improved, all user data migrated to the privatized external storage, for example, now screenshots, downloads, WhatsApp images/video/audio go automatically to external storage, before I had to clear them periodically, but WhatsApp itself stays in internal, same with many other apps. Allow Marshmallow in 8 GB Samsung phones is bad design decision, those phones must stay in 5.1.1.

@erik 2017-08-28 20:18:41

Solution for Samsung J5 is android.stackexchange.com/q/160417/93158.

@RedEyed 2018-03-18 11:58:34

It works on Samsung Galaxy J7 2015. Thanks a lot!

@Gagantous 2018-05-12 05:57:00

for my cases it works sm partition disk:<DISK> private, the <DISK> is your memory id, i just simply put disk: and it works. It works on Samsung J2 Prime

@Bystander 2016-07-01 04:00:04

Apparently need to add the "sm" so: "sm partition disk:179,64 private" otherwise "Partition not found." I'm very new at this, so I'm probably stating the very, very obvious for most people. Anyway, seems to have worked. This was on a Note 4.

I assume what's happened at this point is that, though the total size isn't listing as changed, it actually is. Wish I knew how to confirm with these tools.

Slight correction: Under "Storage" it does list the total correctly with internal being mostly full (as it was) and almost nothing on the card. Assume I can just treat it all as one big happy pile of storage at this point?

But what was meant by "can't be used for transfers"? I assume you're just meaning that you can't yank the thing out and pull things off and on with a computer or other device?

Anyone care to share some caveats or tips after getting to this point?

@Gabriel Staples 2016-07-01 17:26:15

THANK YOU! the sm thing is not obvious. My Verizon Samsung Galaxy S5 was giving me the "partition now found" error before. Using your sm command above fixed it.

@Bystander 2016-07-01 17:30:34

The next step is to get into storage options and play around until it says something along the line of "moving files to sd". Once that's done, other than some confusion between both me and some apps as to what exactly is what, it works very well. My goal was to make it so my wife didn't constantly wonder where the storage she was short of was. Now, it's pretty much one spot, and plenty of it. Thank you all for posting this. I'll correct this later when I'm near my computer.

@Gabriel Staples 2016-07-01 17:44:25

correction: "partition not found" error

@tokam 2017-01-05 15:12:54

I think that it is not available for file-transfairs means, that when I connect the phone to the computer via MTP I can not see the full new combined disk size. So I still end up with 16 GB

@BiTinerary 2017-03-13 04:45:04

What?! Why take command line directions if your not actually going to follow them? Not "apparently" need to add the "sm". Perhaps this was included because it was necessary? w/e. This didn't actually work for me but adb shell sm set-force-adoptable true did.

Related Questions

Sponsored Content

1 Answered Questions

How to Read marshmallow encrypted memory card?

1 Answered Questions

[SOLVED] Galaxy s5 adoptable storage

2 Answered Questions

1 Answered Questions

[SOLVED] Moto G3 Marshmallow SD card as Internal storage

Sponsored Content