By Shamm


2018-12-30 14:36:46 8 Comments

So, I am trying to reset my security questions on my Huawei Nova 3i phone by reseting the settings app, only to find out that I also disabled/hid the developer options. Tapping the build number again makes it only say that I am already a developer. Any suggestions on how to fix this? Without factory reset. Thanks!

1 comments

@Supersonic 2018-12-30 16:28:39

This is not a way to get Developer Options back, but a workaround to launch it. You'll have to this again from Step 2 below every time you want to launch Developer Options.

You can use the ADB method @Robert referred to if you had USB debugging enabled, but based on your question it looks like it is disabled. If it is disabled or you can't use ADB for some reason, you can try the following method:

  1. You'll have to download and install a third-party app, Activity Launcher from Google Play Store.
  2. Open it and choose "All Activities" from the drop-down menu.
  3. Scroll down until you see "Settings" and choose it. It will open an another drop-down below it.
  4. Again scroll down until you see "Developer Options". There will be two menu items of that name.
  5. Choose the first "Developer Options" item. If you want to be extra sure, the light-grey text below the correct one is com.android.settings.Settings$DeveloperSettingsActivity.
  6. That will open the Developer Settings Menu, and you can do what you want there.

Note: I tested this on a P Smart Plus device (which is just your device with a regional change) so it should work on your device too. Also never launch random activities in Activity Launcher! It could damage your device software badly.

Good Luck!

@acejavelin 2018-12-30 17:54:29

I wonder if at this point once you get into Developer Options if you can just hit the slider at the top of the menu to turn it back On again? I have to think this is a bug in the device, because on my Moto if I disable Developer Options from the menu, I just tap the build number 7 times again to re-enable it.

@Supersonic 2018-12-30 18:00:28

I tried that and it works in my device. I can hit that slider and enable Developer Options again.

@Shamm 2018-12-31 01:33:32

I found what your referring to but it says com.android.settings.Settings$DeveloperSettingsDisabledActiv‌​ity. Is there a way to enable this?

@Supersonic 2018-12-31 09:07:31

That's strange, I have both Disabled and without Disabled activities. Also if I disable developer options I can press Build Number 7 times to enable again. It looks like a problem of your device, because I tested that on a P Smart Plus device.

Related Questions

Sponsored Content

2 Answered Questions

Cannot hard reset Huawei P9 (Reset failed)

  • 2017-03-18 14:51:29
  • Adrian Lew
  • 16154 View
  • 1 Score
  • 2 Answer
  • Tags:   huawei

2 Answered Questions

Enabling developer mode in Reliance LYF

1 Answered Questions

[SOLVED] Developer Options not showing up in LineageOS new build

3 Answered Questions

[SOLVED] You are already a developer/but no developer options

2 Answered Questions

[SOLVED] Remove downloaded system update from Huawei

1 Answered Questions

[SOLVED] Enabling developer mode in Huawei Mediapad M2 10.0

Sponsored Content