By Lekgolo137


2019-02-06 19:59:51 8 Comments

I'm currently experiencing a strange bug on my device: Whenever an apostrophe (') would be displayed, it shows an ampersand (&) instead, and the rest of the text that would be after the apostrophe is cut.

This only happens in one app, but the app is not the problem, as it doesn't happen in my friends's phones, I even tried installing the app on an emulator and it works fine.

I'm using a Xiaomi Mi A2 Lite, it's got Android One and is up to date (Android 9, Jan 5 patch), no custom roms or anything.

On the left, how it looks in my phone; and on the right, how it should look.

IMG: IMG:

UPDATE: After tinkering with the database I found out that the text that is being displayed is actually stored in html format that is latter interpreted and rendered by the application.

Also, these apostrophes are being stored as a numeric character reference (&#39 ;) which leads me to believe that the ampersand I'm seeing is actually the first character of the NCR.

I still don't understand why is this happening though, as the rest of the html code is being interpreted correctly.

0 comments

Related Questions

Sponsored Content

2 Answered Questions

[SOLVED] Google app displaying temperature in Fahrenheit

  • 2016-02-28 02:09:09
  • Једноруки Крстивоје
  • 7821 View
  • 3 Score
  • 2 Answer
  • Tags:   applications google

1 Answered Questions

Problem in opening applications

  • 2018-10-21 13:53:53
  • Khalil Ur Rehman
  • 44 View
  • 0 Score
  • 1 Answer
  • Tags:   applications

0 Answered Questions

Malware problem?

2 Answered Questions

[SOLVED] Why is the play store displaying same app twice under the My apps section

1 Answered Questions

whatsapp problem.

  • 2017-03-19 18:22:17
  • Dion Mabuza
  • 37 View
  • 0 Score
  • 1 Answer
  • Tags:   applications wi-fi

1 Answered Questions

Facing some problem with my android mobile

  • 2015-12-27 12:18:08
  • user37355
  • 146 View
  • 1 Score
  • 1 Answer
  • Tags:   applications

0 Answered Questions

0 Answered Questions

contacts not displaying

  • 2013-03-11 22:39:17
  • Joseph
  • 119 View
  • 3 Score
  • 0 Answer
  • Tags:   contacts bugs

1 Answered Questions

[SOLVED] Android 4.4 (Kitkat) and volume problem on a Nexus 7

Sponsored Content