By dsw


2019-04-10 16:30:08 8 Comments

I have a Redmi 3 MIUI7 that I recently flashed with MIUI9 using TWRP. Right after flashing, I tried to boot it but it stuck on a bootloop. Since I haven't booted into the ROM and can't do so because of the bootloop, I have no access to enable USB Debugging AND TWRP recovery mode. No USB Debugging means the device will show as unauthorized when using adb devices, though I can Vol. Down+Power to get into Fastboot. I have flashed several ROMs before flashing to MIUI9 (Resurrect Remix and LineageOS, both Android Oreo and had root access).

I just need way to boot into TWRP recovery mode to a) flash my way out of the loop b) restore a backup.

2 comments

@alecxs 2019-04-11 17:21:33

I can not answer in comments nor edit previous answer, so i have to post here. If you already downloaded AdbWinApi.dll AdbWinUsbApi.dll fastboot_edl.exe and started EDL Mode with edl.cmd with no result, then try this

1) Turn off your phone.
2) Now plug one end of the USB Cable into the PC port and the other end does not connect to the phone.
3) Press the Volume Up and Power buttons and immediately connect the other end of USB Cable to the phone.
4) Automatically the phone will go to EDL Mode with LED lights will light up blinking.

If this not working you should watch a tutorial how to build Deep Flash Cable or how to open the case and boot into EDL from test point.

@alecxs 2019-04-11 17:35:38

@Aroly7 2019-04-10 16:34:39

If you have access only to fastboot you will need complete ROM (including BOOTLOADER and FULL SYSTEM) because ota upgrade can broke custom bootloader

@dsw 2019-04-10 16:48:53

I can't use adb/fastboot commands because the device is "unauthorized"

@Aroly7 2019-04-10 16:57:15

Congratulation to new BRICK. Since you don't have any access to the device. The manufacturer may be able to reflash it on the board level.

@singhnsk 2019-04-10 18:38:12

You can use fastboot commands in fastboot mode. Fastboot has no relation to the USB debugging setting which is only for the ADB.

@Aroly7 2019-04-10 18:40:52

@singhnsk Fastboot can be disabled on some phones from os. Then they can reject commands.

@singhnsk 2019-04-10 18:42:18

@Aroly7 that's interesting. I haven't encountered such a setting on MiUi though. Is it the case, @dsw?

@Aroly7 2019-04-10 18:47:09

@dsw can you run fastboot oem device-info in fastboot?

@dsw 2019-04-11 03:08:05

@Aroly7 yes, tampered: false, unlocked: false, charger screen enabled:false

@Aroly7 2019-04-11 04:48:37

@singhnsk As I said. With bricked fastboot, He cants do anything.

Related Questions

Sponsored Content

1 Answered Questions

Stuck in fastboot, unable to access recovery or system (oneplus 3)

0 Answered Questions

Cannot enter fastboot mode after flashing custom recovery

1 Answered Questions

2 Answered Questions

0 Answered Questions

LG D620r stuck on bootloop after flashing TWRP

1 Answered Questions

[SOLVED] Issue with CWM recovery mode

3 Answered Questions

[SOLVED] Nexus 5X bootloop, recovery mode doesn't exist

1 Answered Questions

0 Answered Questions

Tablet boot in recovery mode always

  • 2014-07-30 12:29:47
  • RRD
  • 360 View
  • 0 Score
  • 0 Answer
  • Tags:   recovery-mode

2 Answered Questions

Sponsored Content