By Quandary

2010-09-14 03:55:03 8 Comments

Is there a way for WiFi-tethering without root access.

I mean before Froyo.

I have HTC Hero 2.1, and frankly, I don't want to root it for security reasons.


@Andy 2011-09-02 03:00:40

Short answer, you need to root for wifi hotspot tethering, or pay Sprint $30 a month. I thought about purchasing the package, but decided against it because they already charge you $10 extra per line for no legit reason. My thought there is they expect you to tether and can't do anything about it really, so they charge you extra and every month, 10 bucks adds up quickly per line, especially for those on your plan who don't even care to tether at all.

@Quandary 2011-12-24 12:30:45

Even if Sprint was my provider (it isn't, I'm in Europe) I wouldn't pay that.

@Quandary 2011-12-24 18:34:55

Here is the ultimate answer:

First, on your phone, install a terminal-emulator from Android market, then run

cat /proc/cpuinfo

which will show you the detailed processor information of your phone (ARM5 in my case).

Afterwards, you need to install an ARM5 cross-compiler environment on your Linux box (download Ubuntu and VirtualBox if you are a Windows/Mac-freak and don't have a Linux box), in order to compile native code for your phone.

You do this in order to be able to start a privilege escalation attack ON YOUR PHONE.

So, next, you need to cross-compile a privilege-escalation attack for ARM5 (HTC Hero microprocessor). For that, use the RageAgainstTheCage attack made by Sebastian Krahmer of Suse Linux Berlin (in binary only), reverse-engineered here:

A precompiled version is available here

Download the Android SDK starter kit from Google.
Install the appropriate Android Platform SDK (version 2.1 for me).

Then, download the superuser (su) package:

Put all, the superuser package, the su program, and the RageAgainstTheCage exploit in the same folder as adb (a program to connect to your android phone from the Android SDK). You need to enable USB-Debugging, and switch of internet sharing.

Next, you transmit the file rageagainstthecage.bin to folder /data/local/tmp on your phone (initially, as normal user, you have write access only to the sdcard and the temp folder, but this is sufficient)

adb push rageagainstthecage.bin /data/local/tmp/

Then you start a shell on your phone:

adb shell

And change ownership on rageagainstthecage.bin to all

chmod 755 /data/local/tmp/rageagainstthecage.bin

Next, you start rageagainstthecage on your phone as normal user


When the exploit finished, your adb connection should terminate.

If it doesn't type

adb kill-server
adb start-server

Now connect again to your phone:

adb shell

ADB shell now runs with escalated privileges (root). So now, remount the file system so you can write on the system partition.

mount -o remount,rw -t yaffs2 /dev/block/mtdblock3 /system

Now push su and superuser to your phone (remember, you have write access now)

adb push su /system/xbin/
adb push Superuser.apk /system/app/

And then change ownership on su to all

adb shell chmod 4755 /system/xbin/su

Next download and install one of all those free tether apps that require you to root your phone. Start superuser.

Now start your tether app. A popup will appear, which will ask you whether you want to grant this app root access. Say yes, and check remember.

Now switch of your phone and restart. When it has restarted, everything is back to normal, no more root privileges. But su is still there and executable for everyone. So, when logged in, start the wifi tether app. Since you checked remember in the superuser app, it will use su to switch this application to root, which means it will now run fine, with only the tether app with root privileges :)

Next, connect with your Linux box to your brand-new working Android WIFI hotspot. After you're sure it works, don't forget to put access restrictions for the hotspot in place.

BTW, if you use your escalated privileges to export some apk packages for reverse-engineering, you will notice that android lacks the cp command.

You can circumvent that restriction by using cat (copy-cat) instead:

cat /data/app/superuser.apk >> /sdcard/Downloads/superuser.apk 


@Dmitriy Likhten 2010-09-26 04:18:32

You can get unrevoked, its an app which gives you root access without changing your kernel/flashing a rom/voiding your warrenty, use that on every startup (its automatic) and then get the superuser app. Then you can use the Open Tethering app which requires root access.

Thats the ONLY free way to do wifi tethering. Otherwise pay sprint or your provider the monthly enable tethering fee.

Worst Case Scenario you can tether using EasyTether app. It creates a forwarding mechanism for HTTP requests through the USB port. Requires software on android + computer. Its not WiFi Tethering, but its free, rootless tethering. For 3 bucks you can get the pro version and do HTTPS as well. Better than nothing (or 30 bucks a month --err thats insane--)

@Quandary 2010-10-07 10:35:04

Unrevoked doesn't work on my hero, I can't get root.

@Dmitriy Likhten 2010-10-11 21:35:00

Poo! I have that problem on certain builds as well. Most unfortunate. Easy Tether might be your only solution. Requires USB cable and some set up on both sides, but better than nothing.

@Barfieldmv 2010-09-17 13:22:09

My samsung galaxy s (android 2.1) had a tethering option build in from the start. Settings->wifi-Mobile AP and I only had to check a checkbox for it to work. And it works really great. (not locked here t-mobile/netherlands)

I can't find the application name though.

@Quandary 2010-09-17 16:08:58

That application is called Android 2.2+.

@Dmitriy Likhten 2010-09-26 04:17:34

Yes but its locked by the provider and you have to pay money to unlock it per month. Sprint wants 30 bucks per month.

@Quandary 2010-10-01 06:49:35

I'm not a Sprint user, I'm an Orange user ;-)) But I don't have 2.2, yet.

@Eric Warriner 2010-10-06 13:25:59

Unfortunately, This does not work on the Samsung Galaxy S Captivate via AT&T here in the USA.

@Louis Rhys 2010-11-20 15:50:45

my galaxy s is 2.1 and this method works for me too

@joevartuli 2010-09-16 22:09:42

Easy tether is an awesome app that allows wifi tethering.

@colithium 2010-09-17 21:54:29

I thought it was just usb tethering...

@Quandary 2010-09-19 16:51:12

@colithium: it is...

@colithium 2010-09-20 01:48:00

He mentioned WiFi tethering.

@Quandary 2010-10-01 06:47:44

@colithium: But it definitely doesn't.

@colithium 2010-10-01 08:34:06

Which is why I commented... The questioner asked for a wifi tethering solution. Easy Tether is a USB only tether solution. Hints the problem with this answer. I'm confused

@colithium 2010-09-16 19:12:08

You won't like this answer but your carrier may provide the service if you're willing to pay extra for it. Sprint offered a WiFi hotspot feature for $30/month on the Evo pre 2.2. Ridiculous, yes. But may be your only option.

@Quandary 2010-09-17 16:07:51

I have 2.1 not 2.2 . And yes, ridiculous, but hey, Linux is FOSS, just compile your own and that WiFi thingy is unlocked. I suppose that is why Motarola digitally signs the bootloader and prevents any non-Motarola ROM from running...

@colithium 2010-09-17 21:56:00

I think xda got around that. But WiFi tethering was possible on 2.1 with Sprint. Just to be clear.

@Quandary 2010-09-19 16:52:55

Are you sure it was 2.1 ? If yes, interesting.

@colithium 2010-09-20 01:47:06

Positive. I'm sure you can find press releases mentioning 2.1 being the launch version and the wireless hotspot feature. Sprint disabled 2.2's built in feature and still wants you to pay them of course.

@Bryan Denny 2010-09-14 04:03:09

I don't know of any way to do wifi tethering without root (before 2.2). You can, however, use bluetooth or a USB cable with PDANet which does not require root.

@Quandary 2010-09-14 04:06:17

I have no Bluethooth (and don't want it either). And unfortunately, the USB cable is wearing out.

@SAGExSDX 2010-09-15 18:56:02

micro USB cables are cheap to buy:…

@Quandary 2010-09-17 16:10:37

Yea, you see, here in Switzerland, the cheapest USB cable you can get is 10 $. While you can buy it for 1 - 2 $ on Amazon (and delivered for 5$), I mind the 60 $ customs processing fee. And apart from that, having to connect and disconnect (and bring with you) the cable is immensly annoying.

@Quandary 2010-10-01 06:46:41

Update: Got Bluetooth working on my Laptop by patching the driver myself. But the quality is poor. PDAnet Bluetooth connects much faster than USB thethering, but it disconnects often.

@Quandary 2011-12-24 09:44:25

@Bryan Denny: Unfortunately not a solution, because I've now no admin access on the windows machine anymore (company laptop).

Related Questions

Sponsored Content

6 Answered Questions

[SOLVED] Using SMB server without root access

2 Answered Questions

[SOLVED] How do I enable USB tethering without turning off the WiFi?

1 Answered Questions

[SOLVED] Enable Wi-Fi tethering via Bluetooth?

1 Answered Questions

[SOLVED] Android 2.1, HTC Hero EU and WIFI configuration issues

2 Answered Questions

[SOLVED] Is there anyway to bypass the Verizon Wireless block of the tethering?

1 Answered Questions

[SOLVED] 2.1 as a secure access point?

Sponsored Content