By meds


2012-12-18 07:55:01 8 Comments

It used to work just fine then I upated to 4.2 and enabled developer options (one or the other must have broken it) and since then it has stopped working, it shows up as a camera device but if I change it to MTP it doesn't work.

I tried turning developer options off, I tried re-installing drivers and a few other things.

How do I make it work again like it was in 4.1 when it worked even when usb debugging was enabled? Now it won't work at all.

6 comments

@Richard Marskell - Drackir 2013-02-19 22:47:50

What worked for me (on Windows) was:

  1. Plug the Nexus 7 into your computer with the USB cable.
  2. Open Device Manager: Start -> Run (or Win+R), type in: devmgmt.msc and hit enter. This opens up the device manager.
  3. Find "Android Composite ADB Device" near the top and expand the node. Double click on the device. (Note: Sorry, I don't see it anymore so it might be named slightly differently.)
  4. In the properties window that pops up, uninstall the driver. You should choose to delete the current driver as well.
  5. Unplug the tablet and plug it back in.

At this point mine got recognized as a Nexus 7 instead of an Android ADB device and allowed me to transfer files again.

I'm not sure how this will affect debugging (especially if you delete the old driver) but it worked for me after days of searching.

@mdelolmo 2013-04-24 13:36:16

It worked for me too, but just to confirm, "delete the current driver" must be checked!

@Jim McKeeth 2013-05-03 04:49:55

Above steps worked for me, then I reinstalled the Google USB drivers after updating them with the SDK manager and it showed up both in explorer and via ADB.

@Daniel Chapman 2013-05-04 19:54:47

+1 Deleting the driver does matter. Definitely do it.

@hB0 2013-11-03 21:58:28

Above steps worked for me, then I reinstalled the Google USB drivers after updating them with the SDK manager and it showed up both in explorer and via ADB. In addition to that I had to de-authorize the computer from android device settings (nexus4) and then disable-enable debugging, and then reconnect the device to windows via usb.

@Elliot 2014-04-04 22:38:13

Dose not work for me as my device is completely invisible to the device manager. There is no entry anywhere in there for me to click on.

@WoJ 2014-06-01 14:19:34

I had the same problem on a Galaxy Note 2 and this solution worked. I did not have the generic "Android Composite ADB Device" but a Samsung entry. After deleting it (as well as the driver - as mentioned above you need to check the checkbox) and re-plugging it got recognized and the internal and SD card are visible again.

@Xilconic 2014-06-05 18:44:47

I've fixed the mentioned problem with these steps and I can also confirm that I deleting the drivers was part of fixing the problems as well (I did the steps without removing the driver at first, but that didn't help).

@Shawn Le 2014-08-22 02:53:56

the same thing does not work on Win 8, I tried and failed by Aug 2014.. so sad!

@Dave Jacoby 2014-12-22 16:49:41

With some modification, worked for my Galaxy S3. THanks

@DKIT 2015-08-15 20:42:58

Worked for me as well, +1

@Camille Goudeseune 2017-06-30 00:06:40

In Device Manager it appeared to me as Portable Devices -> Nexus 7.

@Ismail 2013-03-30 18:35:31

Try enabling USB debugging in Developer options. It worked for me.

@Peanut 2013-03-30 19:51:53

He's tried this, that's what the "I updated to 4.2 and enabled developer options" bit means I believe.

@Gili 2013-03-17 00:19:21

I kept on getting "This device cannot start. (Code 10)." and after hours of repeatedly reinstalling drivers all it took to fix the problem was rebooting the actual phone.

In summary: don't assume Windows is at fault, it could be the phone. Try rebooting it after installing new drivers.

@BigMG 2013-02-26 03:39:10

FINALLY SUCCESS

Tried above steps. Trying to connect a Nexus 7 to Win7-64. The device in the Computer Management/Device Manager/Portable Devices, used to say Nexus 7, now it says MTP USB Device and has the ! with This device cannot start. (Code 10). http://pcsupport.about.com/od/findbyerrormessage/a/code-10-error.htm Essentially, this means uninstalling all devices and reinstalling them. I did that with my three other devices and the Nexus7. There was a USB hub that had those three plugged in, so I just unplugged the whole hub. Replugged Nexus7 to USB, it found it (when I went to Disk Management and did a rescan). Once Nexus7 was recognized, I plugged the hub back in and all was well again.

@geffchang 2013-02-26 05:31:27

In StackExchange sites, ".. above steps .." does not mean anything because the answers get sorted by updates. If you think an answer has helped you, upvote it instead. :)

@bjornson 2013-02-24 22:03:50

I had the same happening even to me. I ended up getting it to work by going to the device manager and uninstalling the device (it was showing up as Samsung phone). Then I unplugged it, plugged it back in and it was installed again automatically, working fine and showing up in MTP mode as Nexus 10.

@cw1998 2012-12-18 22:44:29

This bug happens in some cases when upgrading. I fixed mine by changing quickly between MTP and Camera with the USB unplugged, then I put it back to MTP again and it worked fine when I plugged the USB back in

To change these settings go to Settings> Storage Then click the little menu button in the top right corner and click USB computer conntection.

Related Questions

Sponsored Content

1 Answered Questions

LG D821, where to dowload the ADB drivers?

  • 2015-02-12 19:42:31
  • BlueTrin
  • 1105 View
  • 0 Score
  • 1 Answer
  • Tags:   usb-drivers mtp

1 Answered Questions

How to connect a Nexus 6p to Windows 8.1 in MTP mode

1 Answered Questions

MTP not working under Android 6

1 Answered Questions

Can not recognize Nexus 7 2013 version with USB

1 Answered Questions

[SOLVED] Nexus 7 tablet won't show files when connected to pc

  • 2015-11-15 17:50:34
  • Conrad Hall
  • 34428 View
  • 2 Score
  • 1 Answer
  • Tags:   nexus-7

4 Answered Questions

[SOLVED] Marshmallow USB connection type

1 Answered Questions

[SOLVED] Cannot see phone under 'My Computer'

1 Answered Questions

[SOLVED] Nexus 7 2012 usb debugging not connecting (needed for Nethunter)

Sponsored Content