By Hell No


2012-12-26 11:32:51 8 Comments

I searched a lot over the Internet and tried all the advice I found.

I have installed drivers from the ASUS site and changed C:\Windows\inf\wpdmtp.inf so it now contains

; Nexus 7
%GenericMTP.DeviceDesc%=MTP, USB\MS_COMP_MTP
%GenericMTP.DeviceDesc%=MTP, USB\VID_18D1&PID_4E42&MI_00

both in [Generic.NTx86] and [Generic.NTamd64] sections.

My device is in MTP mode.

Computer sees it in PTP mode.

USB debugging is on.

It was said that I need Windows Media Player 11, but I have Windows 7 so it should be included, although I don't know where to check the version.

Here is what I see in device manager after all failed attempts:

screen shot

1 comments

@Tim 2012-12-26 15:17:01

For some reason, MTP and ADB are incompatible. Try turning USB debugging off, I've never been able to get it to connect right with it on.

Related Questions

Sponsored Content

1 Answered Questions

LG D821, where to dowload the ADB drivers?

  • 2015-02-12 19:42:31
  • BlueTrin
  • 1105 View
  • 0 Score
  • 1 Answer
  • Tags:   usb-drivers mtp

1 Answered Questions

How to connect a Nexus 6p to Windows 8.1 in MTP mode

1 Answered Questions

Can not recognize Nexus 7 2013 version with USB

8 Answered Questions

[SOLVED] Cannot connect my Moto X to Windows 7 PC

1 Answered Questions

Nexus 5 doesn't connect to PC anymore

1 Answered Questions

[SOLVED] Nexus 7 2012 usb debugging not connecting (needed for Nethunter)

1 Answered Questions

[SOLVED] How can I get back access to the media interface drivers?

2 Answered Questions

[SOLVED] Problem connecting Nexus 7 as mass storage device on Windows 7

Sponsored Content