By Liam W


2013-01-16 17:12:08 8 Comments

I am wanting to gain root privileges on my Google Nexus 7 tablet, running Android 4.1-4.2.1. How can I do this?

1 comments

@Liam W 2013-01-16 17:12:08

The Nexus 7 is probably one of the easiest Android devices to root - and all you need is the Android SDK (and 2 downloads).

Step 1

Install the adb and fastboot commands. On Ubuntu:

sudo apt-get install android-tools-adb android-tools-fastboot

On Windows you should download the Android SDK, however you can just download this zip which contains the adb, fastboot and dependencies.

Step 2

On your Nexus 7, go to System Settings->Developer Options->Check USB Debugging (You may need to slide the toggle switch in the action bar to on). If you do not see the USB Debugging option, go to System Settings->About Tablet->Tap on 'Build Number' 7 times.

Connect your Nexus to your computer.

Step 3

Make sure the drivers have downloaded and installed if you're on Windows - Windows Update should automatically find them.

Once connected, open up a terminal window (Windows: Win+R, type cmd press Enter. Ubuntu: ctrl+alt+t) and navigate to where you have unzipped the fastboot & adb programs (no need to do this on linux - they are in the path).

Step 3.5

Type adb backup -all -nosystem to backup your userdata to the backup.ab file.

Step 4

Type adb reboot bootloader.

Step 5

When the Nexus 7 has rebooted into fastboot mode, type fastboot oem unlock. Read the information on the device, and touch the Yes option. Your bootloader will be unlocked. This will erase all userdata!

Step 6

Download the latest TWRP recovery image. Save it in the same location as the fastboot binary. Issue the fastboot flash recovery twrp.img command to flash this recovery image.

Step 7

From the fastboot menu (green robot on its back with the cover open), use the volume keys to cycle through the options start, restart bootloader, power off, to recovery mode. Push the power key to select recovery mode. You'll see the google logo with an unlocked padlock, and then the TWRP splash screen for about 45 seconds. Then TWRP asks "keep system read-only?" Instead of tapping on "no," swipe the swiper to allow these modifications. This shows you the TWRP menu, 8 big buttons. Tap on Advanced. On the next menu, tap on ADB Sideload.

Download the latest SuperSU zip file and save it to the same location as adb and fastboot. DON'T UNZIP IT.

Step 8

On the Nexus 7, swipe the swiper to prepare it to sideload. Issue the command adb sideload CWM-SuperSU-v0.99.zip, which takes about a minute, and then tap the reboot button. This may take several minutes and several reboots, so don't worry.

The Nexus 7 is now rooted!

Step 9

Type adb restore <backup file made in 3.5> to restore from a backup.

@ott-- 2013-01-16 19:31:49

There is a step missing before 5, where you backup the userdata.

@Liam W 2013-01-16 19:52:20

@ott Fixed... ;)

@ComputerLocus 2013-01-17 00:47:39

What does the backup save. Does it save things like music, apps/appdata? What specifically is backed up?

@Liam W 2013-01-18 19:29:23

@Fogest Apps and appdata

@ComputerLocus 2013-01-18 22:42:02

@LiamW So, if I were to do this, and recover the backup, would my device appear like nothing has changed, or are there some things lost? I am just really busy lately and would rather not do this now, if I will have to reconfig a lot.

@Lennart 2013-02-13 14:47:42

The link to the TWRP image doesn't work anymore (404).

@GTF 2014-05-19 08:01:56

TWRP link still doesn't work, but you can get it for the nexus 7 (2013 WiFi) here: teamw.in/project/twrp2/193

@Chris Muench 2015-07-30 13:42:30

ERROR: cmuench-air:platform-tools cmuench$ adb sideload CWM-SuperSU-v0.99.zip loading: 'CWM-SuperSU-v0.99.zip' error: closed

@Camille Goudeseune 2017-06-30 12:56:04

Chris, just before that command, swipe the swiper on the Nexus 7. I've edited step 8 to reflect this. (Also use the name of the .zip file that you downloaded. Mine had about a dozen numbers in it, for instance.)

@Dark Hippo 2017-07-25 14:16:19

I know this is an old post, but I get to step 7 and don't get the TWRP splash screen. Could this be a versioning issue (my Nexus is the old 2012 model)

Related Questions

Sponsored Content

2 Answered Questions

How to root LG K7 (MS330)?

2 Answered Questions

1 Answered Questions

[SOLVED] How can I root my Yarvik Tab411?

  • 2013-04-10 16:43:11
  • marrssel
  • 2599 View
  • 0 Score
  • 1 Answer
  • Tags:   rooting

2 Answered Questions

Root Nexus 7 with 4.2.2

  • 2013-08-28 19:15:17
  • numberwang
  • 578 View
  • 0 Score
  • 2 Answer
  • Tags:   rooting nexus-7

1 Answered Questions

How can I root my General Mobile e-Tab 7b tablet?

  • 2013-07-20 08:14:54
  • forsubhi
  • 413 View
  • 1 Score
  • 1 Answer
  • Tags:   rooting

1 Answered Questions

1 Answered Questions

[SOLVED] Set custom DPI for different apps?

Sponsored Content