8 comments

@Alain Giresse 2018-11-27 08:00:08

In my experience I think play store won't let you install apps when you are running low on storage. For example it won't let you install even an app of about 2mb when storage left is just 90mb. This is for possible performance issue. No one wants to install an 2mb app that would load extra MB of data that would lead to memory issues. What I usually do is to back up large apps (even with app data) uninstall the backuped app and reinstall after installing the desired app. Another work around is to get the apk from a trusted source

@Kalutang 2016-04-21 16:07:00

I encountered this often before even if internal-sd free space was +2 gigs.

I tried this.

On the terminal, type these lines:

su
ps set install location 1
pm get-install-location

Note: Use no space between each line (I can't edit/format the correct spacing between the 3 line entries, sorry).

Now, after two months and dozens of additional apps installed, the "not enough space" annoyance has not bothered me.

Hope this helps.

@Dan Brown 2016-04-17 17:01:28

Unfortunately, this can be the bane of many, many devices. Android needs a bit of storage left over, and won't let google play fill it up - god knows why, since other stuff can - and thats it. You are not out of options, luckily. If you rooted the dang thing, you could buy a v.large SD and modify the vold file to think it was internal storage.

@Shimmy Weitzhandler 2015-05-05 07:45:11

I'm experiencing this problem too, and my experience revealed that it's only the latest version of the app store causing the problem.

So every time I want to install or update apps, I first revert the Play Store to the stock version.
I go to the app drawer, long click the Play Store icon and drag it to "App Info" to open its settings (you can reach there via Settings->Apps->Google Play Store), the press "Uninstall updates".
It will install updates in the following short period, until the Play Store app is upgraded again.
Please comment on if there is a way to prevent the Play Store from updating itself automatically (auto-update apps is set to false).

Hope this helps.

@miva2 2014-12-22 15:28:29

This is a very annoying problem I have also encountered many times. For some reason it thinks you don't have enough space even when you clearly do. Sometimes it can refuse a <1mb app when you have about 100mb free. Or it can allow a <100mb app when you have roughly 300mb free.

I don't think there is a real 'fix' to this.

Freeing up even more space should solve the problem. You can just uninstall a bunch of apps and see if it works again. Or you can clean your caches and other files you don't need (like the log mentioned by David Balažic) with an app like SDMaid or 1TapCleaner or whatever app you use. Cleaning cashes/tombstones/logs can easily free up a lot of space for you to install whatever app you like.

The problem will return though once you run out of space again.

the, arguably, best solution would be to have fewer apps installed (I don't like this but it's what works best for me) or buy an sdCard and install apps on sdCard (with the help of an app like AppMgr III or similar).

For those with a Samsung device that splits memory in Sdcard and USBStorage, you'll have to find a different way to actually put the apps on the external sd card instead of USB Storage. I believe I read somewhere it is possible by factory resetting phone and then choosing to install apps on sd or something like that but I am yet to try that.

@David Balažic 2014-12-21 19:58:14

Note: the following seems to work only on Samsung devices

Enter the number *#9900# in the dialer (no need to press the Call button) and the SysDump menu will appear, there select the second item (Delete dumpstate/logcat). This will delete some "hidden" system log files you didn't know exists and don't need. They can be up to a gigabyte big and cause mysterious "Cannot download, not enough space" and similar "no space" messages, when the system info otherwise claims there is plenty of space free.

Some suggest a restart after the deleting.

@HasH_BrowN 2014-12-21 22:20:51

Incorrect code :(

@David Balažic 2014-12-22 00:13:35

Maybe it works only on Samsung devices?

@John 2014-12-22 23:51:52

Unfortunately, the device in this instance does not have any phone functionality. Can you elaborate on other ways to find these hidden files?

@David Balažic 2015-02-11 12:04:25

According to this forum message (german), you can try to open the recovery menu and select the "wipe/clean cache" item there to get the same effect. The recovery menu is opened by turning the device off, the turning it on while holding some buttons. Which buttons depends on the device - google it. Also try to find more information about the wipe/clean cache operation, I never used it.

@kon psych 2013-06-08 10:05:16

Another workaround that worked for me in a similar case was to restart my device.

I guess that the application is trying to find a continuous free space of about 5MB and memory is not fragmented efficiently (there are many chunks of 4MB or less). Somehow memory is rearranged after restart but maybe the explanation is different.

@Izzy 2013-06-08 11:23:57

I doubt fragmentation is an issue here. It's rather that due to the restart some temp stuff might have been cleared up (e.g. something left in /data/local), and thus some space was freed up. But apart from that: yes, a restart can do that, sometimes :)

@John 2011-10-20 21:17:49

This doesn't answer why it doesn't work, but...

As a workaround, if you have an SD card, you can insert it and it will automatically download to the card instead.

@Shimmy Weitzhandler 2015-05-05 07:37:49

that doesn't work.

Related Questions

Sponsored Content

5 Answered Questions

Not Enough Space?

1 Answered Questions

Why do I keep getting "not enough storage space"

1 Answered Questions

Size required for install much larger than app

2 Answered Questions

[SOLVED] Clear Google Play Failed Download Space

4 Answered Questions

[SOLVED] Apps take up space but do not show up on app list

  • 2013-04-02 23:23:10
  • Joao Ferreira
  • 6940 View
  • 1 Score
  • 4 Answer
  • Tags:   internal-storage

1 Answered Questions

[SOLVED] ZTE Blade S2E not enough space

1 Answered Questions

Sponsored Content