By Thinzar


2014-12-18 06:54:59 8 Comments

I am having a problem with uninstalling apps on Android 5.0 (Nexus 5). I am developing an Android app, so I debug/run the app directly on my device. For production, I exported the same app with my keystore, uninstalled the debug APK that I ran earlier, tried to install the signed APK, and I got this error:

An existing package by the same name with a conflicting signature is already installed.

Is it because the bytecodes are still in the ART runtime? Anyone has any idea how to solve this?

2 comments

@Andrew T. 2014-12-19 06:52:26

When you uninstall an app using usual pre-Lollipop approach (e.g. dragging to "trash" icon, or from App info > Uninstall), it's only uninstalled on current user. It can be confirmed by app showing "Not installed" on stock app manager. Android will detect that the app is still there, preventing the user to install the app with same package name.

It's due to Guest account (if it's activated), that when an app is installed, it's automatically installed on all users. So, you need to uninstall the app from there too, which can be troublesome in daily usage.

There are some approaches to uninstall the app completely (ordered by practicality):

  1. (from Owner account) Go to Settings > Apps, find and open the app info. Then, open the overflow menu (3 vertical dots), and choose Uninstall for all users.
  2. (from guest account) Deactivate the guest account if you don't need it (for more info: Removing the default guest user account from Android Lollipop)
  3. (from PC) Enter adb uninstall <package> on command prompt/shell. This is the same as "uninstall for all users"
  4. (from guest/other accounts) Find the app and uninstall it normally.
    • In case you can't uninstall it, try to remove the account and create a new one, then try to find and uninstall the app again.

@Robert Koritnik 2015-05-27 09:18:01

How about apps that have Uninstall button disabled? Like system apps that are duplicated by apps from gapps packages?

@Andrew T. 2016-05-06 10:46:04

@RobertKoritnik sorry, that's outside of the scope of this answer since uninstalling system apps needs root access, such as this question.

@Scott Biggs 2015-07-29 15:09:18

I managed to uninstall this way:

  • I first attempted to uninstall the normal way (using Settings->Applications->app-name->uninstall), which kind of removes the ability to run it, but clearly does not uninstall.
  • I ran Google Play and looked up the app.
  • I saw that the UnInstall button was inactive, but the Install was active, so I tapped Install. Now I'm able to run the app.
  • After that, the UnInstall button in Google Play is active.
  • Tap the UnInstall to remove the app.

Voila, it's gone!

@Lucky 2015-07-29 18:14:49

I guess the uninstall button wont be visible unless the app is updated to the current version in playstore. If you din't have an updated version of the app that you are trying to uninstall this way it will show you two options i.e. Open Or Update. You have to update the app first and then Uninstall it which is an extra step that the user has to take but thats useless since the user want to get rid of the app.

@Scott Biggs 2015-08-03 18:41:15

@Firelord: 1) Yes, I mean all the above was run within the Google Play Store app on your mobile device. The app allows uninstalling of apps you have already installed (but it won't uninstall apps that were pre-loaded onto your device, sigh).

@Scott Biggs 2015-08-03 18:43:32

@Firelord 2) Clarification: in step 3, I use the Google Play Store app to re-install the app, allowing me to run it. I return to the Google Play Store (and again look up the app in question) for steps 4 and 5. Hope that clears things up.

Related Questions

Sponsored Content

1 Answered Questions

[SOLVED] Cannot uninstall "GO Security" app

1 Answered Questions

1 Answered Questions

[SOLVED] Nexus 10 completely dead after lollipop update

  • 2014-11-21 14:07:30
  • Alison
  • 2798 View
  • 0 Score
  • 1 Answer
  • Tags:   5.0-lollipop

2 Answered Questions

[SOLVED] Uninstall official lollipop Samsung Galaxy s5

2 Answered Questions

[SOLVED] App page sorting after app uninstall

1 Answered Questions

[SOLVED] Installing Gmail Material Design APK

Sponsored Content