By Ryan Conrad


2014-12-29 16:36:23 8 Comments

When the device is set to use MTP, neither Windows, nor ADB will detect the device when connect via USB cable. I have tried multiple cables, in multiple USB ports. I have not tried other computers yet, as this is the only one that actually has the driver installed.

Disclaimer: I am running an Unofficial CyanogenMod 12 build of Android 5.0.2

Device : LG G3 (LG-D855)
Android 5.0.2 CM12-Unofficial-20141228
Google USB Driver: Installed
USB debugging: Enabled
PC: Windows 8.1 Pro Update 1
No one, except me, has reported this as an issue in the XDA thread.

I have been unable to get my PC to detect the device via USB since I first installed CM12, which was around 11/10/2014.

MTP

adb devices - MTP

If i change to PTP, Windows will detect the device, as will ADB. But Windows will only let me access the internal storage, and Camera folders.

PTP

adb devices - PTP

1 comments

@Ryan Conrad 2015-01-01 05:22:51

After a couple of days of digging, I found the solution to this issue.

I opened up Device Manager. My first problem is I was looking for Android Composite ADB Interface, which is what it usually is called. I started looking harder. When I noticed ACER Device. My machine is not an ACER, nor do I have any ACER devices attached, or so I thought. I expanded that group and found ACER Composite ADB Interface.

These are the steps that I followed that got my ADB working with my device. YMMV.

ACER Composite ADB Interface

  • Download the latest USB Driver from Google
  • I right clicked this device
  • Uninstall
    • You may need to reboot after. I did.
  • Open device manager up again
    • The device may identify differently, and will probably have a triangle icon.
  • Scan for hardware changes
  • Right click the device again
  • Selected Update Driver Software
  • Clicked on Browse my computer for driver software browse
  • Select the path to the drivers that you downloaded at the first step, check the "Include subfolders" Let me pick
  • Let it install
  • Open a command windows (I had to open as administrator)
  • Run the following:

    adb kill-server

  • Now run:

    adb start-server

  • Finally run:

    adb devices

  • Profit! Success!!

@leenephi 2015-01-05 15:55:26

This worked! And it was driving me crazy with the Nexus 6. Thanks! :)

@ED-209 2015-03-17 13:53:04

This worked for me too, but be sure to select the 'delete the old drivers' option when removing the Acer Composite ADB Interface, as it your PC will keep telling you it's an Acer device and won't let you assign new drivers.

Related Questions

Sponsored Content

1 Answered Questions

BOOTLOADER - USB Device Not Recognized

1 Answered Questions

1 Answered Questions

How to connect a Nexus 6p to Windows 8.1 in MTP mode

1 Answered Questions

[SOLVED] Nexus 5 not detected by ADB

2 Answered Questions

[SOLVED] PC no longer recognizing Android Device

  • 2018-11-08 00:22:38
  • Charlie
  • 77 View
  • 1 Score
  • 2 Answer
  • Tags:   5.0-lollipop usb

4 Answered Questions

[SOLVED] How to install ADB drivers on Windows 10 (OPO)

2 Answered Questions

[SOLVED] MTP not working but ADB works fine

  • 2014-09-22 05:39:38
  • Shanion
  • 5846 View
  • 3 Score
  • 2 Answer
  • Tags:   adb mtp

3 Answered Questions

[SOLVED] Google Nexus 7 not recognized via USB

Sponsored Content