By Rocks


2015-02-02 04:30:03 8 Comments

After upgrading to Lollipop from 4.4.4, mobile data doesn't work. I have tried all the solutions listed in various forums including, 1. Reboot 2. Reboot after re-inserting the sim card. 3. Manually add the APN (Got the settings from the service provider) 4. Toggle between the Preferred Network type (2G and 3G)

I have only one usable sim slot, and so cannot use sim slot-1. I have heard it worked for a few guys after putting the sim in the other slot, but unfortunately I cannot try that out.

Any suggestions?

1 comments

@Rocks 2015-02-07 16:43:41

Okay, so here I am posting an answer to my own question. I finally visited a Motorola service center today to get the problem fixed and I was told that they are aware of the issue and that they'll be rolling out an update with a fix in 5 days. Hopefully everything will turn out well after that.

@Necktwi 2015-06-09 11:05:22

Just yesterday i got lollipop on my MotoG! I'm having same issue!! Its been 4 months since you posted the answer; Did the update roll out? Is your mobile data working?

@unforgettableid 2016-08-21 19:16:12

@neckTwi: It looks like Rocks may never return. Did you ever find a solution to this issue which started affecting you more than a year ago?

Related Questions

Sponsored Content

2 Answered Questions

Wileyfox Swift Mobile data not working after update to Nougat 7.1.1

1 Answered Questions

2 Answered Questions

1 Answered Questions

[SOLVED] Android 5.0.2 Lollipop- Moto G 1st Gen Wifi Hotspot issue

  • 2015-02-04 13:51:06
  • user92945
  • 11595 View
  • 3 Score
  • 1 Answer
  • Tags:   5.0-lollipop

3 Answered Questions

1 Answered Questions

[SOLVED] Moto G 2 Lollipop update breaks mobile data

2 Answered Questions

Sponsored Content