By VitalyB


2011-05-31 07:46:58 8 Comments

I'm trying to run a tasker task manually from ADB Shell, via SSHDroid. I'm running the following in putty (Windows SSH client):

am broadcast -a net.dinglisch.android.tasker.ACTION_TASK -es task_name Silent

On which I get:

Broadcasting: Intent { act=net.dinglisch.android.tasker.ACTION_TASK dat=Silent } Broadcast completed: result=0

However, despite the existence of task "Silent", nothing happens. Could it be because SSHDroid doesn't have the net.dinglisch.android.tasker.PERMISSION_RUN_TASKS permission? If so, how can I fix that? If not, what else can be the cause?

Thanks!

2 comments

@VitalyB 2012-01-26 12:21:06

This was solved thanks to Bossman's awesome proxy APK. Install it and then run via SSH:

am broadcast -a pl.bossman.taskerproxy.ACTION_TASK --es task_name TASKER_TASK_NAME_GOES_HERE

It works flawlessly :)

@Ryan Conrad 2012-01-25 15:40:35

The reason is because SHDroid does not have permission to execue Tasker actions.

You could contact the developer of SHDroid and ask him to add the permission to the application. I haven't found exact contact info for him, but I found his blog.

Related Questions

Sponsored Content

0 Answered Questions

Tasker: Task after receiving email

  • 2019-05-04 11:05:56
  • Pradeep
  • 12 View
  • 0 Score
  • 0 Answer
  • Tags:   tasker

0 Answered Questions

Tasker: Trigger task when trying to connect to server

  • 2018-08-11 16:54:59
  • Nattfrosten
  • 21 View
  • 0 Score
  • 0 Answer
  • Tags:   tasker

1 Answered Questions

[SOLVED] stop a previuos run of a task in tasker

  • 2017-12-07 21:28:48
  • kurokirasama
  • 1311 View
  • 0 Score
  • 1 Answer
  • Tags:   tasker

1 Answered Questions

[SOLVED] How to send a variable value to and receive it in a task?

0 Answered Questions

Run a Tasker task via ADB

  • 2016-06-20 05:32:07
  • Teiv
  • 841 View
  • 0 Score
  • 0 Answer
  • Tags:   adb tasker

1 Answered Questions

[SOLVED] Tasker: continually check for shell command result and run task when it matches

  • 2015-10-05 00:24:06
  • Nutshell
  • 1113 View
  • 1 Score
  • 1 Answer
  • Tags:   tasker

0 Answered Questions

Manually Stop a Running Task

  • 2015-09-16 16:28:08
  • Ahmed
  • 2767 View
  • 1 Score
  • 0 Answer
  • Tags:   tasker

1 Answered Questions

[SOLVED] Tasker: Notify before executing task

4 Answered Questions

[SOLVED] How to SSH into Android from a different network?

  • 2012-11-02 06:46:46
  • kushdilip
  • 8988 View
  • 7 Score
  • 4 Answer
  • Tags:   networking ssh

0 Answered Questions

Unable to Install APK Via ADB Shell

Sponsored Content