By Nodir Nasirov


2018-11-29 18:13:56 8 Comments

When I am doing some work on my macbook pro, Mail app's main window keeps popping up in the background, it even pops up when I watch movies by interrupting full screen. This is so frustrating, I can't find out solution to this, googled and went to many discussion forums, no luck, suggestions that I found are very old and outdated. Has anyone faced similar issues or does anyone knows solution to this?

8 comments

@Tommy 2019-10-10 19:04:09

I was hoping that with Catalina the problem would be solved, instead here I am.

Looking for a solution I tried to activate the logging of the connection status (from Mail menu: Windows -> Connection Status). Examining the log when the Mail app is popping up, I found out these error messages at the exactly same time and on every occurrence of the problem (when the app doesn't pop up the error messages don't show up):

READ Oct 10 20:41:21.323 [kCFStreamSocketSecurityLevelTLSv1_2] -- host:imap.gmail.com -- port:993 -- socket:0x6000003b7de0 -- thread:0x60000322d080
5.659 NO [AUTHENTICATIONFAILED] Invalid credentials (Failure)
--
READ Oct 10 20:41:21.427 [kCFStreamSocketSecurityLevelTLSv1_2] -- host:imap.gmail.com -- port:993 -- socket:0x6000003b7de0 -- thread:0x60000322d080
6.659 BAD Invalid SASL argument. z66mb54202756wmc
--
READ Oct 10 20:41:21.732 [kCFStreamSocketSecurityLevelTLSv1_2] -- host:imap.gmail.com -- port:993 -- socket:0x6000003b7de0 -- thread:0x60000322d080
7.659 NO [AUTHENTICATIONFAILED] Invalid credentials (Failure)

(Just posting the lines containing the errors)

The error messages are present only on the log file of my Gmail account, every other mail account doesn't show any error message. So as many of you, I also think that the problem is due to the Gmail accounts.

Hope this can help to solve the problem in any meaningful way.

@ankii 2019-10-10 20:07:10

yes gmail login fails and then the app pops up, then login succeeds. Thanks for logging! you might want to help on this question too. How to investigate Mail app's random popup bug on Mojave?

@Mirko 2019-10-03 15:15:40

I deal with this is by "quitting" Mail with ⌘-H. That hides mail, but keeps it active in the background. If you reopen mail, it starts up exactly the way you hid it before.

@ankii 2019-10-03 19:40:55

Just to clarify, it is actually hiding the application, not quitting it. It would still appear in CMD+TAB strip. Emphasis on the double quotes.

@Mirko 2019-10-06 12:52:02

True, but if you close the mail app (red button), it's in the cmd tab window too. It just doesn't do anything if you select it. Plus its quicker working with hiding and cmd tab than opening apps from the dock.

@ankii 2019-10-06 12:55:18

the red button closes all windows (that is what we see in File menu too), quitting is cmd Q(both quit and close are different), hiding all windows is cmd H. Re: "It just doesn't do anything" Actually it does! it brings up mail application in focus where you can use alt cmd N for a new window.

@Frank Augurk 2019-09-09 09:17:59

I have solved this problem by removing my Google account in Mail and making my Google Gmail address a normal (IMAP) account. Since then no more pop-ups.

@whiteknight2628 2019-09-06 15:00:21

I found this answer on Apple Community website useful. It also works to my situation. I think the reason is the Mail app does not support 2-step authentication well. So don't use the Gmail portal to connect your Gmail, but generate an app password from Google website and manually set up your Gmail using the normal email portal in the Mail app. enter image description here

@N B 2019-06-03 13:57:32

I have the same issue: The google calendar stuff is nonsense. The notification settings suggestion doesn't work.

I've narrowed it down to the following:

I normally hit the red cross button on the viewer window once I have finished looking at my mail, this closes open viewer windows but leaves the mail app active in the dock:

So if I have mail running, but no viewer windows open, then I get a viewer window randomly popping up to the foreground a few times an hour.

If instead of hitting the red cross button, I minimise mail using the minus button, then I don't get any viewer windows randomly opening. In this scenario, the mail viewer window is minimised either on the right hand side of the dock or into the application icon itself, depending on your settings (System Preferences > Dock > "Minimize windows into application icon").

So I have changed my habits to work around this annoying bug...

@Andreas 2019-07-06 12:15:24

Now we just have to wait a few years to be allowed to minimize fullscreen windows

@serdarsenay 2019-07-15 23:49:44

or just quit the damn mail, i have an annoying and whopping 20k unreads anyway!

@Simon L. Brazell 2019-07-19 02:40:01

Tried everything else, this is the only thing that works, wonder if this is on the 'roadmap' to be fixed at some point, it's been happening now for many months.

@Simon L. Brazell 2019-07-19 02:40:12

Tried everything else, this is the only thing that works, wonder if this is on the 'roadmap' to be fixed at some point, it's been happening now for many months.

@Drumbeg 2019-07-23 13:49:07

This is the only sensible workaround here.

@y3sh 2019-09-06 13:29:28

I did a screen capture of this happening and it looks like it pops up because of an auth error with gmail (that quickly resolves). The error text shows up just under the search bar. I have 2FA turned on and wonder if that in combination with how frequently mail fetches happen is causing problems. I'll just hit the minus for now

@DrAchernar 2019-06-19 13:00:57

you need to follow this way on top menu , but first you should fix google calendar step on google account settings. then; Mail > Accounts > Google and uncheck calendar. if you have multiple google account, apply this to all unchecked calendar

@Reyraa 2019-06-25 07:41:01

When you uncheck the calendar, your don't get your calendar events anymore. Certainly this is not what the question asks.

@Geoff Nixon 2019-02-14 12:26:57

  1. Mail > Preferences > General, uncheck:
    "Prefer opening messages in split view when in full screen."

  2. ⌘-W and ⌘-Q are your friends.
    Maybe try to get in the habit of closing Mail when watching a movie? It'll save you this hassle, a little battery life, and I promise, your mail will still be there when your movie is over. :)

  3. Maybe try a different mail app? The thing is, Mail.app has been a really wonky program since time immemorial. Its one of a handful of apps that has never once got a full rewrite (along with the likes of Grapher and Activity Monitor). So I wouldn't hold your breath for a fix for these mysterious stirrings. So, if you're someone who really prefers a good desktop email client, you might want to look at a program like Unibox (super slick, ~$15, and/or available through Setapp). Outlook 2019 isn't too bad either, although it is still Microsoft Outlook, so there's "a lot there".

@Wesley Bland 2019-06-21 14:25:44

Thanks for #1. That's a good tip. #2 is hardly a helpful snarky comment. Substitute "watching a movie" for "doing work". #3 is also not an answer to the question and in many workplaces is not a viable option.

@Jason Machacek 2019-06-27 23:16:50

@WesleyBland The original question specifically mentioned interruptions while watching full-screen movies, so it wasn't that snarky.

@Nikita 2019-07-18 12:22:38

the question is how to solve this issue and not all these 3 answers; me for example, I want to understand whether some fraud service is doing it or it's just an apple's bug; besides this the mail app of apple is a great mail client!

@z0nam 2019-02-14 05:02:12

@JBis 2019-02-14 05:07:04

Yes. I have a bunch of gmail accounts that have Calendar enabled and I have had them on for years without a problem. The link seems like an annoying working around in which I would be left without notifications. This is not a viable option for me.

Related Questions

Sponsored Content

1 Answered Questions

[SOLVED] Shutdown prompt keeps popping up

1 Answered Questions

[SOLVED] Open/Reopen dialog regarding Finder keeps popping up?

  • 2019-05-06 11:59:34
  • slm
  • 149 View
  • 0 Score
  • 1 Answer
  • Tags:   finder mojave

3 Answered Questions

[SOLVED] App download progress in redesigned Mac App Store (macOS Mojave)

2 Answered Questions

[SOLVED] Reset All Mojave App Permissions

2 Answered Questions

[SOLVED] Mail app is slow/unresponsive under macOS Mojave. What can I do?

  • 2018-09-02 08:24:13
  • vomako
  • 3401 View
  • 0 Score
  • 2 Answer
  • Tags:   mail.app mojave

1 Answered Questions

[SOLVED] How can I prevent "Mail" from popping up alerts?

  • 2011-11-23 00:14:10
  • Agvorth
  • 2506 View
  • 3 Score
  • 1 Answer
  • Tags:   mail.app

Sponsored Content