By isuruAb


2019-03-09 14:15:25 8 Comments

Recently I bought a second hand iPhone 8. When I'm trying to unlock the device It shows this error: The Apple ID "[email protected]" cannot be used to unlock this iPhone

  • Previous user deleted this device from "find my iPhone" service (But still it shows "Erase requested 1hour ago")

How can I register my device under my apple ID? Do they take more time to erase a device from the database ?

2 comments

@isuruAb 2019-03-10 11:10:32

I asked previous owner to enter his Apple ID and Password. After that it gave me a pop up window to add my Apple ID. Now It works correctly.

@bmike 2019-03-09 14:44:22

Apple’s activation servers are generally instant. I’ve gone through the official process maybe 20 times in the past two years for work, and it has never not worked within 1 minutes let alone waiting 5.

Here is the official guide and link for the previous user to remove that lock:

Activation Lock is part of the iOS Activation status here:

So if you believe it’s failing, the instructions there are correct - contact Apple Support directly. The only thing I can add, is Apple doesn’t tell you the full email of the previous owner, so unless you have the passcode, you won’t really know which email is “[email protected]” above.

  • How exactly are you connected to the internet from the device to try and unlock / activate it?
  • Do you actually know the email some other way or were you putting something hypothetical in the question?

Related Questions

Sponsored Content

1 Answered Questions

[SOLVED] Unable to unlock Apple Account

3 Answered Questions

5 Answered Questions

[SOLVED] How can we unlock an iPhone backup file if we don't know the password?

1 Answered Questions

2 Answered Questions

2 Answered Questions

[SOLVED] How do I tell if my AT&T iPhone 5 is unlocked?

  • 2014-08-16 03:46:01
  • sigjuice
  • 3849 View
  • 2 Score
  • 2 Answer
  • Tags:   iphone unlock att

2 Answered Questions

1 Answered Questions

Problem in creating a new apple id

  • 2014-11-28 12:06:45
  • mounica
  • 4717 View
  • 0 Score
  • 1 Answer
  • Tags:   apple-id

2 Answered Questions

[SOLVED] Can't activate iPhone 4S

0 Answered Questions

iPhone shows apple logo and iPhone is not restored gives unknown error 2001

  • 2014-03-19 11:05:25
  • Arslan Khalid
  • 346 View
  • 1 Score
  • 0 Answer
  • Tags:   itunes ios iphone

Sponsored Content