By jmh


2019-03-13 03:09:43 8 Comments

When I am running on the command line using iTerm, it is in a different mode than I'm used to, shown in the images below.

enter image description here

enter image description here

When I try to type a command it shows all the previous variations of that command. When I try to run a commandit often adds other options to the command line. How do I get out of this mode?

2 comments

@jmh 2019-04-11 01:33:57

when running iTerm click on the View menu and under that menu is an option for "Auto Command Completion". That option was selected which caused the problem mentioned in the question. When that option was deselected the iTerm windows performed as normal.

@LangLangC 2019-04-09 21:33:27

This looks like what happens when you start typing a command and then hit cmd+;. The options in that mode are :

iTerm2: Highlights for New Users: Autocomplete

Any text that exists in a tab or its scrollback buffer can be autocompleted in that tab. To use autocomplete, type the beginning of a word and then press cmd-;. An autocomplete window opens showing the top 20 choices for words beginning what you have entered. The list can be filtered by typing a subsequence. The filter can be reset by pressing backspace. If you make a selection and press return, it will be entered for you. If you make a selection and press tab, your autocomplete will be extended with the selection.

To just get "out of this mode" – not making a selection – hit esc.

This then could therefore be for this special case a setting found 'automated' in Preferences>Profiles>Advanced>Triggers:

enter image description here

If that's the case, then clicking edit should open a sheet-pop-up where you see some entries, one of them providing this now unwanted feature.

enter image description here

In the lower left here is a plus and minus sig box. Select the unwanted trigger and delete it.


Alternatively, you might just create an entirely new profile (first picture with "Default" + "TUSTEP"), click the plus sign in the lower left, and compare settings with your former "Default"-profile (in case you have some more sophisticated settings).


The files at

~/Library/Preferences/com.googlecode.iterm2.plist
~/Library/Application\ Support/iTerm2

might also be worth a look.

If there are external 'input manipulators' installed (text autocompleter, scripters, listeners to events) things get more complicated…

@jmh 2019-04-09 22:03:37

i have added some images to my question that is rlated to your answer. i don't have a trigger to delete! Can you check my question and look at additions i've made.

Related Questions

Sponsored Content

1 Answered Questions

[SOLVED] Windows won't open from Mac Dock

4 Answered Questions

[SOLVED] Alfred Terminal / Shell Command does not work

0 Answered Questions

Terminal and iTerm appear to be partially opening in zsh

0 Answered Questions

2 Answered Questions

[SOLVED] How to get Ctrl+return key binding for emacs in iTerm2 working?

0 Answered Questions

iTerm2 keeps switching desktops using dropdown

  • 2017-03-13 08:30:41
  • Matthew Lowe
  • 211 View
  • 3 Score
  • 0 Answer
  • Tags:   el-capitan iterm

4 Answered Questions

[SOLVED] How can I reset a Mac's password from Single User Mode?

1 Answered Questions

[SOLVED] How to enable true color mode in an OS X Terminal?

1 Answered Questions

[SOLVED] Switching terminal styles in iTerm 2

Sponsored Content