By David


2019-03-14 09:05:33 8 Comments

I have 2 x 3TB disks I've removed from a Synology NAS. When I try to mount these disks on OS X, they show as only having a single 800GB partition.

I've tried erasing in the Disk Util app, but it only finds and creates a new partition for the 800GB.

Repartitioning, erasing, repairing, all only see the disk as 800GB.

Any idea how to get these back to 3TB each? Both disks behave identically, and are WD RED disks WD30EFRX

disktutil - List...

/dev/disk3 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *801.6 GB   disk3
   1:                        EFI EFI                     209.7 MB   disk3s1
   2:                  Apple_HFS Untitled                801.2 GB   disk3s2

And the info...

DT:~ david$ diskutil info /dev/disk3
   Device Identifier:         disk3
   Device Node:               /dev/disk3
   Whole:                     Yes
   Part of Whole:             disk3
   Device / Media Name:       EFRX-68EUZN0

   Volume Name:               Not applicable (no file system)
   Mounted:                   Not applicable (no file system)
   File System:               None

   Content (IOContent):       GUID_partition_scheme
   OS Can Be Installed:       No
   Media Type:                Generic
   Protocol:                  USB
   SMART Status:              Not Supported

   Disk Size:                 801.6 GB (801569726464 Bytes) (exactly 1565565872 512-Byte-Units)
   Device Block Size:         512 Bytes

   Read-Only Media:           No
   Read-Only Volume:          Not applicable (no file system)

   Device Location:           External
   Removable Media:           Fixed

   Virtual:                   No

What avenue to wipe this drive and set it up for new filesystem to be installed exist?

1 comments

@jksoegaard 2019-03-14 15:52:31

This usually happens for one of two reasons: Either your partition table is incorrect/corrupted, or you have a limiting disk interface converter connecting.

Corrupted partition table

You'll need to wipe the partition table and write a new one, which will then allow you to use the full disk.

Follow the instructions below the heading "Erase and repartition a device" on this link to do so:

https://support.apple.com/kb/ph22240?locale=en_US

If you want to be absolutely sure that you have wiped the partition table, then choose to make it an MBR table first, and then do it again and choose GUID the second time.

Limiting disk interface converter

Some old USB to SATA adapters actually limit what drive size they will report over USB. This is because they convey the number of sectors on the drive as a 32-bit number only. Your disk (3 TB) requires 36-bits to describe the number of sectors. This would make the drive report as approx. 750-800 GB instead of the correct size.

You'll need to use a different adapter to connect the disk to solve this.

@David 2019-03-14 17:15:12

Thanks but that doesn't do it unfortunately. I followed those steps exactly before, and did them again, to convert to MBR and then again to GUID (because I had not tried that previously), and in each case, the drive is partitioned into a single 801.57GB partition.

@David 2019-03-14 17:16:44

Might the Synology NAS have changed the operating parameters of the drive in some persistent storage so it actually thinks it has less heads / cylinders etc that it does in reality. I would have thought erasing this way would remove any hidden partitions etc. At a loss with this one!

@jksoegaard 2019-03-14 17:28:48

@David I have updated the answer with an alternative explanation. If you're using such an adapter, this could be the cause of it.

@David 2019-03-14 17:38:51

I am using an adapter, so that's quite feasible. I will try to find another one to test with and come back with the results. Just ordered one that supports up to 4TB, so hopefully that's the issue - Thank you.

@David Anderson 2019-03-14 21:47:00

Do you think the problem may be the drive has a 4096 byte sector size and does not have the ability to emulate a 512 sector size? And/or, the adaptor is not capable of handling a 4096 byte sector size and requires either a drive with legacy 512 byte sector size or a drive with the ability to emulate a 512 byte sector size? Can you add the model of the adaptor you are using to your question?

@jksoegaard 2019-03-14 22:34:54

@DavidAnderson Yes, this along the lines of what I think and added to the answer earlier. When you use 512 byte sector sizes, the actual drive size reported over the USB can no longer be contained in a 32-bit integer, and thus the problem appears. It's not the actual 4096/512 byte sector that is the problem per se, as it would work fine with either sector size had the drive just been smaller in capacity - but it is the combination of the smaller sector size with the limited 32-bit drive size that gives the problem. Newer adapters all support more than 32-bit for the drive size.

@David 2019-03-15 12:28:49

It was the adapter. New one arrived this morning and 3TB straight off the bat! Thank you!

@jksoegaard 2019-03-15 15:22:51

Perfect :-) Good to know!

Related Questions

Sponsored Content

1 Answered Questions

[SOLVED] My Fusion Drive Partitioning Seems Wrong/Strange/Wonky

2 Answered Questions

4 Answered Questions

2 Answered Questions

1 Answered Questions

0 Answered Questions

2 Answered Questions

[SOLVED] Why do I have /Volumes/Storage Drive?

1 Answered Questions

[SOLVED] EFI automounts on startup

1 Answered Questions

[SOLVED] Can't modify partitions

0 Answered Questions

Broken FileVault Drive

Sponsored Content