1 comments

@jjanes 2018-10-26 23:30:15

I have not verified this myself, but the answer seems to be Yes, from version 42.2.0 of the driver from the jdbc.postgresql.org project.

To quote the changelog for Version 42.2.0:

Support SCRAM-SHA-256 for PostgreSQL 10 in the JDBC 4.2 version (Java 8+) using the Ongres SCRAM library.

See GitHub pull request # 842.

That driver uses the SCRAM Java Implementation project by ongres.

Related Questions

Sponsored Content

Sponsored Content