By Ardalan Shahgholi


2014-02-01 14:58:10 8 Comments

I have SQL Server 2012 with version 11.0.3000.0 .

enter image description here

I need upgrade my version to SQL Server 2012 SP1 because I need install Cumulation 4 in Sql Server 2012 Cumulative Update 4 for use PowerPivot in Multidimensional Database.

Before install Sql Server 2012 Cumulative Update 4 I need Upgrade my SQL Server to Service Pack 1.

How Can I Update My Version to SP1.

I sow this Link and download SQLServer2012SP1-KB2674319-x64-ENU.exe and SQLServer2012SP1-FullSlipstream-ENU-x64.iso but this not work in my Server.

I have this error :

enter image description here

2 comments

@Aaron Bertrand 2014-02-01 16:41:54

It looks like you are already at Service Pack 1 (this is why MSSQLSERVER is checked and greyed out). 11.0.3000 and 11.1.3000 are essentially the same thing, different files just have different reasons for exposing a different number in the middle - that number is really not relevant to your problem.

So now you just need to download and install the latest CU. I've blogged about SP1 CU #8 here, you can download it here, or if you really want CU #4 specifically, you can download that here (just keep in mind that this CU was released last June; you are missing a boatload of fixes if you limit yourself to that update).

P.S. you check the version of SQL Server by opening a query window and running:

SELECT @@VERSION;

The method you're using now checks the version of Management Studio - these are client tools that can be older or newer than the server service itself.

@Ardalan Shahgholi 2014-02-02 09:49:53

my sql server version is : Microsoft SQL Server 2012 - 11.0.2100.60 (X64) Feb 10 2012 19:39:15 Copyright (c) Microsoft Corporation Enterprise Edition (64-bit) on Windows NT 6.1 <X64> (Build 7601: Service Pack 1) (Hypervisor) but When I run SP1 CU #8 I get this error : The version of SQL Server instance Shared Component does not match the version expected by the SQL Server update. The installed SQL Server product version is 11.0.2100.60, and the expected SQL Server version is 11.1.3000.0.

@Aaron Bertrand 2014-02-02 13:30:26

@loup then that is not the same server or instance that the screen shot in your question is attempting to patch. If your server is at 2100 then that is RTM and you need to apply SP1 first. You won't get that validation error applying SP1 to an RTM instance. Are you trying to apply the service pack and/or cumulative update to a server from your workstation?

@Ardalan Shahgholi 2014-02-02 21:02:30

merci. it work. i first run service pack 1 and then U8

@CRAFTY DBA 2014-02-01 15:20:39

If you go to the download page on service packs, there are a lot of details.

http://www.microsoft.com/en-us/download/details.aspx?id=35575

Thus, SP1 install contains CU1 and cu2.

Are you sure the SQL server engine is installed?

I did a bunch of checking. Not too much information on this error.

First place to start is the event logs and sql server error logs.

Please check for more information (details) on this error.

@Ardalan Shahgholi 2014-02-01 16:12:56

I am sure that SQL server engine is installed. and my error is : there are no sql server instance or shared features that can be updated on this computer.

Related Questions

Sponsored Content

1 Answered Questions

[SOLVED] Upgrading SQL Server 2012 from SP2 to SP3

2 Answered Questions

1 Answered Questions

1 Answered Questions

1 Answered Questions

1 Answered Questions

[SOLVED] Failed Upgrade from SQL Server 2005 sp2 to SQL Server 2005 sp4

Sponsored Content