By Bart Bergmans


2019-01-09 13:13:27 8 Comments

In the status report of my drupal website I got the message that I had to up Database 4 byte UTF-8 support. I updated all my tables and database like it's told here: https://www.drupal.org/node/2754539. I checked and all my tables and the database have utf8mb4 encoding and utf8mb4_general_ci collation.

I get the following warning:

Enabled, but database tables need conversion Please convert all database tables to utf8mb4 prior to enabling it in settings.php. See the documentation on adding 4 byte UTF-8 support for more information.

1 comments

@Bart Bergmans 2019-01-09 14:28:28

I fixed it by manual setting the drupal_all_databases_are_utf8mb4 variable to true. You can do this by using drush or setting it in the database and then clear all caches.

Related Questions

Sponsored Content

0 Answered Questions

Is it safe to upgrade all the tables for 4 byte UTF-8 support?

  • 2019-02-16 04:36:51
  • sd100
  • 24 View
  • 0 Score
  • 0 Answer
  • Tags:   7 database

1 Answered Questions

[SOLVED] MySQL 5.1 to MySQL 5.6 update causes php-cgi error: PDO issue?

  • 2014-12-24 18:06:23
  • floatingpointmatt
  • 669 View
  • 1 Score
  • 1 Answer
  • Tags:   database

0 Answered Questions

Move from utf8_general_ci to utf8mb4_general_ci

  • 2017-05-11 18:59:02
  • eye-wonder
  • 307 View
  • 1 Score
  • 0 Answer
  • Tags:   7 database

2 Answered Questions

[SOLVED] Drush database connection issue

1 Answered Questions

[SOLVED] After enabling utf8mb4 on 7.50, cannot enable update module

  • 2016-08-26 00:48:36
  • Patrick Kenny
  • 444 View
  • 2 Score
  • 1 Answer
  • Tags:   7 database

0 Answered Questions

Feeds SQL Import shows data in preview but fails to import

1 Answered Questions

3 Answered Questions

[SOLVED] French accented characters not saving to database

0 Answered Questions

Migrating database from Mysql to SQLite in Drupal7

2 Answered Questions

[SOLVED] Drupal 6 database has mixed InnoDB & MyISAM. Need to fix before migration

  • 2012-02-15 19:54:14
  • jkneip
  • 613 View
  • 1 Score
  • 2 Answer
  • Tags:   database

Sponsored Content