By Dmytro Zarezenko

2012-06-03 19:30:34 8 Comments

I have configured my Apache by myself and have tried to load phpMyAdmin on a virtual host, but I received:

403 Forbidden You don't have permission to access / on this server

My httpd.conf

# This is the main Apache HTTP server configuration file.  It contains the
# configuration directives that give the server its instructions.
# See <URL:> for detailed information.
# In particular, see 
# <URL:>
# for a discussion of each configuration directive.
# Do NOT simply read the instructions in here without understanding
# what they do.  They're here only as hints or reminders.  If you are unsure
# consult the online docs. You have been warned.  
# Configuration and logfile names: If the filenames you specify for many
# of the server's control files begin with "/" (or "drive:/" for Win32), the
# server will use that explicit path.  If the filenames do *not* begin
# with "/", the value of ServerRoot is prepended -- so "logs/foo.log"
# with ServerRoot set to "C:/Program Files (x86)/Apache Software Foundation/Apache2.2" will be interpreted by the
# server as "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/logs/foo.log".
# NOTE: Where filenames are specified, you must use forward slashes
# instead of backslashes (e.g., "c:/apache" instead of "c:\apache").
# If a drive letter is omitted, the drive on which httpd.exe is located
# will be used by default.  It is recommended that you always supply
# an explicit drive letter in absolute paths to avoid confusion.

# ServerRoot: The top of the directory tree under which the server's
# configuration, error, and log files are kept.
# Do not add a slash at the end of the directory path.  If you point
# ServerRoot at a non-local disk, be sure to point the LockFile directive
# at a local disk.  If you wish to share the same ServerRoot for multiple
# httpd daemons, you will need to change at least LockFile and PidFile.
ServerRoot "C:/Program Files (x86)/Apache Software Foundation/Apache2.2"

# Listen: Allows you to bind Apache to specific IP addresses and/or
# ports, instead of the default. See also the <VirtualHost>
# directive.
# Change this to Listen on specific IP addresses as shown below to 
# prevent Apache from glomming onto all bound IP addresses.

Include conf/vhosts.conf

# Dynamic Shared Object (DSO) Support
# To be able to use the functionality of a module which was built as a DSO you
# have to place corresponding `LoadModule' lines at this location so the
# directives contained in it are actually available _before_ they are used.
# Statically compiled modules (those listed by `httpd -l') do not need
# to be loaded here.
# Example:
# LoadModule foo_module modules/
LoadModule actions_module modules/
LoadModule alias_module modules/
LoadModule asis_module modules/
LoadModule auth_basic_module modules/
#LoadModule auth_digest_module modules/
#LoadModule authn_alias_module modules/
#LoadModule authn_anon_module modules/
#LoadModule authn_dbd_module modules/
#LoadModule authn_dbm_module modules/
LoadModule authn_default_module modules/
LoadModule authn_file_module modules/
#LoadModule authnz_ldap_module modules/
#LoadModule authz_dbm_module modules/
LoadModule authz_default_module modules/
LoadModule authz_groupfile_module modules/
LoadModule authz_host_module modules/
#LoadModule authz_owner_module modules/
LoadModule authz_user_module modules/
LoadModule autoindex_module modules/
#LoadModule cache_module modules/
#LoadModule cern_meta_module modules/
LoadModule cgi_module modules/
#LoadModule charset_lite_module modules/
#LoadModule dav_module modules/
#LoadModule dav_fs_module modules/
#LoadModule dav_lock_module modules/
#LoadModule dbd_module modules/
#LoadModule deflate_module modules/
LoadModule dir_module modules/
#LoadModule disk_cache_module modules/
#LoadModule dumpio_module modules/
LoadModule env_module modules/
#LoadModule expires_module modules/
#LoadModule ext_filter_module modules/
#LoadModule file_cache_module modules/
#LoadModule filter_module modules/
#LoadModule headers_module modules/
#LoadModule ident_module modules/
#LoadModule imagemap_module modules/
LoadModule include_module modules/
#LoadModule info_module modules/
LoadModule isapi_module modules/
#LoadModule ldap_module modules/
#LoadModule logio_module modules/
LoadModule log_config_module modules/
#LoadModule log_forensic_module modules/
#LoadModule mem_cache_module modules/
LoadModule mime_module modules/
#LoadModule mime_magic_module modules/
LoadModule negotiation_module modules/
#LoadModule proxy_module modules/
#LoadModule proxy_ajp_module modules/
#LoadModule proxy_balancer_module modules/
#LoadModule proxy_connect_module modules/
#LoadModule proxy_ftp_module modules/
#LoadModule proxy_http_module modules/
#LoadModule proxy_scgi_module modules/
#LoadModule reqtimeout_module modules/
#LoadModule rewrite_module modules/
LoadModule setenvif_module modules/
#LoadModule speling_module modules/
#LoadModule ssl_module modules/
#LoadModule status_module modules/
#LoadModule substitute_module modules/
#LoadModule unique_id_module modules/
#LoadModule userdir_module modules/
#LoadModule usertrack_module modules/
#LoadModule version_module modules/
#LoadModule vhost_alias_module modules/
LoadModule php5_module "c:/Program Files/php/php5apache2_2.dll" 

<IfModule !mpm_netware_module>
<IfModule !mpm_winnt_module>
# If you wish httpd to run as a different user or group, you must run
# httpd as root initially and it will switch.  
# User/Group: The name (or #number) of the user/group to run httpd as.
# It is usually good practice to create a dedicated user and group for
# running httpd, as with most system services.
User daemon
Group daemon


# 'Main' server configuration
# The directives in this section set up the values used by the 'main'
# server, which responds to any requests that aren't handled by a
# <VirtualHost> definition.  These values also provide defaults for
# any <VirtualHost> containers you may define later in the file.
# All of these directives may appear inside <VirtualHost> containers,
# in which case these default settings will be overridden for the
# virtual host being defined.

# ServerAdmin: Your address, where problems with the server should be
# e-mailed.  This address appears on some server-generated pages, such
# as error documents.  e.g. [email protected]
ServerAdmin [email protected]

# ServerName gives the name and port that the server uses to identify itself.
# This can often be determined automatically, but we recommend you specify
# it explicitly to prevent problems during startup.
# If your host doesn't have a registered DNS name, enter its IP address here.

# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
DocumentRoot "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs"

# Each directory to which Apache has access can be configured with respect
# to which services and features are allowed and/or disabled in that
# directory (and its subdirectories). 
# First, we configure the "default" to be a very restrictive set of 
# features.  
<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all

# Note that from this point forward you must specifically allow
# particular features to be enabled - so if something's not working as
# you might expect, make sure that you have specifically enabled it
# below.

# This should be changed to whatever you set DocumentRoot to.
<Directory "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs">
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    # The Options directive is both complicated and important.  Please see
    # for more information.
    Options Indexes FollowSymLinks

    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    #   Options FileInfo AuthConfig Limit
    AllowOverride None

    # Controls who can get stuff from this server.
    Order allow,deny
    Allow from all


# DirectoryIndex: sets the file that Apache will serve if a directory
# is requested.
<IfModule dir_module>
    DirectoryIndex index.html index.php

# The following lines prevent .htaccess and .htpasswd files from being 
# viewed by Web clients. 
<FilesMatch "^\.ht">
    Order allow,deny
    Deny from all
    Satisfy All

# ErrorLog: The location of the error log file.
# If you do not specify an ErrorLog directive within a <VirtualHost>
# container, error messages relating to that virtual host will be
# logged here.  If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.
ErrorLog "logs/error.log"

# LogLevel: Control the number of messages logged to the error_log.
# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

<IfModule log_config_module>
    # The following directives define some format nicknames for use with
    # a CustomLog directive (see below).
    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
    LogFormat "%h %l %u %t \"%r\" %>s %b" common

    <IfModule logio_module>
      # You need to enable mod_logio.c to use %I and %O
      LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combinedio

    # The location and format of the access logfile (Common Logfile Format).
    # If you do not define any access logfiles within a <VirtualHost>
    # container, they will be logged here.  Contrariwise, if you *do*
    # define per-<VirtualHost> access logfiles, transactions will be
    # logged therein and *not* in this file.
    CustomLog "logs/access.log" common

    # If you prefer a logfile with access, agent, and referer information
    # (Combined Logfile Format) you can use the following directive.
    #CustomLog "logs/access.log" combined

<IfModule alias_module>
    # Redirect: Allows you to tell clients about documents that used to 
    # exist in your server's namespace, but do not anymore. The client 
    # will make a new request for the document at its new location.
    # Example:
    # Redirect permanent /foo

    # Alias: Maps web paths into filesystem paths and is used to
    # access content that does not live under the DocumentRoot.
    # Example:
    # Alias /webpath /full/filesystem/path
    # If you include a trailing / on /webpath then the server will
    # require it to be present in the URL.  You will also likely
    # need to provide a <Directory> section to allow access to
    # the filesystem path.

    # ScriptAlias: This controls which directories contain server scripts. 
    # ScriptAliases are essentially the same as Aliases, except that
    # documents in the target directory are treated as applications and
    # run by the server when requested rather than as documents sent to the
    # client.  The same rules about trailing "/" apply to ScriptAlias
    # directives as to Alias.
    ScriptAlias /cgi-bin/ "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/cgi-bin/"


<IfModule cgid_module>
    # ScriptSock: On threaded servers, designate the path to the UNIX
    # socket used to communicate with the CGI daemon of mod_cgid.
    #Scriptsock logs/cgisock

# "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
<Directory "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/cgi-bin">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all

# DefaultType: the default MIME type the server will use for a document
# if it cannot otherwise determine one, such as from filename extensions.
# If your server contains mostly text or HTML documents, "text/plain" is
# a good value.  If most of your content is binary, such as applications
# or images, you may want to use "application/octet-stream" instead to
# keep browsers from trying to display binary files as though they are
# text.
DefaultType text/plain

<IfModule mime_module>
    # TypesConfig points to the file containing the list of mappings from
    # filename extension to MIME-type.
    TypesConfig conf/mime.types

    # AddType allows you to add to or override the MIME configuration
    # file specified in TypesConfig for specific file types.
    #AddType application/x-gzip .tgz
    # AddEncoding allows you to have certain browsers uncompress
    # information on the fly. Note: Not all browsers support this.
    #AddEncoding x-compress .Z
    #AddEncoding x-gzip .gz .tgz
    # If the AddEncoding directives above are commented-out, then you
    # probably should define those extensions to indicate media types:
    AddType application/x-compress .Z
    AddType application/x-gzip .gz .tgz

    # AddHandler allows you to map certain file extensions to "handlers":
    # actions unrelated to filetype. These can be either built into the server
    # or added with the Action directive (see below)
    # To use CGI scripts outside of ScriptAliased directories:
    # (You will also need to add "ExecCGI" to the "Options" directive.)
    #AddHandler cgi-script .cgi

    # For type maps (negotiated resources):
    #AddHandler type-map var

    # Filters allow you to process content before it is sent to the client.
    # To parse .shtml files for server-side includes (SSI):
    # (You will also need to add "Includes" to the "Options" directive.)
    #AddType text/html .shtml
    #AddOutputFilter INCLUDES .shtml

    AddType application/x-httpd-php .php 

# The mod_mime_magic module allows the server to use various hints from the
# contents of the file itself to determine its type.  The MIMEMagicFile
# directive tells the module where the hint definitions are located.
#MIMEMagicFile conf/magic

# Customizable error responses come in three flavors:
# 1) plain text 2) local redirects 3) external redirects
# Some examples:
#ErrorDocument 500 "The server made a boo boo."
#ErrorDocument 404 /missing.html
#ErrorDocument 404 "/cgi-bin/"
#ErrorDocument 402

# MaxRanges: Maximum number of Ranges in a request before
# returning the entire resource, or one of the special
# values 'default', 'none' or 'unlimited'.
# Default setting is to accept 200 Ranges.
#MaxRanges unlimited

# EnableMMAP and EnableSendfile: On systems that support it, 
# memory-mapping or the sendfile syscall is used to deliver
# files.  This usually improves server performance, but must
# be turned off when serving from networked-mounted 
# filesystems or if support for these functions is otherwise
# broken on your system.
#EnableMMAP off
#EnableSendfile off

# Supplemental configuration
# The configuration files in the conf/extra/ directory can be 
# included to add extra features or to modify the default configuration of 
# the server, or you may simply copy their contents here and change as 
# necessary.

# Server-pool management (MPM specific)
#Include conf/extra/httpd-mpm.conf

# Multi-language error messages
#Include conf/extra/httpd-multilang-errordoc.conf

# Fancy directory listings
#Include conf/extra/httpd-autoindex.conf

# Language settings
#Include conf/extra/httpd-languages.conf

# User home directories
#Include conf/extra/httpd-userdir.conf

# Real-time info on requests and configuration
#Include conf/extra/httpd-info.conf

# Virtual hosts
#Include conf/extra/httpd-vhosts.conf

# Local access to the Apache HTTP Server Manual
#Include conf/extra/httpd-manual.conf

# Distributed authoring and versioning (WebDAV)
#Include conf/extra/httpd-dav.conf

# Various default settings
#Include conf/extra/httpd-default.conf

# Secure (SSL/TLS) connections
#Include conf/extra/httpd-ssl.conf
# Note: The following must must be present to support
#       starting without SSL on platforms with no /dev/random equivalent
#       but a statically compiled-in mod_ssl.
<IfModule ssl_module>
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin

PHPIniDir "c:/Program Files/php" 

and vhosts.conf:


    DocumentRoot i:/projects/webserver/__tools/phpmyadmin/


@amd 2012-07-02 07:19:26

Update October 2016

4 years ago, since this answer is used as a reference by many, and while I learned a lot from security perspective during these years, I feel I am responsible to clarify some important notes, and I've update my answer accordingly.

The original answer is correct but not safe for some production environments, in addition I would like to explain some issues that you might fall into while setting up your environment.

If you are looking for a quick solution and SECURITY IS NOT A MATTER, i.e development env, skip and read the original answer instead

Many scenarios can lead to 403 Forbidden:

A. Directory Indexes (from mod_autoindex.c)

When you access a directory and there is no default file found in this directory AND Apache Options Indexes is not enabled for this directory.

A.1. DirectoryIndex option example

DirectoryIndex index.html default.php welcome.php

A.2. Options Indexes option

If set, apache will list the directory content if no default file found (from the above 👆🏻 option)

If none of the conditions above is satisfied

You will receive a 403 Forbidden


  • You should not allow directory listing unless REALLY needed.
  • Restrict the default index DirectoryIndex to the minimum.
  • If you want to modify, restrict the modification to the needed directory ONLY, for instance, use .htaccess files, or put your modification inside the <Directory /my/directory> directive

B. deny,allow directives (Apache 2.2)

Mentioned by @Radu, @Simon A. Eugster in the comments You request is denied, blacklisted or whitelisted by those directives.

I will not post a full explanation, but I think some examples may help you understand, in short remember this rule:


Order allow,deny

Deny will win if matched by both directives (even if an allow directive is written after the deny in the conf)

Order deny,allow

allow will win if matched by both directives

Example 1

Order allow,deny
Allow from localhost

Only localhost and * can access this, all other hosts are denied

Example 2

Order allow,deny
Deny from
Allow from # <-- has no effect since this will be evaluated first

All requests are denied, the last line may trick you, but remember that if matched by both the last win rule (here Deny is the last), same as written:

Order allow,deny
Allow from
Deny from # <-- will override the previous one 

Example 4

Order deny,allow
Allow from
Deny from # <-- has no effect since this will be matched by the above `Allow` directive

Requests are accepted from all hosts

Example 4: typical for public sites (allow unless blacklisted)

Order allow,deny
Allow from all
Deny from
Deny from

Example 5: typical for intranet and secure sites (deny unless whitelisted)

Order deny,allow
Deny from all
Allow from mypc.localdomain
Allow from managment.localdomain

C. Require directive (Apache 2.4)

Apache 2.4 use a new module called mod_authz_host

Require all granted => Allow all requests

Require all denied => Deny all requests

Require host => Only from are allowed

D. Files permissions

One thing that most people do it wrong is configuring files permissions,



In linux:

  • Directories should have the Execute permission

  • Files should have the Read permission

  • YES, you are right DO NOT ADD Execute permission for files

for instance, I use this script to setup the folders permissions

# setting permissions for /var/www/

# read permission ONLY for the owner 
chmod -R /var/www/ 400 

# add execute for folders only
find /var/www/ -type d -exec chmod -R u+x {} \;

# allow file uploads 
chmod -R /var/www/ u+w

# allow log writing to this folder
chmod -R /var/www/ 

I posted this code as an example, setup may vary in other situations

Original Answer

I faced the same issue, but I solved it by setting the options directive either in the global directory setting in the httpd.conf or in the specific directory block in httpd-vhosts.conf:

Options Indexes FollowSymLinks Includes ExecCGI

By default, your global directory settings is (httpd.conf line ~188):

<Directory />
    Options FollowSymLinks
    AllowOverride All
    Order deny,allow
    Allow from all

set the options to : Options Indexes FollowSymLinks Includes ExecCGI

Finally, it should look like:

<Directory />
    #Options FollowSymLinks
    Options Indexes FollowSymLinks Includes ExecCGI
    AllowOverride All
    Order deny,allow
    Allow from all

Also try changing Order deny,allow and Allow from all lines by Require all granted.


Directory Indexes source code (some code remove for brevity)

if (allow_opts & OPT_INDEXES) {
     return index_directory(r, d);
} else {
        const char *index_names = apr_table_get(r->notes, "dir-index-names");

        ap_log_rerror(APLOG_MARK, APLOG_ERR, 0, r, APLOGNO(01276)
                      "Cannot serve directory %s: No matching DirectoryIndex (%s) found, and "
                      "server-generated directory index forbidden by "
                      "Options directive",
                       index_names ? index_names : "none");
        return HTTP_FORBIDDEN;

@Radu 2012-10-19 19:29:36

Also, one should check the folder's permissions so that the Apache process' owner has permissions to read/execute the specified path for the virtual host. On Windows this could rarely be a problem but on Linux it can be a more frequent cause of 403.

@Brady Zhu 2013-07-04 08:38:10

httpd.conf on my Ubuntu is empty and httpd-vhosts.conf cannot be found.

@Simon A. Eugster 2013-07-23 19:19:10

I additionally had to change Order deny,allow, Allow from all to Require all granted on Apache 2.4. See here:

@pylover 2013-10-27 16:31:22

only after adding Require all granted it worked

@Stephane Paquet 2014-01-20 01:14:02

@pylover Doesn't and mess up my configuration... (and the one of this guy too…)

@mjs 2014-05-05 19:15:26

In addition to this following step is required find the line > Listen 80 and change to > listen

@Melsi 2014-05-15 16:57:37

@Radu this comment could be an answer since your comment solved the issue for me.

@Darius.V 2014-10-21 13:34:38

I also needed to add index.html or index.php to the root directory

@ola 2014-10-25 10:00:47

I only had to add Indexes after that everything worked fine. So my Options line ended up looking like this: Options FollowSymLinks Multiviews Indexes

@Mateen 2015-02-06 11:40:40

In the recent version of apache (2.4.7) httpd.conf has been renamed to apache2.conf

@Allen 2015-05-12 11:15:53

Not working for me. I solved this issue by run chmod in terminal.

@Iman Marashi 2015-06-25 18:02:03

After this changes you must Restart All Services.

@Dineshkumar 2015-07-11 13:21:27

All this didn't work for me, finally changing User _www to my username in httpd.conf worked.

@ethmz 2015-07-24 13:03:20

Worked for me. Win8.1 + Apache2.4 + PHP5.6 + mod_fcgid (fast CGI)

@Hafiz Shehbaz Ali 2015-09-20 08:02:04

this is not working for me.

@PJW 2015-10-24 17:05:11

Did not have to change 'Options'. Only changed: 'Require all granted' and in the envvars file in /etc/apache2, changed 'export APACHE_RUN_USER=www-data' to 'export APACHE_RUN_USER=[my_username]'

@Uzumaki Naruto 2015-11-20 16:10:09

Thankyou so much.. you saved me a lot of trouble

@RiggsFolly 2016-06-05 12:29:34

This answer is SO WRONG! You should NEVER set Allow from all in the <Directory /> section of httpd.conf Thats just a hackers delight

@amd 2016-06-06 07:30:39

@RiggsFolly If you read well the answer, you will notice, that what I am suggesting is to modify the Options param and not the Allow

@RiggsFolly 2016-06-06 08:02:07

But you still have Allow from all in the <Directory /> The <Directory /> section should protect the root folder and all subfolders from all access. Then you allow access to only the directories that Apache actually requires access to. Then if you are hacked the hacker does not gain access to all your file system from a hacked Apache. See Protect Server Files by Default

@Ninja 2017-04-18 04:25:18

I got a 403 forbidden, and add Require all granted , and now it works ...

@Abdul wahid 2017-07-19 16:12:38

can I edit all the conf files to make allow from all in place of deny

@Charlie Harding 2018-06-30 17:25:13

Aren't these chmod arguments backwards? According to die, the file always goes last

@akash 2019-11-25 19:19:19

If the 'Original answer' needs to be used, then the conf file to be updated is changed from /etc/apache2/httpd.conf to /etc/apache2/apache.conf

@errolflynn 2020-01-04 06:19:59

SELinux types was my issue. As this is the accepted answer it may be helpful to reference @Dominic/@Peter Mortensen answer below

@Sal Borrelli 2018-07-16 17:34:25

I know this question has several answers already, but I think there is a very subtle aspect that, although mentioned, hasn't been highlighted enough in the previous answers.

Before checking the Apache configuration or your files' permissions, let's do a simpler check to make sure that each of the directories composing the full path to the file you want to access (e.g. the index.php file in your document's root) is not only readable but also executable by the web server user.

For example, let's say the path to your documents root is "/var/www/html". You have to make sure that all of the "var", "www" and "html" directories are (readable and) executable by the web server user. In my case (Ubuntu 16.04) I had mistakenly removed the "x" flag to the "others" group from the "html" directory so the permissions looked like this:

drwxr-xr-- 15 root root 4096 Jun 11 16:40 html

As you can see the web server user (to whom the "others" permissions apply in this case) didn't have execute access to the "html" directory, and this was exactly the root of the problem. After issuing a:

chmod o+x html

command, the problem got fixed!

Before resolving this way I had literally tried every other suggestion in this thread, and since the suggestion was buried in a comment that I found almost by chance, I think it may be helpful to highlight and expand on it here.

@Lakshmi 2017-10-14 03:54:15

    I changed 
    Order Deny,Allow
    Deny From All      in .htaccess to   " Require all denied "    and restarted apache but it did not help.

Path for apache2.conf in ubuntu is /etc/apache2/apache.conf

Then I added following lines in apache2.conf and then my folder is working fine

    <Directory /path of required folder>
            Options Indexes FollowSymLinks
            AllowOverride All
            Require all granted

   and run  " Sudo service apache2 restart " 

@José Lozano Hernandez 2017-01-25 16:04:15

This solution doesn't Allow from all

I just want to change my public directory www, and access it from my PC, and mobile connected by Wifi. I've Ubuntu 16.04.

  1. So, first, I modified /etc/apache2/sites-enabled/000-default.conf and I changed the line DocumentRoot /var/www/html for my new public directory DocumentRoot "/media/data/XAMPP/htdocs"

  2. Then I modified /etc/apache2/apache2.conf, and I put the permissions for localhost, and my mobile, this time I used the IP address, I know it is not completely safe, but it's OK for my purposes.

        Options FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from localhost

@washere 2017-04-29 18:36:52

RiggsFolly answered this for me elsewhere, simply:

in your apache conf folder edit file: httpd-vhost.conf:

Add this little line inside the Directory nest:

Require ip 192.168.1

Restart the server, apache or Wamp or whatever you have.

That's it, now all your HOME deivces (in ip range can see your PC server. Note you only add the first 3 parts of ip number).

Any problems, exit your firewall to test.

To see your network devices ip numbers, download an "IP Scanner" software (quite a few free ones around) for PC or for android get Fing from play store.

@luchonacho 2017-04-07 13:51:19

Permissions error

Some very noob users like me face this problem when having incorrect permissions set in a page (in particular, that "other" users do not have read permissions). For example, say you are attempting to access index.html, and you get the above error. To fix, type:

chmod o+r index.html

and then upload to server again. Error disappears.

@Dave 2017-04-03 20:32:48

Just to add another potential gotcha to this growing list, my problem (running CentOS 6.8) was with a particular virtualhost which worked fine on a different server, the issue turned out to be a faulty .htaccess file using mod_rewrite:

In .htaccess, this caused a 403 error: <IfModule mod_rewrite.c> RewriteEngine On RewriteBase / </IfModule>

Adding FollowSymLinks as the first line fixed the issue: <IfModule mod_rewrite.c> Options +FollowSymLinks RewriteEngine On RewriteBase / </IfModule>

@wuxmedia 2016-11-10 09:55:42

We had modsec enabled, check the site's error log for an modsec ID then enter a locationmatch for the file in the vhost (or .htaccess I guess):

 <LocationMatch "/yourlocation/index.php">
    <IfModule security2_module>
        SecRuleRemoveById XXXXXXX

@shellbye 2016-08-19 01:22:24

I use Mac OS X, in my case, I just forget to enable php in apache, all I need to do is to uncomment one line from /etc/apache2/httpd.conf:

LoadModule php5_module libexec/apache2/

ref this article for detail.

@Matthias 2016-07-22 20:47:44

This is pretty ridiculous, but I got the 403 Forbidden when the file I was trying to download wasn't there on the filesystem. The apache error is not very accurate in this case, and the whole thing worked after I simply put the file where it was supposed to be.

@hmoyat 2014-07-10 00:09:53

Some configuration parameters have changed in Apache 2.4. I had a similar issue when I was setting up a Zend Framework 2 application. After some research, here is the solution:

Incorrect Configuration

<VirtualHost *:80>
    ServerName zf2-tutorial.localhost
    DocumentRoot /path/to/zf2-tutorial/public
    SetEnv APPLICATION_ENV "development"
    <Directory /path/to/zf2-tutorial/public>
        DirectoryIndex index.php
        AllowOverride All
        Order allow,deny #<-- 2.2 config
        Allow from all #<-- 2.2 config

Correct Configuration

<VirtualHost *:80>
    ServerName zf2-tutorial.localhost
    DocumentRoot /path/to/zf2-tutorial/public
    SetEnv APPLICATION_ENV "development"
    <Directory /path/to/zf2-tutorial/public>
        DirectoryIndex index.php
        AllowOverride All
        Require all granted #<-- 2.4 New configuration

If you are planning to migrate from Apache 2.2 to 2.4, here is a good reference:

@Mladen Ilić 2016-08-23 08:39:18

Thanks! You answer is right on the mark!

@M. Reza Nasirloo 2014-07-18 00:56:39

After changing the configuration files don't forget to Restart All Services.

I wasted three hours of my time on it.

@dastan 2015-04-28 09:54:36

Try this and don't add anything Order allow,deny and others:

AddHandler cgi-script .cgi .py 
ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Require all granted
    Allow from all


sudo a2enmod cgi
sudo service apache2 restart

@Jerrychayan 2016-06-25 17:39:37

WORKING Method (unless there is no other problem)

By default, Apache is not restricting access from IPv4 (common external IP address)

What are restricted are the commands given in 'httpd.conf'.

Replace all

<Directory />
    AllowOverride none
    Require all denied


<Directory />
    AllowOverride none
    # Require all denied

hence removing out all restriction given to Apache.

Replace Require local with Require all granted for the C:/wamp/www/ directory.

<Directory "c:/wamp/www/">
    Options Indexes FollowSymLinks
    AllowOverride all
    Require all granted
    # Require local

@Peter Mortensen 2016-07-02 09:20:42

Is it really "<Directory />" (two instances)? Shouldn't it be "<Directory>"?

@James 2016-09-17 17:50:04

The first receives the dir path <Directory {/path/to/your/dir}>

@Programster 2016-06-08 18:17:22

I had this issue when using SSHFS to mount the files in my VirtualBox guest from my local filesystem before running a docker build. In the end, the "fix" was to copy all the files to the VirtualBox instance rather than building from inside the SSHFS mount, and then run the build from there.

@Ekene 2015-11-15 05:59:14

Remember that the correct file to be configured in this situation is not the httpd.conf in the phpMyAdmin alias, but in bin/apache/your_version/conf/httpd.conf.

Look for the following line:

DocumentRoot "c:/wamp/www/"

# Each directory to which Apache has access can be configured with respect
# to which services and features are allowed and/or disabled in that
# directory (and its subdirectories).
# First, we configure the "default" to be a very restrictive set of
# features.
<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Allow from all

Make sure it is set to Allow from all...

If not, phpMyAdmin might even work, but not your root and other folders under it. Also, remember to restart WAMP and then put online...

This solved my headache.

@RiggsFolly 2016-06-05 12:32:11

This answer is SO WRONG! You should NEVER set Allow from all or Require all granted in the <Directory /> section of httpd.conf Thats just a hackers delight

@Czar Pino 2013-02-03 10:59:48

I understand this issue is resolved but I happened to solve this same problem on my own.

The cause of

Forbidden You don't have permission to access / on this server

is actually the default configuration for an apache directory in httpd.conf.

# Each directory to which Apache has access can be configured with respect
# to which services and features are allowed and/or disabled in that
# directory (and its subdirectories). 
# First, we configure the "default" to be a very restrictive set of 
# features.  
<Directory "/">
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all          # the cause of permission denied

Simply changing Deny from all to Allow from all should solve the permission problem.

Alternatively, a better approach would be to specify individual directory permissions on virtualhost configuration.

<VirtualHost *:80>

    # Set access permission
    <Directory "/path/to/docroot">
        Allow from all


As of Apache-2.4, however, access control is done using the new module mod_authz_host (Upgrading to 2.4 from 2.2). Consequently, the new Require directive should be used.

<VirtualHost *:80>

    # Set access permission
    <Directory "/path/to/docroot">
        Require all granted


@7stud 2014-08-19 17:24:31

Apache/2.2.24 on OSX 10.6.8. 1) This post, and 2) the instructions here: (You will get a warning that the line NameVirtualHost *:80 does nothing, so you can delete it. You also have to create the directory for the logfiles.), and...

@7stud 2014-08-19 17:36:46

3) adding the line to the bottom of the file /private/etc/hosts worked for me. If you have Apache setup to listen on, say, port 8080, then use <VirtualHost *:8080>, and just as you have to use the url http://localhost:8080, you will need to use the url 4) In the end, I went with @hmoyat's <Directory> configuration(in one of the other answers) because it seems more specific.

@eagor 2015-01-18 05:40:12

after adding 'Require all granted' now instead of default apache page I see this: 'Mcrypt PHP extension required.' (it's already installed). What do I do now?

@Czar Pino 2015-01-18 06:54:07

Hi @eagor. Be sure to also enable the MCrypt extension (not just install it). That error is also more related to PHP than Apache so you'll want to try or similar threads.

@adrian4aes 2015-02-19 20:33:45

Require all granted solve my problem

@Hafiz Shehbaz Ali 2015-09-20 08:02:57

I used require all granted doesnot solve my problem. Some this error occurred. I used to change the owner using ` sudo chown www-data:www-data file`

@robson 2015-09-20 09:30:57

Please be patient with granting access to your root directory. It is unsecure. Better is to grant access to particular directory (you want to show to public).

@Czar Pino 2015-09-21 08:27:49

@shehbazali, try and They have, on some occasions, solved this issue for me as well.

@Hafiz Shehbaz Ali 2015-09-21 11:58:01

I tried both solution. I don't know why this is not working? @CzarPino can you tell me why this error happen 403? Is this only for user permission and file mode.

@theblackpearl 2016-01-19 18:50:07

I do not find 'httpd.conf' file in my root!! Using apache2 web server.

@RiggsFolly 2016-06-05 12:36:47

Do you understand what <Directory /> Allow from all </Directory> is actually doing. I guess not! That gives Apache full access to your whole filesystem. Very dangerous if your site gets hacked!!

@Czar Pino 2016-06-06 01:25:04

To those that used <Directory />, the recommended way of setting up access permission is per directory (i.e. <Directory "/path/to/docroot">). My previous example used <Directory /> which apparently grants remote host access to the entire filesystem. I am currently unaware exactly how this can be leveraged by a cracker except that providing more permissions than needed is a basic security no-no. I've updated my answer for posterity's sake. Apologies for the lacking insight on security.…

@Giles Roberts 2013-01-31 10:28:54

A common gotcha for directories hosted outside of the default /var/www/ is that the Apache user doesn't just need permissions to the directory and subdirectories where the site is being hosted. Apache requires permissions to all the directories all the way up to the root of the file system where the site is hosted. Apache automatically gets permissions assigned to /var/www/ when it's installed, so if your host directory is directly underneath that then this doesn't apply to you. Edit: Daybreaker has reported that his Apache was installed without correct access permissions to the default directory.

For example, you've got a development machine and your site's directory is:


You may think you can get away with:

chgrp -R www-data /username/home/Dropbox/myamazingsite/
chmod -R 2750 /username/home/Dropbox/myamazingsite/

because this gives Apache permissions to access your site's directory? Well that's correct but it's not sufficient. Apache requires permissions all the way up the directory tree so what you need to do is:

chgrp -R www-data /username/
chmod -R 2750 /username/

Obviously I would not recommend giving access to Apache on a production server to a complete directory structure without analysing what's in that directory structure. For production it's best to keep to the default directory or another directory structure that's just for holding web assets.

Edit2: as u/chimeraha pointed out, if you're not sure what you're doing with the permissions, it'd be best to move your site's directory out of your home directory to avoid potentially locking yourself out of your home directory.

@daybreaker 2013-03-10 01:57:32

Your answer helped out a lot. For some reason my /var/www wasnt set up for access by the apache user. Thanks!

@Craig 2013-03-28 10:50:29

I just did this and went from "Apache doesn't have permission" to "500 Internal Server Error" :(

@Giles Roberts 2013-03-28 11:17:21

@Craig That's progress. It means you've solved your initial permissions problem. Start looking through your Apache / application log files to determine what's causing the 500 error.

@seniorpreacher 2014-03-04 17:00:58

Thanks to this answer, I successfully locked out myself from the /home directory tree... :)

@anc1revv 2014-03-25 03:22:15

Doing this: chgrp -R apache /username/ fixed the problem for me! but just like Edifice, now I can't access my home directory tree unless I chgrp back to my user. So now I need to change to my original user to pull in my changes via git. Then change back to apache to redeploy my server. Is this the only way?

@Giles Roberts 2014-03-25 08:48:48

@anc1revv Is this a development machine or a production machine?

@anc1revv 2014-03-25 15:18:38

@GilesRoberts this would be on my production machine. What ended up working for me is just changing the user and group in my httpd to be my username. Is there any downfall to doing that?

@Giles Roberts 2014-03-25 15:35:13

@anc1revv Unsure. You'd have to find someone better versed in Linux security than me to answer that. Perhaps worth Googling or asking as a separate question. For me I generally don't use Git for deployment as I don't want my whole development environment replicated to the deployed site. I generally use a script or deployment tool. Just out of interest, if this is a production server, why are you outside of the normal Apache web serving directory?

@anc1revv 2014-03-25 18:03:41

@GilesRoberts I developed my django app locally, then I just pushed my project to my ec2 instance using git. And from there I wanted to deploy my app. The way django is set up, the project is typically not copied to the web serving directory. I followed this guide:

@Tebe 2014-06-24 06:49:01

chmod -R 2750 - what could mean number 2 ? 7 - rwe permissions for owner, 5 - re for group, and 0 - nothing for others. But what is 2 ? Thanks

@Giles Roberts 2014-06-24 16:35:16

@gekannt The chmod numeric format accepts up to four octal digits. The rightmost three refer to permissions for the file owner, the group, and other users. The next digit (fourth from the right) specifies special setuid, setgid, and sticky flags.

@Giles Roberts 2014-06-24 16:37:15

@gekannt But use whatever permissions you'd normally use for securing a web directory. The above permissions are only an example that fit with my personal dev environment.

@Giles Roberts 2014-06-24 16:40:08

@gekannt Some more detail on 4 digit file system permissions.

@317 2014-09-23 07:21:35

Thank you. The user directory used to host was in 700 and it didn't occur to me to check it out before reading your answer.

@TonyTony 2015-06-10 21:20:40

the upper level folder works for me when it is 755, while 750 is not working. Thanks a lot.

@chimeraha 2015-07-19 21:38:48

Before locking your home directory (LOL), I would highly recommend adding "Require all granted"

@Hafiz Shehbaz Ali 2015-09-21 11:52:51

My other website in the localhost is working. But, this project is not working. and giving 403 Error.

@Bassam Alugili 2016-06-29 16:30:21

Thanks it is very useful!

@Jeel Shah 2016-07-06 20:11:28

Does anyone know how to give the home directory back to the user?

@Vincent Polisi 2016-11-08 18:20:18

This answer resolved the problem for me when everything else was setup correctly. I was pulling my hair out and then came to find out that the /var/www directory somehow inexplicably had different permissions other than Apache. find /var/www -exec chown apache:apache {} \; And Boom! Problem solved....

@mpgn 2015-06-05 15:06:38

With Apache 2.2

Order Deny,Allow
Allow from all

With Apache 2.4

Require all granted


@crmpicco 2015-07-17 13:01:22

This is an important difference. Allow from all will not work in Apache 2.4.

@Diego B. Sousa 2015-09-19 20:02:07

Thank you @mpgn, you have helped me a lot.

@Rajveer gangwar 2019-03-06 09:55:54

This is the answer which i was searching for

@Iman Marashi 2015-06-25 18:06:56

You can change youralias.conf file like this code:

Alias /Quiz/ "h:/MyServer/Quiz/" 
 <Directory "h:/MyServer/Quiz/">
   Options Indexes FollowSymLinks
   AllowOverride all
   <IfDefine APACHE24>
     Require local
   <IfDefine !APACHE24>
    Order Deny,Allow
    Deny from all
    Allow from localhost ::1

@Adam Hollock 2015-05-11 15:59:24

I ran into this problem, and my solution was moreso that www-data didn't own the proper folders, and instead I set it for one of the users to own it. (I was trying to do a bit of fancy, but erroneous trickery to get ftp to play nicely.)

After running:

chown -R www-data:www-data /var/www/html

The machine started serving data again. You can see who currently owns the folder by means of

ls -l /var/www/html

@Rocky Inde 2014-07-21 19:35:34

On Ubuntu 14.04 using Apache 2.4, I did the following:

Add the following in the file, apache2.conf (under /etc/apache2):

<Directory /home/rocky/code/documentroot/>
  Options Indexes FollowSymLinks
  AllowOverride None
  Require all granted

and reload the server:

sudo service apache2 reload

Edit: This also works on OS X Yosemite with Apache 2.4. The all-important line is

Require all granted

@Do Nhu Vy 2014-11-26 17:06:21

If you are using CentOS with SELinux Try:

sudo restorecon -r /var/www/html

See more:

@UrielUVD 2015-05-08 20:02:31

One whole Internet for this man please, he earned it.

@Erikas 2016-07-13 14:20:44

You saved my life. I don't know why it is not pointed out somewhere else...

@Antony Fuentes Artavia 2017-08-18 14:59:37

You sir saved my day, thanks!

@Vladimir Lazarevski 2019-05-24 19:27:33

This is the most important answer on the internet

@Dan 2014-10-06 14:51:04

If you are using MAMP Pro the way to fix this is by checking the Indexes checkbox under the Hosts - Extended tab.

In MAMP Pro v3.0.3 this is what that looks like: enter image description here

@Ahmed_Ali 2016-10-09 10:36:57

thanks it worked for me.

@IonicBurger 2014-07-31 21:29:33

I had the same issue, but due to the fact that I changed the path on apache to a folder outside var/www, I started running into problems.

I fixed it by creating a symlink in var/www/html > home/dev/project which seemed to do the trick, without having to change any permissions...

@oscar.fimbres 2016-08-21 08:51:04

Thank you so much, you saved me too much work knowing this!

@oabarca 2014-06-05 16:39:06

(In Windows and Apache 2.2.x)

The "Forbidden" error is also the result of not having virtual hosts defined.

As noted by Julien, if you intend to use virtual hosts.conf, then go to the httpd file and uncomment the following line:

#Include conf/extra/httpd-vhosts.conf

Then add your virtual hosts definitions in conf/extra/httpd-vhosts.conf and restart Apache.

@Gank 2017-11-29 10:22:37

You are right!!!!!!

@Julien BRENELIERE 2013-09-18 14:46:43

Just to bring another contribution as I ran to this problem too:

I had a VirtualHost configured that I did not want to. I have commented out the line where the include for the vhost occured, and it worked.

@James 2013-08-05 15:54:00

Check exactly where you are putting your files, don't nest them in the Documents folder.

For instance I made the mistake of putting my code in the Documents folder of as mentioned this isn't going to work because Documents is explicitly only available to YOU and not APACHE. Try moving it up one directory and you may not see this issue.

Move folder from:


To here: /Users/YOURUSERNAME/code

@Antony P. 2013-03-21 05:28:34

I had the same issue for a specific controller only - which was really weird. I had a folder in the root of the CI folder that had the same name as the controller I was trying to access... Because of that, CI was directing the request to this directory instead of the controller itself.

After removing this folder (which was there a bit by mistake), it all worked fine.

To be more clear, here is what it looked like:



I had to remove /ci/register/.

@pgee70 2014-06-05 13:57:54

sometimes codeigniter uses .htaccess files to stop direct access. have a look with ls -Al to ensure there are no hidden files.

@Sonu 2013-02-27 06:53:03

If you are using a WAMP server then try this:

  • Single click on the WAMP server icon at the taskbar

  • Select the option put online

  • Your server will restart automatically

  • Then try to access your localwebsite

Related Questions

Sponsored Content

1 Answered Questions

[SOLVED] apache httpd 2.4.37 forward proxy not working

1 Answered Questions

2 Answered Questions

[SOLVED] "RewriteEngine not allowed here" .htaccess error using XAMPP

1 Answered Questions

1 Answered Questions

[SOLVED] Installing mod_wsgi module for apache

  • 2012-05-04 10:30:50
  • TomJoy
  • 9568 View
  • 4 Score
  • 1 Answer
  • Tags:   apache mod-wsgi

2 Answered Questions

[SOLVED] Cannot load module

  • 2010-06-25 23:06:23
  • Mark Striemer
  • 5846 View
  • 0 Score
  • 2 Answer
  • Tags:   apache mod-wsgi

Sponsored Content