By Naveen Prince P


2012-10-22 06:56:26 8 Comments

I am developing an app and I know my database *.db will appear in data/data/com.****.***

I can access this file from AVD in Eclipse with help of sqlite manager

But I can't access this file in my Android phone.
I google it and it says I need to root my phone to do it, but I don't want to do it. (New phone, warranty issues, and security issues)

So here is my question: How can I access my data/data/..... directory in my Android phone "without rooting it"?

Can I change user permissions for the directory data/data..... without rooting it?

18 comments

@ikhlas ahmed 2019-12-12 20:20:44

SQLlite database is store on user's Phone and it's hidding under path:

/Data/Data/com.companyname.AppName/File/

you have 2 options here:

  1. you can root your phone so that you get access to view your hidding db3 file
  2. this is not a solution but a work around. Why not just create test page that display your database table in it using 'select' statment.

@suther 2018-08-10 06:11:10

You can download a sigle file like that:

adb exec-out run-as debuggable.app.package.name cat files/file.mp4 > file.mp4

Before you download you might wan't to have a look at the file structure in your App-Directory. For this do the following steps THelper notice above:

adb shell
run-as com.your.packagename 
cd files
ls -als .

The Android-Studio way Shahidul mention (https://stackoverflow.com/a/44089388/1256697) also work. For those who don't see the DeviceFile Explorer Option in the Menu: Be sure, to open the /android-Directory in Android Studio. E.g. react-native users have this inside of their Project-Folder right on the same Level as the /ios-Directory.

@Russian 2018-06-05 23:54:54

adb backup didn't work for me, so here's what I did (Xiaomi Redmi Note 4X, Android 6.0):
1. Go to Settings > Additional Settings > Backup & reset > Local backups.
2. Tap 'Back up' on the bottom of the screen.
3. Uncheck 'System' and 'Apps' checkmarks.
4. Tap detail disclosure button on the right of the 'Apps' cell to navigate to app selection screen.
5. Select the desired app and tap OK.
6. After the backup was completed, the actual file need to be located somehow. Mine could be found at /MIUI/backup/AllBackup/_FOLDER_NAMED_AFTER_BACKUP_CREATION_DATE_.
7. Then I followed the steps from this answer by RonTLV to actually convert the backup file (.bak in my case) to tar (duplicating from the original answer):
"
a) Go here and download: https://sourceforge.net/projects/adbextractor/
b) Extract the downloaded file and navigate to folder where you extracted.
c) run this with your own file names: java -jar abe.jar unpack c:\Intel\xxx.ab c:\Intel\xxx.tar
"

@Sheraz Ahmad Khilji 2012-10-22 07:17:58

You could also try fetching the db using root explorer app. And if that does not work then you can try this:

  1. Open cmd
  2. Change your directory and go into 'Platform tools'
  3. Type 'adb shell'
  4. su
  5. Press 'Allow' on device
  6. chmod 777 /data /data/data /data/data/com.application.package /data/data/com.application.package/*
  7. Open DDMS view in Eclipse and from there open 'FileExplorer' to get your desired file

After this you should be able to browse the files on the rooted device.

@Naveen Prince P 2012-10-22 16:40:52

i think root explore app works only for rooted phones. I will try 2nd method

@bofredo 2013-08-22 15:47:03

Unable to chmod /data: Operation not permitted

@Sheraz Ahmad Khilji 2014-02-03 06:42:21

@bofredo I think its because your phone isn't rooted. you should root your phone and then try this

@Sheraz Ahmad Khilji 2014-03-24 06:05:17

@mahemadhi what do u mean sub directories ?

@Mahendran 2014-03-24 06:08:11

I have some directories inside files dir. like files>profiles files>comments . . I have to run this command for every directory? It won't work recursively?

@Sheraz Ahmad Khilji 2014-03-24 06:44:36

@mahemadhi yes you would probably have to run this command manually for every directory as all directories have permissions that are private to them.

@Vladimír 2018-02-27 14:11:38

run-as: Could not set capabilities: Operation not permitted

@Vivek Chavda 2018-04-26 20:14:42

Do both of these methods require root?

@Sheraz Ahmad Khilji 2018-05-02 15:53:55

@VivekChavda yup they require rooted phone

@live-love 2017-12-18 20:51:56

You can also try copying the file to the SD Card folder, which is a public folder, then you can copy the file to your PC where you can use sqlite to access it.

Here is some code you can use to copy the file from data/data to a public storage folder:

private void copyFile(final Context context) {
    try {
        File sd = Environment.getExternalStorageDirectory();
        File data = Environment.getDataDirectory();

        if (sd.canWrite()) {
            String currentDBPath =
                    context.getDatabasePath(DATABASE_NAME).getAbsolutePath();

            String backupDBPath = "data.db";

            File currentDB = new File(currentDBPath);
            File backupDB = new File(sd, backupDBPath);

            if (currentDB.exists()) {
                FileChannel src = new FileInputStream(currentDB).getChannel();
                FileChannel dst = new FileOutputStream(backupDB).getChannel();
                dst.transferFrom(src, 0, src.size());
                src.close();
                dst.close();
            }
        }
    } catch (Exception e) {
        e.printStackTrace();
    }
}

Manifest:

<uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" />
<uses-permission android:name="android.permission.READ_EXTERNAL_STORAGE" />
<uses-permission android:name="android.permission.WRITE_INTERNAL_STORAGE" />
<uses-permission android:name="android.permission.READ_INTERNAL_STORAGE" />

@Steve Luck 2018-03-19 09:11:21

All action for copy file is not accessible if the file doesn't share Read permission to Others

@Shahidul 2017-05-20 18:24:29

If you are using Android Studio 3.0 or later version then follow these steps.

  1. Click View > Tool Windows > Device File Explorer.
  2. Expand /data/data/[package-name] nodes.

You can only expand packages which runs in debug mode on non-rooted device.

Steps followed in Android Studio 3.0

@Mahdi Azadbar 2017-06-25 08:34:10

i cant see any thing in this dock. and say me nothing show. do you know whats the problem?

@itinance 2017-08-02 08:35:00

This works only in debug-mode, not for release-builds

@Lensflare 2018-02-20 17:03:51

Thank you for showing the no-pita way to look into the file system!

@Codingale 2018-03-21 04:11:50

I don't seem to have the option in version 3.0.1, has it moved?

@checkmate711 2018-09-12 18:40:59

this is awesome. Wish I had known this a while ago.

@SmartyP 2018-12-24 10:47:27

For those wondering, the path is usually something like: /data/user/0/[package.name]

@user3829503 2014-07-11 13:02:56

may be to access this folder you need administrative rights.

so you have two options:-

  1. root your device and than try to access this folder
  2. use emulator

p.s. : if you are using any of above two options you can access this folder by following these steps

open DDMS perspective -> your device ->(Select File Explorer from right window options) select package -> data -> data -> package name ->files

and from there you can pull up your file

@RonTLV 2017-01-04 19:44:16

To backup from Android to Desktop

Open command line cmd and run this: adb backup -f C:\Intel\xxx.ab -noapk your.app.package. Do not enter password and click on Backup my data. Make sure not to save on drive C root. You may be denied. This is why I saved on C:\Intel.

To extract the *.ab file

  1. Go here and download: https://sourceforge.net/projects/adbextractor/
  2. Extract the downloaded file and navigate to folder where you extracted.
  3. run this with your own file names: java -jar abe.jar unpack c:\Intel\xxx.ab c:\Intel\xxx.tar

@Russian 2018-06-05 23:16:48

This is a great answer, thank you. Worked for me for extracting a single-app backup created on a Xiaomi device (with .bak extension). No rooting required

@THelper 2013-07-26 08:38:41

Accessing the files directly on your phone is difficult, but you may be able to copy them to your computer where you can do anything you want with it. Without rooting you have 2 options:

  1. If the application is debuggable you can use the run-as command in adb shell

    adb shell
    run-as com.your.packagename 
    cp /data/data/com.your.packagename/
    
  2. Alternatively you can use Android's backup function.

    adb backup -noapk com.your.packagename
    

    You will now be prompted to 'unlock your device and confirm the backup operation'. It's best NOT to provide a password, otherwise it becomes more difficult to read the data. Just click on 'backup my data'. The resulting 'backup.ab' file on your computer contains all application data in android backup format. Basically it's a compressed tar file. This page explains how you can use OpenSSL's zlib command to uncompress it. You can use the adb restore backup.db command to restore the backup.

@theblang 2013-12-04 16:28:06

adb backup -f \location\on\local\drive -noapk app.package.name worked for me without root

@Hooman 2014-03-17 18:27:12

Use this command to uncompress your backup file: dd if=backup.ab bs=24 skip=1|openssl zlib -d > backup.tar

@Antony 2014-04-22 23:56:05

The 2nd option appears to not work on 4.4.2 Maybe because I did not develop the app?

@THelper 2014-04-23 06:57:59

@Antony Are you sure you replaced 'com.your.packagename' with the correct package name of the app you are trying to backup?

@Antony 2014-04-24 14:09:43

The issue actually has to do with on my end. I encrypted my phone, so I did not know I was supposed to use the same encryption key to backup. Problem solved.

@KyleCrowley 2014-07-20 20:26:06

This is actually a known bug with some system images on android 4.3+. To see if you are affected: 1. Fire up adb shell 2. ls -l on data/system 3. If the permissions on packages.list is -rw-rw----, you are affected

@Gerard 2014-09-03 04:20:03

In Option 1, how do I tell the cp command to save them to my laptop (Mac)? If you give a Win example, I'd like to know too, and will just translate it. Thanks.

@nAkhmedov 2015-03-03 13:59:25

run-as com.your.packagename command is working. says to me unknown package name

@THelper 2015-03-03 14:08:32

@nAkhmedov You have to replace com.your.packagename with the actual package name of the app you want to access. If you already did that check for typos.

@Menelaos Kotsollaris 2015-05-20 15:12:12

Important: Running adb backup -noapk com.your.packagename will save the ab file on the current directory, so make sure you have navigated in the right directory (e.g. cd Desktop..)

@Abdul Mohsin 2015-09-21 08:27:09

i am doing adb backup. but the problem is when i decompress the tar. i am getting an empty folder. no content is there :(

@matangs 2016-01-11 01:07:15

Once you have the backup file, you can use following on command line to unpack it, worked for me on mac, remove quotes "( printf "\x1f\x8b\x08\x00\x00\x00\x00\x00" ; tail -c +25 backup.ab ) | tar xfvz -"

@Pinkerton 2016-06-02 18:27:18

i dont understand what cp /data/data/com.your.pacakagename/ is doing? why are you copying something?

@Ursus 2016-06-11 21:38:09

With option 2 my backup has 41 bytes, after using Andorid Backup Extractor it produces broken tar.

@Pinkerton 2016-06-14 16:29:11

@THelper are you implying that I need to specify my target as the desktop of my computer or something (how would i do that)? Even doing that, I wouldn't expect that to do anything. In order to get files from internal storage on my computer, I had to jump through a few hoops. First I had to reference the files and make them "setReadable" in my code then I had to open another cmd prompt and use adb pull. Does using cp in a shell work for you?

@Matt__C 2016-07-27 20:12:55

To extract the backup into a .tar file you can use the instructions from here: forum.xda-developers.com/showthread.php?t=2011811

@Dan Mirescu 2018-01-21 21:07:56

Also, make sure you have a newer adb.exe. I used an old adb and it only produced an empty backup file.

@Pavel Netesa 2018-02-24 18:19:47

It really worked for me. I was able to copy .apk file on non-rooted device. The only thing I had to find out is package name. Then I copied it on flash: $ adb shell [email protected]:/ $ cp /data/app/com.nullsoft.winamp-1/base.apk /storage/9016-4EF8/_my Thanks!

@Tadas Ĺ ukys 2018-07-27 16:06:55

@THelper I think option 1 is not completely correct, you have cp to some other directory that is accessible from PC. What works for my is "cp /data/data/com.your.packagename/file.txt /sdcard/Download". Then exit run-as and shell and pull needed file to PC "pull /sdcard/Download/file.txt".

@Tom 2019-05-01 01:24:17

Note that the backup approach will yield an empty backup if your app has disabled backups via android:allowBackup="false" in the manifest.

@Dave Black 2019-09-09 23:19:26

@Hooman - can you explain what "dd" is and where I can get it for Windows?

@Hooman 2019-09-10 18:28:34

@DaveBlack, dd is a Unix tool for reading/writing from/to files or different input/output streams. I don't know of any counterpart in Windows! linux.die.net/man/1/dd

@Pete Alvin 2019-12-21 16:59:13

Running the "adb backup" command deleted my Android Simulator from Android Studio!

@Isura Amarasinghe 2014-09-11 10:44:43

  1. Open your command prompt
  2. Change directory to E:\Android\adt-bundle-windows-x86_64-20140702\adt-bundle-windows-x86_64-20140702\sdk\platform-tools
  3. Enter below commands
  4. adb -d shell
  5. run-as com.your.packagename cat databases/database.db > /sdcard/database.db
  6. Change directory to cd /sdcard to make sure database.db is there.
  7. adb pull /sdcard/database.db or simply you can copy database.db from device .

@technik 2017-04-17 17:53:43

Works perfect for me. Thanks! But in my case, the database file name has no .db extension.

@Tonio FERENER - VARI 2016-03-16 05:39:34

The question is: how-to-access-data-data-folder-in-android-device?


If android-device is Bluestacks * Root Browser APK shows data/data/..


Try to download Root Browser from https://apkpure.com/root-browser/com.jrummy.root.browserfree


If the file is a text file you need to click on "Open as", "Text file", "Open as", "RB Text Editor"

@lol2dubs 2015-10-24 23:54:07

On a rooted device, the correct solution is this:

Open cmd
Change your directory and go into 'Platform tools'
Type 'adb shell'
su
Press 'Allow' on device
chmod 777 /data /data/data /data/data/*
Open DDMS view in Eclipse/IntelliJ and from there open 'FileExplorer' to get your desired file

The original solution worked, but the chmod would return unknown directory. Changing the chmod command to /data/data/* gave access to all subfolders in the data directory from DDMS in Intellij. I assume the same solution is true for Eclipse DDMS.

UPDATE So, what I've found is strange. I'm running a Nexus 6 using DDMS in IntelliJ (Android Device Monitor). I have built a little starter app. Said app saves data to a .csv file in data/data/com.example.myapp/files

When I first started to try to access this file on my Nexus 6, I found that I have to root the device.. I could see the data folder, but trying to open it would not work. As mentioned online in other places, the expand + would vanish then reappear shortly thereafter (note, there are solutions on the web that claim to allow access to these folders without rooting, I didn't find them till too late, and I'm not sure if I prefer not to root anyway ((I'd rather be able to do it manually than rely on an app or command prompt to give me my solutions))). I rooted my 6 and tried DDMS again.

At this point, it showed me the data folder and I could expand the folder and see the com. directories, but I could not open any of them. That is when I discovered the above solution. The initial instructions would not work on this part:

chmod 777 /data /data/data /data/data/com.application.pacakage /data/data/com.application.pacakage/*

That is when I tried the solution I posted:

chmod 777 /data /data/data /data/data/*

That solution seemed to work, but only on certain folders. I now could expand my myapp folder, but could not expand the files directory in it.

At this point, I played around for a while then figured why not just try it on the directory I need rather than trying these wildcard entries.

chmod 777 /data /data/data /data/data/com.example.myapp/*

Followed by:

chmod 777 /data /data/data /data/data/com.example.myapp/files

These commands allowed me to expand and view the files in my app's directory to confirm that the .csv was being saved correctly.

Hope this helps someone. I struggled with this for hours!

(to compound on this a tad further, oddly enough, the permissions did not pass to the .csv file that passed to the files directory. my files directory permissions read drwxrwxrwx and my log.csv file permissions read -rw-rw---- .. just fyi)

@Khairul Alam Licon 2015-08-23 18:30:00

I had also the same problem once. There is no way to access directly the file within android devices except adb shell or rooting device.

Beside here are 02 alternatives:

1)

 public void exportDatabse(String databaseName)
   {
     try {
        File sd = Environment.getExternalStorageDirectory();
        File data = Environment.getDataDirectory();

        if (sd.canWrite()) {
            String currentDBPath = "//data//"+getPackageName()+"//databases//"+databaseName+"";
            String backupDBPath = "backupname.db";
            File currentDB = new File(data, currentDBPath);
            File backupDB = new File(sd, backupDBPath);

            if (currentDB.exists()) {
                FileChannel src = new FileInputStream(currentDB).getChannel();
                FileChannel dst = new FileOutputStream(backupDB).getChannel();
                dst.transferFrom(src, 0, src.size());
                src.close();
                dst.close();
            }
        }
    } catch (Exception e) {

    }
}

2) Try this: https://github.com/sanathp/DatabaseManager_For_Android

@Alex P. 2015-08-07 15:07:34

The easiest way (just one simple step) to pull a file from your debuggable application folder (let's say /data/data/package.name/databases/file) on an unrooted Android 5.0+ device is by using this command:

adb exec-out run-as package.name cat databases/file > file

@Anirudh Ramanathan 2012-10-22 07:03:47

To do any of the above (i.e. access protected folders from within your phone itself), you still need root. (That includes changing mount-permissions on the /data folder and accessing it)

Without root, accessing the /data directly to read except from within your application via code isn't possible. So you could try copying that file to sdcard or somewhere accessible, and then, you should be able to access it normally.

Rooting won't void your warranty if you have a developer device. I'm sorry, there isn't any other way AFAIK.

@Naveen Prince P 2012-10-22 16:29:43

i am not using an developers device. Mine is Xperia U

@Naveen Prince P 2012-10-22 16:37:38

can i edit user permission of data folder with chmode commands?

@Anirudh Ramanathan 2012-10-22 16:39:18

The whole partition is mounted as read-only. I'd say your best bet would be adb pull as mentioned in the below answer.

@Jan Hudec 2013-10-04 09:08:12

I is possible if the application allows it. The directories all have x permission for everybody (but no r for everybody, so you have to know the path). Than it depends on whether the application made the file world accessible or not. Some files are, most are not.

@untill 2015-06-10 12:57:46

First you say it's impossible to read, then you suggest to copy the file elsewhere. But, how to copy a file without reading it in the first place? I think this answer's buggy.

@Anirudh Ramanathan 2015-06-10 15:34:53

@until, your application can still access the fie. You can write code to copy that file out to a universally accessible location. Incidentally, that's what the accepted answer also suggests, but by a different mechanism.

@Wyatt8740 2017-12-25 21:38:56

Gonna have to return the (verizon) pixel 2 I was just given for xmas, then... and pay $300 more out of pocket for a rootable one

@Vito 2013-07-11 08:36:06

you can copy this db file to somewhere in eclipse explorer (eg:sdcard or PC),and you can use sqlite to access and update this db file .

@waqaslam 2012-10-22 07:14:56

One of the simple way is to create your database on SD-Card. Because you cannot get access to your phone's data folder in internal memory, unless you root your phone. So why not simply create your database on SD-Card.

Moreover, if you want, you may write some file copying-code to copy your existing database file (from internal memory) to external memory without requiring any root.

@Naveen Prince P 2012-10-22 16:41:48

how to do it? how can i create a db in sdcard

@waqaslam 2012-10-22 21:22:25

This method will help you to create database on sd-card. Simply provide a path of File pointing to SD-Card and you are good to go

@Nguyen Minh Binh 2012-10-22 07:05:21

Use File Explorer in eclipse. Select Windows => Show View => Other ... => File Explorer.

An another way is pull the file via adb:

adb pull /system/data/data/<yourpackagename>/databases/<databasename> /sdcard

Related Questions

Sponsored Content

102 Answered Questions

[SOLVED] Close/hide android soft keyboard

33 Answered Questions

[SOLVED] How to avoid reverse engineering of an APK file?

48 Answered Questions

[SOLVED] Is there a unique Android device ID?

31 Answered Questions

[SOLVED] How to save an activity state using save instance state?

42 Answered Questions

[SOLVED] Can't start Eclipse - Java was started but returned exit code=13

11 Answered Questions

[SOLVED] Proper use cases for Android UserManager.isUserAGoat()?

55 Answered Questions

[SOLVED] Android ADB device offline, can't issue commands

33 Answered Questions

[SOLVED] ADB Android Device Unauthorized

Sponsored Content