By Bhavesh Patadiya


2013-02-14 07:38:19 8 Comments

I want to Update my Android SDK Tool from 22.0.1 to 22.0.4

I also Have ADT installed, but could not update the SDK Tool to 22.0.4

I am facing the following issue :

Download interrupted: Read timed out issue.

Below is the screen shot while updating SDK :

enter image description here Can anyone help me :

Thanks in Advance.

EDITED : I Found the Solution For above problem and have added the Solution as an answer. If anyone has the same problem, he/she can also solve this issue as explained.

6 comments

@Ibrahim Benzer 2014-09-13 17:57:18

run Android SDK Manager as administrator. that solved my problem

sudo android

@Bhavesh Patadiya 2013-02-14 09:24:02

I viewed the Eclipse ADT documentation and found out the way to get around this issue. I was able to Update My SDK Tool to 22.0.4 (Latest Version).

Solution is: First Update ADT to 22.0.4(Latest version) and then Update SDK Tool to 22.0.4(Latest Version)

The above link says,

ADT 22.0.4 is designed for use with SDK Tools r22.0.4. If you haven't already installed SDK Tools r22.0.4 into your SDK, use the Android SDK Manager to do so

What I had to do was update my ADT to 22.0.4 (Latest Version) and then I was able to update SDK tool to 22.0.4. I thought only SDK Tool has been updated not ADT, so I was updating the SDK Tool with Older ADT Version (22.0.1).

How to Update your ADT to Latest Version

  1. In Eclipse go to Help
  2. Install New Software ---> Add
  3. inside Add Repository write the Name: ADT (or whatever you want)
  4. and Location: https://dl-ssl.google.com/android/eclipse/
  5. after loading you should get Developer Tools and NDK Plugins
  6. check both if you want to use the Native Developer Kit (NDK) in the future or check Developer Tool only
  7. click Next
  8. Finish

@steveh 2013-02-14 23:43:42

sounds like a stupid question but where should i download ADT 21.1.0 from? ok, i just found it on softpedia.com but that a pain of a site, all ads. is there no official place?

@steveh 2013-02-15 01:29:21

i just download a whole new adt from developer.android.com/sdk/index.html#download seems to be the best way

@Ajoy 2013-02-16 16:35:18

@Bhavesh That explains a lot. Thanks

@Jonathan 2013-03-25 03:31:56

Please make sure that you use the HTTPS version of the site. Do not use the built-in Android Developer Tools Update Site from eclipse (which uses HTTP). Otherwise, it will result to an error mentioned here (An error occurred while collecting items to be installed session context)

@Mustafa Alammar 2013-04-15 01:05:31

I want to second steveh's suggestion. Trying to update the Developer Tools manually breaks adt's integration. Downloading from scratch seems to work though.

@Xilconic 2013-06-02 14:35:46

I second steveh's comment. When I followed Bhavesh's steps, it broke the adt integration for me as well. Re-downloading from the android dev website works like a charm (you might have to reset the Eclipse workspace, but that's about it)

@imdadhusen 2013-07-01 12:26:02

Really great answer or findings. it is also helped me. +1

@Johan 2013-07-17 08:11:20

Thanks for this, it helped me when I got the problem today. Eclipse really is a retarded tool.

@Ogre 2013-07-24 23:50:42

Doesn't work for me. Eclipse complains that each package is already installed. If it's already installed, why doesn't it use it instead of complaining that it's not there?

@VicTorn 2014-03-20 19:18:02

I couldn't get things to work through Eclipse no matter what I tried, so on Windows ran this command first from console window, then returned to Eclipse afterwards and was finally able to update: C:\Program Files\Android\android-sdk\tools>android.bat update sdk --no-ui

@Khaled 2013-08-18 06:17:14

You may need to go to Window -> Android SDK Manager -> Packages -> Reload to fetch latest updates and then update the SDK.

@vrtis 2013-07-27 13:30:29

I'm on OSX, I was using Android Studio instead of ADT and I had this issue, my problem was being behind a proxy with authentication, for what ever reason, In Android SDK Manager Window, under Preferences -> Others, I needed to uncheck the

"Force https://... sources to be fetched using http://..."

Also, there was no place to put the proxy credentials, but it will prompt you for them.

@piratemurray 2015-10-15 11:03:18

I would urge others to try unchecking this option too as it helped me from on a mac behind a firewall. No idea why, but saves me pulling my hair out.

@Nikola Malešević 2016-11-29 21:25:51

I had to check this option to make it work.

@Jeevan 2013-05-16 12:40:54

I faced the same issue, I tried the below solution and it worked for me In Android SDK Manager Window, click on Tools->Options-> under "Others", check "Force https://... sources to be fetched using http://..."

@ihsanhf 2013-02-14 08:03:22

Have you tried this http://tools.android.com/preview-channel ? Download preview channel. After that, install ADT Preview.

@Bhavesh Patadiya 2013-02-14 09:12:28

Thanks for your Quick Reply but could not help me out.

Related Questions

Sponsored Content

51 Answered Questions

42 Answered Questions

[SOLVED] Can't start Eclipse - Java was started but returned exit code=13

42 Answered Questions

[SOLVED] Automatically accept all SDK licences

20 Answered Questions

[SOLVED] Android: remove left margin from actionbar's custom layout

45 Answered Questions

[SOLVED] Android SDK installation doesn't find JDK

11 Answered Questions

[SOLVED] Error: This Android SDK requires Android Developer Toolkit version 22.6.1 or above

6 Answered Questions

43 Answered Questions

[SOLVED] Update Eclipse with Android development tools v. 23

7 Answered Questions

[SOLVED] Libraries do not get added to APK anymore after upgrade to ADT 22

  • 2013-05-16 20:34:17
  • SimonSays
  • 70391 View
  • 236 Score
  • 7 Answer
  • Tags:   android eclipse adt

Sponsored Content