By user3638431

2014-05-14 21:02:21 8 Comments

I am installing the Wamp Server on another computer to run a mid-sized database and UI. I have been successful in blocking IIS and routing the server to Localhost:8080. But whenever I try to access on of my projects from the localhost homepage, in the www file; I get redirected to a Page not found error.

When I hover above the links the directory always comes up "http:// ProjectFolderNameHere /". when it's supposed to be "http:// LocalHost:8080 / ProjectFolderNameHere /". What can I do to get the links working properly?

My Machine runs on Windows 7 Home Edition 64-bits, and I already have Microsoft's IIS disabled.


@RiggsFolly 2014-06-02 08:50:25

How to create a Virtual Host in WampServer

WAMPServer 3 has made this process much easier!

You can do almost everything from a utility provided as part of WAMPServer.

  • Create a folder inside to contain your This can be under the C:\wamp\www\ directory or in a completely seperate folder like C:\websites.

  • Create a folder inside the location you have chosen EG C:\websites\project1\www or under the c:\wamp\www\project1\www

  • Now open localhost wampmanager->localhost and click on the link Add a Virtual Host under the TOOLS section on the homepage.

You will see a page like this:

enter image description here

  • Fill in the fields as specified by the instructions above each field

  • The Virtual Host config will have been created for you.

  • Now you must restart the DNS Cache. You can do this from the wampmanager menus like this right click wampmanager->Tools->Restart DNS. The DNS Cache will be restarted and then Apache will also be stopped and restarted. When the wampmanager icon goes green again all is completed.

  • Now you must create a simple index.php file or install your site into the folder you created above.

  • Assuming your VH was called You should see that name under the Your Virtual Hosts Section of the WAMPServer homepage.

  • You can launch the site from this menu, or just use the new Domain Name in the address bar EG and the site shoudl launch.

Old WAMPServer 2.5 mechanism, or if you want to do it all manually

There has been a change of concept in WampServer 2.5 and above and there is a good reason for this change!

In WampServer it is now STRONGLY encouraged to create a Virtual Host for each of your projects, even if you hold them in a \wamp\www\subfolder structure.

Virtual Hosts Documentation

Virtual Host Examples

The WampServer home page ( \wamp\www\index.php ) now expects you to have created a Virtual Host for all your projects and will therefore work properly only if you do so.


In order to make life easier for beginners using WampServer to learn PHP Apache and MySQL it was suggested that you create subfolders under the \wamp\www\ folder.

  |-- www
       |-- Chapter1
       |-- Chapter2
       |-- etc

These subfolders would then show as links in the WampServer Homepage under a menu called 'Your Projects' and these links would contain a link to localhost/subfoldername.

Acceptable only for simple tutorials

This made life easy for the complete beginner, and was perfectly acceptable for example for those following tutorials to learn PHP coding. However it was never intended for use when developing a real web site that you would later want to copy to your live hosted server. In fact if you did use this mechanism it often caused problems as the live sites configuration would not match your development configuration.

The Problem for real website development.

The reason for this is of course that the default DocumentRoot setting for wamp is

DocumentRoot "c:/wamp/www/"

regardless of what your subfolder was called. This ment that often used PHP code that queried the structure or your site received different information when running on your development WampServer to what it would receive when running on a live hosted server, where the DocumentRoot configuration points to the folder at the top of the website file hierarchy. This kind of code exists in many frameworks and CMS's for example WordPress and Joomla etc.

For Example

Lets say we have a project called project1 held in wamp\www\project1 and run incorrectly as localhost/project1/index.php

This is what would be reported by some of the PHP command in question:

$_SERVER['HTTP_HOST'] = localhost
$_SERVER['SERVER_NAME'] = localhost
$_SERVER['DOCUMENT_ROOT'] = c:/wamp/www

Now if we had correctly defined that site using a Virtual Host definition and ran it as http://project1 the results on the WAMPServer devlopment site will match those received when on a live hosted environment.

$_SERVER['HTTP_HOST'] = project1
$_SERVER['SERVER_NAME'] = project1
$_SERVER['DOCUMENT_ROOT'] = c:/wamp/www/project1

Now this difference may seem trivial at first but if you were to use a framework like WordPress or one of the CMS's like Joomla for example, this can and does cause problems when you move your site to a live server.

How to create a Virtual Host in WampServer

Actually this should work basically the same for any wndows Apache server, with differences only in where you may find the Apache config files.

There are 3 steps to create your first Virtual Host in Apache, and only 2 if you already have one defined.

  1. Create the Virtual Host definition(s)
  2. Add your new domain name to the HOSTS file.
  3. Uncomment the line in httpd.conf that includes the Virtual Hosts definition file.

Step 1, Create the Virtual Host definition(s)

Edit the file called httpd-hosts.conf which for WampServer lives in


(Apache version numbers may differ, engage brain before continuing)

If this is the first time you edit this file, remove the default example code, it is of no use.

I am assuming we want to create a definition for a site called project1 that lives in


Very important, first we must make sure that localhost still works so that is the first VHOST definition we will put in this file.

<VirtualHost *:80>
    DocumentRoot "c:/wamp/www"
    ServerName localhost
    ServerAlias localhost
    <Directory  "c:/wamp/www">
        Options Indexes FollowSymLinks
        AllowOverride All
        Require local

Now we define our project: and this of course you do for each of your projects as you start a new one.

<VirtualHost *:80>
    DocumentRoot "c:/wamp/www/project1"
    ServerName project1
    <Directory  "c:/wamp/www/project1">
        Options Indexes FollowSymLinks
        AllowOverride All
        Require local

NOTE: That each Virtual Host as its own DocumentRoot defined. There are also many other parameters you can add to a Virtual Hosts definition, check the Apache documentation.

Small aside

The way virtual hosts work in Apache: The first definition in this file will also be the default site, so should the domain name used in the browser not match any actually defined virtually hosted domain, making localhost the first domain in the file will therefore make it the site that is loaded if a hack attempt just uses your IP Address. So if we ensure that the Apache security for this domain is ALWAYS SET TO

Require local

any casual hack from an external address will receive an error and not get into your PC, but should you misspell a domain you will be shown the WampServer homepage, because you are on the same PC as WampServer and therfore local.

Step 2:

Add your new domain name to the HOSTS file. Now we need to add the domain name that we have used in the Virtual Host definition to the HOSTS file so that windows knows where to find it. This is similiar to creating a DNS A record, but it is only visible in this case on this specific PC.

Edit C:\windows\system32\drivers\etc\hosts

The file has no extension and should remain that way. Watch out for notepad, as it may try and add a .txt extension if you have no better editor. I suggest you download Notepad++, its free and a very good editor.

Also this is a protected file so you must edit it with administrator privileges, so launch you editor using the Run as Administrator menu option.

The hosts file should look like this when you have completed these edits localhost project1

::1 localhost
::1 project1

Note that you should have definitions in here for the IPV4 loopback address and also the IPV6 loopback address ::1 as Apache is now IPV6 aware and the browser will use either IPV4 or IPV6 or both. I have no idea how it decides which to use, but it can use either if you have the IPV6 stack turned on, and most window OS's do as of XP SP3.

Now we must tell windows to refresh its domain name cache, so launch a command window again using the Run as Administrator menu option again, and do the following.

net stop dnscache
net start dnscache

This forces windows to clear its domain name cache and reload it, in reloading it will re-read the HOSTS file so now it knows about the domain project1.

Step 3: Uncomment the line in httpd.conf that includes the Virtual Hosts definition file.

Edit your httpd.conf, use the wampmanager.exe menus to make sure you edit the correct file.

Find this line in httpd.conf

# Virtual hosts
#Include conf/extra/httpd-vhosts.conf

And just remove the # to uncomment that line.

To activate this change in you running Apache we must now stop and restart the Apache service.

wampmanager.exe -> Apache -> Service -> Restart Service

Now if the WAMP icon in the system tray does not go GREEN again, it means you have probably done something wrong in the \wamp\bin\apache\apache2.4.9\conf\extra\httpd-hosts.conf file.

If so here is a useful mechanism to find out what is wrong. It uses a feature of the Apache exe (httpd.exe) to check its config files and report errors by filename and line numbers.

Launch a command window.

cd \wamp\bin\apache\apache2.4.9\bin
httpd -t

So fix the errors and retest again until you get the output

Syntax OK

Now there is one more thing.

There are actually 2 new menu items on the wampmanager menu system. One called 'My Projects' which is turned on by default. And a second one, called 'My Virtual Hosts', which is not activated by default.

'My Projects' will list any sub directory of the \wamp\www directory and provide a link to launch the site in that sub directory. As I said earlier, it launches 'project1` and not 'localhost/project1' so to make the link work we must create a Virtual Host definition to make this link actually launch that site in your browser, without the Virtual Host definition it's likely to launch a web search for the site name as a keyword or just return a site not found condition.

The 'My Virtual Hosts' menu item is a little different. It searches the file that is used to define Virtual Hosts ( we will get to that in a minute ) and creates menu links for each ServerName parameter it finds and creates a menu item for each one. This may seem a little confusing as once we create a Virtual Host definition for the sub directories of the \wamp\www folder some items will appear on both of the 'My Projects' menu and the 'My Virtual Hosts' menu's.

How do I turn this other 'My Virtual Hosts' menu on?

  • Make a backup of the \wamp\wampmanager.tpl file, just in case you make a mistake, its a very important file.
  • Edit the \wamp\wampmanager.tpl
  • Find this parameter ;WAMPPROJECTSUBMENU, its in the '[Menu.Left]' section.
  • Add this new parameter ;WAMPVHOSTSUBMENU either before or after the ;WAMPPROJECTSUBMENU parameter.
  • Save the file.
  • Now right click the wampmanager icon, and select 'Refresh'. If this does not add the menu, 'exit' and restart wampmanager.

Big Note The new menu will only appear if you already have some Virtual Hosts defined! Otherwise you will see no difference until you define a VHOST.

Now if you take this to its logical extension

You can now move your web site code completely outside the \wamp\ folder structure simply by changing the DocumentRoot parameter in the VHOST definition. So for example you could do this:

Create a folder on the wamp disk or any other disk ( beware of network drive, they are a bit more complicated)

MD websites
CD websites
MD www

You now copy your site code to, or start creating it in the \websites\\www folder and define your VHOST like this:

<VirtualHost *:80>
    DocumentRoot "d:/websites/"
    <Directory  "d:/websites/">
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted

    php_flag display_errors Off
    php_flag log_errors On

    php_value max_upload_size 40M
    php_value max_execution_time 60
    php_value error_log "d:/wamp/logs/example_com_phperror.log"

Then add this new development domain to the HOSTS file: localhost
::1 localhost project1
::1 project1

NOTE: It is not a good idea to use a ServerName or ServerAlias that is the same as your live domain name, as if we had used as the ServerName it would mean we could no longer get to the real live site from this PC as it would direct to i.e. this PC and not out onto the internet.

ALSO: See that I have allowed this site to be accessed from the internet from within the VHOST definitions, this change will apply to only this site and no other. Very useful for allowing a client to view your changes for an hour or so without having to copy them to the live server. This does mean that we have to edit this file manually to turn this access on and off rather than use the Put Online/Offline menu item on wampmanager.

Also I have added some modifications to the PHP config, again that will only apply to this one site. Very useful when maintaining a site with specific requirement unlike all the other sites you maintain. I guess we can assume from the parameters used that it has a long running page in it somewhere and it is very badly written and will not run with errors being displayed on the browser without making a horrible mess of the page. Believe me sites like this exist and people still want them maintained badly. But this mean we only have to change these parameters for this specific site and not globally to all Virtual sites running on WampServer.

@Chris 2014-12-01 18:21:45

Hugely helpful. This really should be the accepted answer. Very informative and if followed properly, will have you up and running in about 10 minutes. Great advice. One quick point though. I got a .htaccess: Invalid command 'RewriteEngine' error. I had to tick rewrite_module under the Apache Modules menu. Could someone answer why I had to do this?

@RiggsFolly 2014-12-04 12:41:16

@Chris Apache's rewrite_module is the code that actually provides the rewrite engine. Without it apache does not know how to do url rewriting. Basicaly its not part of the core of apache but a addon for want of a better description

@bcsteeve 2015-06-29 21:45:53

"Edit the file called httpd-hosts.conf which for WampServer lives in \wamp\bin\apache\apache2.4.9\conf\extra\httpd-hosts.conf" In my fresh install of wampserver 2.5, this file does not exist. If you meant httpd-vhosts.conf, please correct.

@RiggsFolly 2015-06-29 22:12:48

@bcsteeve Thanks for that

@SunfiShie 2015-07-17 19:46:01

Wow - great help for us newb php'ers (and WAMP'ers) -thanks!

@Khadka Pushpendra 2015-08-10 05:25:38

@RiggsFolly thanks for you complete solution,

@Khadka Pushpendra 2015-08-10 06:45:49

Can you please teach how to run such host from local server? I have 3 computers in my home, previously i used to call them with ip or computer name (xena-pc/project1) from next computer now how to call vhosts??

@RiggsFolly 2015-08-10 23:40:11

@KhadkaPushpendra Ask this as another question

@user3733831 2015-10-27 03:36:44

You may probably need Options Indexes FollowSymLinks within directory code when you are trying to setup virtual host outside from `\wamp` folder structure.

@RiggsFolly 2015-10-27 09:27:02

@user3733831 Good point, I have added that to the post. Thanks

@user3733831 2015-10-28 08:21:10

@RiggsFolly, What is the reason to use code below the <Directory "d:/websites/"> when we setup virtual hosts outside from \wamp folder structure. I mean this code of blocks php_flag display_errors Off php_flag log_errors On php_value max_upload_size 40M php_value max_execution_time 60 php_value error_log "d:/wamp/logs/example_com_phperror.log"

@RiggsFolly 2015-10-28 09:03:08

@user3733831 That is a way of setting PHP parameters specifically for this Virtual Host. For example, you may have an old app or a badly written app and want to turn off on screen error reporting, or an app that requires the max_execution_time to be increased. These changes will only effect this one Virtual Host instance. Making these changes in PHP.INI would effect all VH's this way it does not.

@starleaf1 2016-02-19 08:28:05

Now I wish the next version of WampServer would include a "new project" feature that would automate all of this.

@RiggsFolly 2016-02-19 09:09:52

@starleaf1 You wish is our command! Run localhost/add_vhost.php on WAMPServer 3, check out this post on WAMPServers Forum

@Das 2016-08-24 03:00:44

Thanks for this! A lot of great information! Having come back to WAMP I completely forgot about the System Host file. Thanks again!

@Thomas Williams 2016-08-27 18:23:16

Thanks for the information and I can see why a virtual host might be useful, but I have a folder for a website and inside that I have many versions numbered of the same website as I make changes. So adding a virtual host for everyone of these would be impossible to do.

@Radmation 2016-11-19 19:29:52

Thanks alot for this! I am starting work on a new web project and they require all work be done locally. With the Virtual Hosts is place - I can create many projects all configured differently! YOU ARE AWESOME!!

@Atara 2017-05-23 11:40:47

note: project/folder name cannot contain underline sign ("_"), it may contain minus sign "-".

@Arnaud Leyder 2017-02-08 14:39:10

This works on Wamp 3+.

  • Go to wamp folder (wamp/ or wamp64/)
  • Open wampmanager.conf
  • Find urlAddLocalhost param and set it on: urlAddLocalhost = "on"

There should not be the need to tweak the index.php in www folder.

@Rakesh 2016-09-07 20:51:29

In order to access project from the homepage you need to create a Virtual Host first.

Most easiest way to do this is to use Wamp's Add a Virtual Host Utility.

Just follow these steps:

  1. Create a folder inside "C:\wamp\www\" directory and give it a name that you want to give to your site for eg. 'mysite'. So the path would be "C:\wamp\www\mysite".
  2. Now open localhost's homepage in your browser, under Tools menu click on Add a Virtual Host link.
  3. Enter the name of the virtual host, that name must be the name of the folder we created inside www directory i.e. 'mysite'.
  4. Enter absolute path of the virtual host i.e. "C:\wamp\www\mysite\" without quotes and click the button below saying 'Start the creation of the VirtualHost'.
  5. Virtual Host created, now you just need to 'Restart DNS'. To do this right click the wamp server's tray menu icon, click on Tools > Restart DNS and let the tray menu icon become green again.
  6. All set! Now just create 'index.php' page inside "C:\wamp\www\mysite\" directory. Add some code in 'index.php' file, like
    <?php echo "<h1>Hello World</h1>"; ?>

Now you can access the projects from the localhost's homepage. Just click the project link and you'll see 'Hello World' printed on your screen.

@Nmaster88 2016-09-27 16:50:46

I think this should be the accepted awnser because i had the same problem and it worked!

@Junaid 2016-12-06 08:24:04

this one is latest and perfect and worked for me . thanks . some of the above answers are lengthy and obsolete.

@rolo 2017-04-19 00:08:30

This should be the current accepted answer as of 4/18/2017. Worked perfectly for me.

@SuN 2016-05-31 11:25:02

I find it's a lot easier (than accepted answer) to create a local subdomain by project and tell Apache to serve multiple sites by name.

For example, let's say you created a project under c:/wamp64/www/sites/mysite, to be able to access it at http://mysite.localhost you simply need to do the following:

1. Tell your machine to answer to different names Add mysite.localhost to C:\windows\system32\drivers\etc\hosts

2. Flush your DNS cache Open a Command Prompt as administrator and type net stop dnscache, then net start dnscache.

3. Tell Apache where to look Click on Wamp's icon in tray, go to Apache -> httpd.conf, and add this at the end:

# Tells Apache to identify which site by name
NameVirtualHost *:80
# Tells Apache to serve the default WAMP Server page to "localhost"
ServerName localhost
DocumentRoot "C:/wamp/www"
# Tells Apache to serve Client 1's pages to "client1.localhost"
# Duplicate and modify this block to add another client
# The name to respond to
ServerName client1.localhost
# Folder where the files live
DocumentRoot "C:/wamp64/www/sites/mysite"
# A few helpful settings...
<Directory "C:/wamp64/www/sites/mysite">
allow from all
order allow,deny
# Enables .htaccess files for this site
AllowOverride All
# Apache will look for these two files, in this order, if no file is specified in the URL
DirectoryIndex index.html index.php


4. Restart Apache Click on Wamp's icon in tray, select "restart"

5. Define a base url Go to your project folder, add <base href="http://mysite.localhost" /> to your <head> section to prevent /links to server root from being broken.

Personally, I inject this html code dynamically into my template using PHP (something like $site_root = (IS_LOCALHOST) ? '<base href="http://mysite.localhost" />' : null;) so I don't have to bother removing that once on production.

@Khadka Pushpendra 2015-08-10 05:38:42

You can follow all steps by @RiggsFolly thats is really good answer, If you do not want to create virtual host and want to use like previous localhost/example/ or something like that you can use answer by @Arunu

But if you still face problem please use this method,

  1. Locate your wamp folder (Eg. c:/Wamp/) where you have installed
  2. Goto Wamp/www/
  3. Open index.php file
  4. find this code $projectContents .= '<li><a href="'.($suppress_localhost ? 'http://' : '').$file.'">'.$file.'</a></li>';
  5. modify it add localhost after http:// $projectContents .= '<li><a href="'.($suppress_localhost ? 'http://localhost' : '').$file.'">'.$file.'</a></li>';
  6. Restart wamp server
  7. open localhost see the updated links

Hope you got your url like previous version of wamp server.

@vimal krishna 2016-07-09 11:16:17

@Khadak, this is simple solution and it works!.

@Sushivam 2016-09-23 14:10:28

Could you please suggest on hoe we do it for xampp . i tried all ways , still my site redirects to xampp homepage

@Samoei 2015-07-14 09:01:43

Navigate to your www directory (if you are using wamp server) htdocs (if on XAMPP). Open your admin.php and search on project contents/ or just go directly to line number 339 and change the link, inserting 'local host to the link .

That should work ,,

@Raman verma 2015-07-09 05:25:40

  1. check wamp server icon is green or not if it is green then it is working if not then you have to follow these steps to do

    a. all the programs should be closed before running the wamp because most of the cases some softwares like skype takes the same port (80) which is using by wamp.

    b. you can change the port of skype : Tool-s->oprions->advanced->connection untick use port 80

  2. restart the wamp it will work.


  1. when you click on the project in loalhost it does not show the localhost infront of the project name and because of that it looks like wamp is not working then you have to one thing on only

    . go to wamp index.php file and change $suppress_localhost = false; from $suppress_localhost = true; or try vice versa it will work

@Raman verma 2015-04-01 04:07:53

Hello you need to open the index.php from the wamp server and change $suppress_localhost = false; from $suppress_localhost = true; then your wamp will working fine

@Vael Victus 2015-04-23 21:27:59

There are plenty of answers that say exactly this.

@Raman verma 2015-07-21 06:16:40

yes and those works as well...

@Vael Victus 2015-07-22 18:38:12

Then you have contributed nothing.

@hyp0xia 2015-01-13 19:12:27

How To Fix The Broken Icon Links (blank.gif, text.gif, etc.)

Unfortunately as previously mentioned, simply adding a virtual host to your project doesn't fix the broken icon links.

The Problem:

WAMP/Apache does not change the directory reference for the icons to your respective installation directory. It is statically set to "c:/Apache24/icons" and 99.9% of users Apache installation does not reside here. Especially with WAMP.

The Fix:

  1. Find your Apache icons directory! Typically it will be located here: "c:/wamp/bin/apache/apache2.4.9/icons". However your mileage may vary depending on your installation and if your Apache version is different, then your path will be different as well.\

  2. Open up httpd-autoindex.conf in your favorite editor. This file can usually be found here: "C:\wamp\bin\apache\apache2.4.9\conf\extra\httpd-autoindex.conf". Again, if your Apache version is different, then so will this path.

  3. Find this definition (usually located near the top of the file):

    Alias /icons/ "c:/Apache24/icons/"
    <Directory "c:/Apache24/icons">
    Options Indexes MultiViews
    AllowOverride None
    Require all granted
  4. Replace the "c:/Apache24/icons/" directories with your own. IMPORTANT You MUST have a trailing forward slash in the first directory reference. The second directory reference must have no trailing slash. Your results should look similar to this. Again, your directory may differ:

    Alias /icons/ "c:/wamp/bin/apache/apache2.4.9/icons/"
    <Directory "c:/wamp/bin/apache/apache2.4.9/icons">
    Options Indexes MultiViews
    AllowOverride None
    Require all granted
  5. Restart your Apache server and enjoy your cool icons!

@RiggsFolly 2016-04-02 12:29:48

A better more general solution is to change the Alias to Alias /icons/ "icons/" in versions prior to WAMPServer 3. In WAMPServer 3 and above this is the default and no change is required.

@Arunu 2014-06-10 06:46:21

Open index.php in www folder and set

$suppress_localhost = false;

This will prepend http://localhost/ to your project links

@Ahmed Faizan 2017-02-13 03:26:47

Update: There is a new way to do this. here:

@Valtec 2014-09-07 14:39:03

$suppress_localhost = false;

This did the trick for me.

@Xawery Wiƛniowiecki 2017-03-20 20:01:00

WAMP 2.5 - works for me also. Thanks

@TheSteven 2014-06-29 10:23:30

Re: Wampserver LocalHost links not working correctly
This is as of June 2014 with Wampserver2.5 (maybe they'll fix this in later builds).
Note: to use LocalHost:8080 instead of LocalHost just make the appropriate changes in the edits mentioned below.

There are 2 aspects of this issue -
The first is to be able to access items under "Your Projects" from the Wamp localhost homepage.
The second is to be able to correctly access items listed in the Wampserver Icon Taskbar's "My Projects" list.

To fix the first (to be able to access items under "Your Projects" from the Wamp localhost homepage) you will need to do the following...

There are 2 edits that you must make in the index.php file located in your wamp\www folder (usually C:\wamp\www)

1) on Line 30 change

  $suppress_localhost = true;


  $suppress_localhost = false;

2) on line 338 change

  $projectContents .= '<li><a href="'.($suppress_localhost ? 'http://' : '').$file.'">'.$file.'</a></li>';


  $projectContents .= '<li><a href="'.($suppress_localhost ? 'http://' : 'http://localhost//').$file.'">'.$file.'</a></li>';

After you've made the above edits - if the Wampserver is running just refresh the local host page and the changes become immediately effective.

To fix the 2nd item (the Wampserver Icon Taskbar's "My Projects" list): You need to edit C:\wamp\scripts\refresh.php

Locate line 651 and change the section of the line that reads

   Parameters: "http://'.$projectContents[$i].'/"; Glyph: 5


   Parameters: "http://localhost//'.$projectContents[$i].'/"; Glyph: 5

After you make these 2nd set of changes you may have to force Wampserver to refresh the "My Projects" list by toggling the Put Online/Offline option at the bottom of the Wamp Icon Tray App.

@Cammy 2015-01-21 09:34:11

Awesome dude, finally something that works! (for going round iis jacking port 80 making a site work from the wamp localhost page)

@Hussain 2014-06-17 10:15:24

I believe this is the best solution:

Open index.php in www folder and set

change line 30:$suppress_localhost = true;

to $suppress_localhost = false;

This will ensure the project is prefixed with your local host IP/name

@Shubham Badal 2014-11-08 09:38:56

thanks! solved problem but icons/images of /icons path not showing blank.git, back.gif, folder.gif shows not found. any solution for this too?

@RiggsFolly 2014-11-26 10:48:52

Yes, create a virtual Host for each site, see answer above for how to.

@Nadhir Titaouine 2017-01-31 04:45:38

thanks, it works

@RiggsFolly 2017-06-06 17:00:23

There is now (WAMPSERVER 3) a simple menu option on wampmanager to do this if you really dont understand what a bad idea it is. right click wampmanager->Wamp Settings->Add localhost to url The only good thing about this is you can then turn it off again easily when you realise what a bad idea it was in the first place!

Related Questions

Sponsored Content

7 Answered Questions

[SOLVED] How does PHP 'foreach' actually work?

0 Answered Questions

Not able to open projects on wamp server

  • 2018-09-22 14:01:12
  • Devendra
  • 15 View
  • 0 Score
  • 0 Answer
  • Tags:   wamp wampserver

0 Answered Questions

WAMP folder path

  • 2018-05-20 19:20:12
  • Jack Mc
  • 21 View
  • 0 Score
  • 0 Answer
  • Tags:   wamp wampserver

4 Answered Questions

[SOLVED] My CodeIgniter project not running on WAMP server

0 Answered Questions

WAMP Virtual Host Not Working with Personal Project

  • 2016-06-06 12:23:38
  • faisal abdulai
  • 866 View
  • 0 Score
  • 0 Answer
  • Tags:   apache wamp

4 Answered Questions

[SOLVED] Link in "Your Projects" isn't working in WAMP server

2 Answered Questions

[SOLVED] set up virtual host in wamp server to run multiple website

1 Answered Questions

WAMP is opening index; localhost disappeared

  • 2013-09-21 17:40:50
  • Red Zambala
  • 3703 View
  • 1 Score
  • 1 Answer
  • Tags:   wamp

2 Answered Questions

[SOLVED] localhost doesn't open in WAMP

1 Answered Questions

Setting up projects in WAMP

Sponsored Content