By Maven


2014-06-08 08:10:27 8 Comments

I am getting this error while on of my .Net application are trying to make a connection to oracle database.

The error says that This problem will occur when running in 64 bit mode with the 32 bit Oracle client components installed.. But I have made sure many times that the client installed in x64 bit not 32.

Date Time: 6/8/2014 10:57:55 AM: System.InvalidOperationException: Attempt to load Oracle client libraries threw BadImageFormatException.  This problem will occur when running in 64 bit mode with the 32 bit Oracle client components installed. ---> System.BadImageFormatException: An attempt was made to load a program with an incorrect format. (Exception from HRESULT: 0x8007000B)
       at System.Data.Common.UnsafeNativeMethods.OCILobCopy2(IntPtr svchp, IntPtr errhp, IntPtr dst_locp, IntPtr src_locp, UInt64 amount, UInt64 dst_offset, UInt64 src_offset)
       at System.Data.OracleClient.OCI.DetermineClientVersion()
       --- End of inner exception stack trace ---
       at System.Data.OracleClient.OCI.DetermineClientVersion()
       at System.Data.OracleClient.OracleInternalConnection.OpenOnLocalTransaction(String userName, String password, String serverName, Boolean integratedSecurity, Boolean unicode, Boolean omitOracleConnectionName)
       at System.Data.OracleClient.OracleInternalConnection..ctor(OracleConnectionString connectionOptions)
       at System.Data.OracleClient.OracleConnectionFactory.CreateConnection(DbConnectionOptions options, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionFactory.CreatePooledConnection(DbConnection owningConnection, DbConnectionPool pool, DbConnectionOptions options)
       at System.Data.ProviderBase.DbConnectionPool.CreateObject(DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionPool.UserCreateRequest(DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionPool.GetConnection(DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
       at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
       at System.Data.OracleClient.OracleConnection.Open()
       at CustomizedSetupInstaller.Runscripts.InitializeDBObjects(String connectionString, String dbProvider)

18 comments

@Mykola Boyko 2019-02-14 10:22:02

I had this error in my DNN application installed on Windows 2012 R2. It's using some 32 bit dll and only Oracle.DataAccess.dll x32 was working. My solution is:

  1. Uninstall old Oracle Client \ ODAC.
  2. Install Oracle 11 Client x32.
  3. Install Oracle ODAC 12 x64.
  4. Check IIS Application Pool (Classic version) has option "Enable 32-Bit Applications" = true.

@Ratnesh Sahu 2018-10-10 14:26:30

I was also getting the same error I checked it my system was in 64 bit and I was using oracle.DataAccess of 32 bit version I added correct 64 version now it got resolved below path for the ref of Oracle.DataAccess.dll

Correct path for 64 bit OS- C:\Oracle\11g_64\product\11.2.0\client_64\odp.net\bin\4\Oracle.DataAccess.dll

Correct path for 32 bit OS- C:\Oracle\11g_32\product\11.2.0\client_64\odp.net\bin\4\Oracle.DataAccess.dll

@Wernfried Domscheit 2014-06-09 12:15:34

One solution is to install both x86 (32-bit) and x64 Oracle Clients on your machine, then it does not matter on which architecture your application is running.

Here an instruction to install x86 and x64 Oracle client on one machine:

Assumptions: Oracle Home is called OraClient11g_home1, Client Version is 11gR2

  • Optionally remove any installed Oracle client (see How to uninstall / completely remove Oracle 11g (client)? if you face problems)

  • Download and install Oracle x86 Client, for example into C:\Oracle\11.2\Client_x86

  • Download and install Oracle x64 Client into different folder, for example to C:\Oracle\11.2\Client_x64

  • Open command line tool, go to folder %WINDIR%\System32, typically C:\Windows\System32 and create a symbolic link ora112 to folder C:\Oracle\11.2\Client_x64 (see commands section below)

  • Change to folder %WINDIR%\SysWOW64, typically C:\Windows\SysWOW64 and create a symbolic link ora112 to folder C:\Oracle\11.2\Client_x86, (see below)

  • Modify the PATH environment variable, replace all entries like C:\Oracle\11.2\Client_x86 and C:\Oracle\11.2\Client_x64 by C:\Windows\System32\ora112, respective their \bin subfolder. Note: C:\Windows\SysWOW64\ora112 must not be in PATH environment.

  • If needed set your ORACLE_HOME environment variable to C:\Windows\System32\ora112

  • Open your Registry Editor. Set Registry value HKLM\Software\ORACLE\KEY_OraClient11g_home1\ORACLE_HOME to C:\Windows\System32\ora112

  • Set Registry value HKLM\Software\Wow6432Node\ORACLE\KEY_OraClient11g_home1\ORACLE_HOME to C:\Windows\System32\ora112 (not C:\Windows\SysWOW64\ora112)

  • You are done! Now you can use x86 and x64 Oracle client seamless together, i.e. an x86 application will load the x86 libraries, an x64 application loads the x64 libraries without any further modification on your system.

  • Probably it is a wise option to set your TNS_ADMIN environment variable (resp. TNS_ADMIN entries in Registry) to a common location, for example TNS_ADMIN=C:\Oracle\Common\network.

Commands to create symbolic links:

cd C:\Windows\System32 mklink /d ora112 C:\Oracle\11.2\Client_x64 cd C:\Windows\SysWOW64 mklink /d ora112 C:\Oracle\11.2\Client_x86

Notes:

Both symbolic links must have the same name, e.g. ora112.

Despite of their names folder C:\Windows\System32 contains the x64 libraries, whereas C:\Windows\SysWOW64 contains the x86 (32-bit) libraries. Don't be confused.

@sliderhouserules 2014-10-23 20:29:36

When running the Oracle Client installer, it asks you for a path for the Oracle Base, and one for the Oracle Home. In your instructions here, would you just tack on "OraClient11g_home1" to each of the paths you specify? So Oracle Base would be "C:\Oracle\11.2\Client_x86" and Software Location (Oracle Home) would be "C:\Oracle\11.2\Client_x86\OraClient11g_home1"?

@Wernfried Domscheit 2014-10-24 05:49:04

OraClient11g_home1 is the "Oracle Home Name" which is used to identify correct key in your registry, see How Home Selector Works. In earlier Oracle versions you had an "Oracle Home Selector" application where you can switch between different Oracle Clients installed on one machine. It is not mandatory to have the Oracle Home Name equal to your folder name where Oracle is installed. Oracle Base "C:\Oracle\11.2\Client_x86" and Software Location "C:\Oracle\11.2\Client_x86\OraClient11g_home1" works fine.

@sliderhouserules 2014-10-24 19:17:45

Ah, I see... the Instant Client only asks you for one path: the Software Location, i.e. the Oracle Home. So all of your paths above are the Oracle Home. If you choose any of the other three install types (Administrator, Runtime, Custom) it makes you choose a path for both Oracle Base and Oracle Home. If I choose "C:\Oracle\11.2\Client_x86\OraClient11g_home1" for my Oracle Home, then I need to use that path in place of your paths above...

@Andrew Grothe 2015-02-04 15:31:31

This is very helpful. Is the 64bit xCopy package good enough or is the full 64bit client needed? I can't seem to find a download for it besides the instaclient, but I don't have the 32bit instaclient installed, rather the full client.

@b_levitt 2015-02-17 12:49:51

what is the point of the symbolic links or modifying the registry? When left alone, the provider will find the unmanaged libraries by the path IT sets in the registry.

@Wernfried Domscheit 2015-02-17 13:16:51

@agrothe, this guideline applies for any type of installation, no matter if "Instant Client", "Full", "Administrator", etc. It can be even mixed, e.g. 64-bit Full Client, 32-bit Instant Client only.

@Wernfried Domscheit 2015-02-17 13:31:14

@b_levitt, please read this to get an understanding: How Windows 64-bit Supports 32-bit Applications. The 64-bit provider searches for Oracle binaries in %WINDIR%\System32\ora112\bin which points to C:\Oracle\11.2\Client_x64\bin whereas a 32-bit provider searches in %WINDIR%\SysWOW64\ora112\bin which points to C:\Oracle\11.2\Client_x86\bin. You cannot put folders directly to PATH, because (depending on order) a 64-bit provider may search first C:\Oracle\11.2\Client_x86\bin and would fail.

@b_levitt 2015-02-17 18:39:18

@Wernfried, I understand all that. What I think you are missing is that the system path is the LAST thing the oracle provider uses to find it's unmanaged dlls (see Search Order for Unmanaged DLLs in: docs.oracle.com/database/121/ODPNT/InstallODP.htm ). Side by side installation works fine without modifying the path, changing the registry, or creating symbolic links. Is your solution exclusive to the deprecated System.Data.OracleClient?

@Wernfried Domscheit 2015-02-17 19:30:07

@b_levitt, it applies to anything which uses Oracle Client binaries, include System.Data.OracleClient and ODBC drivers. The issue is this: Oracle.DataAccess.dll itself loads further Oracle dll's (e.g. oci.dll or oranls11.dll, etc) and those dll's are searched in folders listed in PATH Environment (plus current directory). So, depending whether you run 64 or 32 bit application, Oracle.DataAccess.dll has to search different folders. This is achieved by the symbolic links.

@Wernfried Domscheit 2015-02-18 08:14:35

@b_levitt, I made some tests on my machine. Using c:\oracle\product\11.2\Client_x64;c:\oracle\product\11.2\Cli‌​ent_x64\bin directly in PATH worked for ODP.NET(x86) but some OLEBD(x86) and ODBC(x86) drivers failed. Without the symbolic links all failed if architecture does not match, i.e. ODP.NET, OLEDB and ODBC - no matter whether I use the Microsoft drivers (which are deprecated apart from ODBC) or the Oracle drivers.

@b_levitt 2015-02-18 15:35:12

I should clarify my last comment. In the context of a .net app connecting with the oracle provider with somebody that's obviously new to connecting to oracle, I guess I'm wondering why you would go thru all this as opposed to just setting dllpath in the .config file? In the end I'll just post my own answer, but since you have the accepted answer I wanted to show the discussion.

@QSS 2017-11-22 07:14:04

I developed desktop application using C#.net with 2.0 framework along with system.data.oracleclient for connecting oracle db and I was facing similar error message ,"Attempt to load Oracle client libraries threw BadImageFormatException. This problem will occur when running in 64 bit mode with the 32 bit Oracle client components installed."

following solutions were applied

  • Project, properties, Build TAB, select platform target : x86
  • Project, clean build, ReBuild solution
  • Install Oracle 11G*32 bit client

now, it work because application is set for 32bit and oracle 32bit client installed over Win2012 R2 server, hopefully will work for you.

@Raghu 2017-09-08 07:25:21

Please download the correct version of Oracle Client like Oracle Client 11.2 32-Bit; which resolved the problem for me.

@vladimir 2017-07-17 14:19:21

Make sure that registry HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\ODP.NET\4.112.# DIIPath key is pointing to 32 bit Oarcle client BIN directory. For example, DIIPath value can be C:\app\User_name\11.2.0\client_32bit\bin

@Amir Tofighi 2017-05-25 19:42:57

I had the same issue on a Windows 10 PC. I copied the project from my old computer to the new one, both 64 bits, and I installed the Oracle Client 64 bit on the new machine. I got the same error message, but after trying many solutions to no effect, what actually worked for me was this: In your Visual Studio (mine is 2017) go to Tools > Options > Projects and Solutions > Web Projects

On that page, check the option that says: Use the 64 bit version of IIS Express for Websites and Projects

@Sreekumar P 2018-03-25 03:46:54

This worked for me as well. By default IIS express will be running in 32 bit mode in VS.

@Vikas 2017-03-04 00:59:54

Mine is the console application (it should work for the windows application as well) and I had same problem. To solve it I used PlatformTarget as x64 as my System.Data.OracleClient.dll (64 bit file) is at C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework.NETFramework\v4.5. This will explicitly use 64 bit version of Oracle Client. This might help you if your solution works only on 64bit and if you are not using 32 bit dlls like dlls made in VB. I hope it will help you.

@gcr 2016-05-01 11:19:09

I had the same problem in SSIS 2008. I tried to connect to an Oracle 11g using ODAC 12c 32 bit. Tried to install ODAC 12c 64 bit as well. SSIS was actually able to preview the table but when trying to run the package it was giving this error message. Nothing helped. Switched to VS 2013, now it was running in debug mode but got the same error when the running the package using dtexec /f filename. Then I found this page: http://sqlmag.com/comment/reply/17881.

To make it short it says: (if the page is still there just go to the page and follow the instrucrtions...) 1) Download and install the latest version of odac 64 bit xcopy from oracle site. 2) Download and install the latest version of odac 32 bit xcopy from oracle site. How? open a cmd shell AS AN ADMINSTARTOR and run: c:\64bitODACLocation> install.bat oledb c:\odac\odac64. the first parameter is the component you want to install. The second param is where to install to. install the 32 version as well like this: c:\32bitODACLocation> install.bat oledb c:\odac\odac32. 3) Change the path of the system to include c:\odac\odac32; c:\odac\odac32\bin; c:\odac\odac64;c:\odac\odac64\bin IN THIS ORDER. 4) Restart the machine. 5) make sure you have the same tnsnames.ora in both odac32\admin\network and odac64\admin\network folders (or at least the same entry for your connection). 6) Now open up SSIS in visual studio (I used the free 2013 version with the ssis package) - Use OLEDB and then select the Oracle Provider for OLE DB provider as your connection type. Set the name of the entry in your tnsnames.ora as the "server or file name". Username is your schema name (db name) and password is the password for schema. you are done!

Again, you can find the very detailed solution and much more in the original site.

This was the only thing which worked for me and did not mess up my environment.

Cheers! gcr

@Martijn Pieters 2016-05-01 14:03:57

Please describe (in your own words) what the instructions told you to do. The page you link to could easily disappear, and then we are all still none the wiser as to how to solve this error.

@theozdemir 2016-03-10 14:48:40

this solution work for me ,

To revise IIS

Select Application Pools.
Clic in ASP .NET V4.0 Classic.
Select Advanced Settings.
In General, option Enable 32-Bit Applications, default is false. Select TRUE.
Refresh and check site.

Comment:

Platform: Windows Server 2012 Standart- 64Bit - IIS 8

@user3559374 2016-01-15 00:37:23

I got this issue for a console Application. In my case i just changed the Platform Target to "Any CPU" which you can see when you right click your solution and click on properties , you will find a Tab "Build" click on it you will see "Platform target:" change it to "Any CPU", which will solve your issue

@javier maffla 2015-10-05 14:52:56

To revise IIS

  1. Select Application Pools.
  2. Clic in ASP .NET V4.0 Classic.
  3. Select Advanced Settings.
  4. In General, option Enable 32-Bit Applications, default is false. Select TRUE.
  5. Refresh and check site.

Comment:

Platform: Windows Server 2008 R2 Enterprise - 64Bit - IIS 7.5

@Arno 2015-09-30 14:14:02

Just build your code in x86 mode not in AnyCpu.

@Pascal 2015-09-02 14:50:05

I would like to add a resolution that worked for me. Setup: Oracle 11g 64 bits running on Windows 2008 R2 (64 bits OS)

Client is a .net framework 3.5 application (ported from 2.0) compiled with x86 platform setting.

I had the exact same issue of BadImageFormatException. Compiling to 64 bits eliminates the exception but it was not an option for me as my app is using 32 bits activex components who do not work in 64 bits.

I solved the issue by downloading Oracle Instant Client 11 (this is just a bunch of DLL than can be xcopied) from Oracle website, and copying the files in my application files directory. See here : http://www.oracle.com/technetwork/database/features/oci/instant-client-wp-131479.pdf

This has solved the issue, from ProcMon tool I can see that the locally copied oci.dll gets loaded by System.Data.OracleClient and everything is fine.

It could probably be done by changing environment settings like proposed above, but this method has the advantage of not altering any settings on the server configuration.

@b_levitt 2015-02-18 17:09:28

As it was pointed out in the comments, System.Data.OracleClient is deprecated. There is little reason to start using it so late in the game.

Also as pointed out in the comments (I've marked this as community wiki in observence), there is now a managed provider as part of the 12c and later versions of the odp.net package. This provider does NOT require any unmanaged dlls so this should be a non issue in that case.

If you would prefer to use the old unmanaged Oracle.DataAccess provider from oracle, the simplest solution is to set the "DllPath" configuration variable:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
  <oracle.dataaccess.client>
    <add key="DllPath"            value="C:\oracle\bin"/>
  </oracle.dataaccess.client>
</configuration>

See "Search Order for Unmanaged DLLs" in http://docs.oracle.com/database/121/ODPNT/InstallODP.htm for more information

@sliderhouserules 2015-09-04 21:05:40

An update here, since VS2015 and Oracle 12cR3 are out... if you want to install both the 32-bit and 64-bit clients, download both ODAC packages (took me a while to find them, but just search for e.g. "oracle 64 bit odac" etc.). Install each of them to an Oracle Base path of "C:\Oracle\12.1.0.2.1\" and then for the Software Location add "\Client_x86" (or x64) onto that path. Everything that b_levitt has said then applies. Both versions are fully configured and 32-bit apps will use the 32-bit driver, and 64-bit apps will use the 64-bit driver. Easy-peasy.

@sliderhouserules 2015-09-04 21:06:52

Oh, and as of 2015-09-04 Oracle still hasn't released the Oracle Developer Tools for Visual Studio 2015. They promised to have it released within one month of VS2015 RTM, but it's well past that and still a no-show. :(

@Tomás 2014-09-30 09:50:17

As apc mentioned that error occurs "when a 32bit dll calls a 64bit dll or vice versa". The problem is that if you have build using AnyCPU and are running on a 64bit environment then the application will run as 64bit. If rebuilding explicitly for 32 and 64 bit is not an option then you could use a microsoft utility called corflags.exe which comes with the Windows SDK. Basically, you can modify a flag in the exe of the program you are executing to tell it to run as 32bit even if the environment is 64bit.

See here for information on using it

@DavidRR 2014-09-29 20:17:10

In my situation, the Oracle 11.2 32-bit client was installed on my 64-bit Windows 2008 R2 OS.

My solution: In the Advanced Settings for the Application Pool assigned to my ASP.NET application, I set Enable 32-Bit Applications to True.

Please see below for the standalone .ashx test script that I used to test the ability to connect to Oracle. Before making the Application Pool change, its response was:

[Running as 64-bit] Connection failed.

...and after the Application Pool change:

[Running as 32-bit] Connection succeeded.

TestOracle.ashx – Script to Test an Oracle Connection via System.Data.OracleClient:

To use: Change the user, password and host variables as appropriate.

Note that this script can be used in a standalone fashion without disturbing your ASP.NET web application project file. Just drop it in your application folder.

<%@ WebHandler Language="C#" Class="Handler1" %>
<%@ Assembly Name="System.Data.OracleClient, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" %>

using System;
using System.Data.OracleClient;
using System.Web;

public class Handler1 : IHttpHandler
{
    private static readonly string m_User = "USER";
    private static readonly string m_Password = "PASSWORD";
    private static readonly string m_Host = "HOST";

    public void ProcessRequest(HttpContext context)
    {
        context.Response.ContentType = "text/plain";

        string result = TestOracleConnection();
        context.Response.Write(result);
    }

    public bool IsReusable
    {
        get { return false; }
    }

    private string TestOracleConnection()
    {
        string result = IntPtr.Size == 8 ?
            "[Running as 64-bit]" : "[Running as 32-bit]";

        try
        {
            string connString = String.Format(
              "Data Source={0};Password={1};User ID={2};",
              m_Host, m_User, m_Password);

            OracleConnection oradb = new OracleConnection();
            oradb.ConnectionString = connString;
            oradb.Open();
            oradb.Close();
            result += " Connection succeeded.";
        }
        catch
        {
            result += " Connection failed.";
        }

        return result;
    }
}

@apc 2014-06-09 08:12:10

BadImageFormatException occures when a 32bit (x86) dll calls a 64bit dll or vice versa. If using AnyCPU for your entry executable then when run on a 64bit machine it will run as 64bit, however if that then calls a 32bit dll you get the exception which is why AnyCPU isn't always the answer.

I tend to build everything as 32bit (x86) as we still have to interface with some old components done in VB6 (32bit (x86)). While performance might be better for 64bit machines if we where to build in AnyCPU reliability is more important for us.

I would suggest trying to build all you components in 32bit (x86), unless you are doing some really intensive stuff I doubt it will make much difference.

Related Questions

Sponsored Content

0 Answered Questions

OCIEnvCreate failed with return code -1 but error message text was not available

0 Answered Questions

1 Answered Questions

1 Answered Questions

Use ASP.Net insert command to apply on an ORACLE database table

  • 2015-06-20 05:08:37
  • TDL
  • 529 View
  • 0 Score
  • 1 Answer
  • Tags:   asp.net oracle

1 Answered Questions

[SOLVED] NHibernate - SafeHandle Cannot be Null

1 Answered Questions

Connecting to .sdf

2 Answered Questions

[SOLVED] OLEDB Debugging

1 Answered Questions

Unable to open connection using oledb for csv file

  • 2011-12-28 07:20:32
  • Woolgather
  • 1634 View
  • 3 Score
  • 1 Answer
  • Tags:   c# asp.net .net csv

1 Answered Questions

Sponsored Content