By Mark wealse


2015-03-19 02:25:18 8 Comments

I tried to run my Hello World application in Android Studio. I got the following error:

Emulator: ERROR: x86 emulation currently requires hardware acceleration!

Please ensure Intel HAXM is properly installed and usable.

CPU acceleration status: HAX kernel module is not installed!

Can you tell me what I can do with the error?

24 comments

@Junaed 2019-12-14 19:08:06

I already had HAXM installed, but it was an older version. Then I updated from SDK manager, then emulator worked!

@Daniil Shevelev 2015-07-16 15:29:18

As per this response, the complete steps are:

1) Open SDK Manager (In Android Studio, go to Tools > Android > SDK Manager) and Download Intel x86 Emulator Accelerator (HAXM installer) if you haven't.

Intel x86 Emulator Accelerator (HAXM installer)

2) Now go to your SDK directory C:\users\%USERNAME%\AppData\Local\Android\sdk\extras\intel\Hardware_Accelerated_Execution_Manager\ and run the file named intelhaxm-android.exe.

In case you get an error like "Intel virtualization technology (vt,vt-x) is not enabled". Go to your BIOS settings and enable Hardware Virtualization.

3) Restart Android Studio and then try to start the AVD again.

It might take a minute or 2 to show the emulator window.

@Maksim Dmitriev 2016-04-25 11:47:55

Installation of Intel HAXM consists of two steps. First, you need to download it using SDK manager. Then you need to run intelhaxm-android.exe to install Intel HAXM. The reason I'm writing this comment is that I downloaded HAXM, and the error dialog continued showing up until I ran intelhaxm-android.exe

@Vijay Nandwana 2016-05-08 05:58:35

If you don't find Android under Local folder, then download intelhaxm-andriod.exe directly from software.intel.com/en-us/android/articles/…

@Sold Out 2016-07-13 21:32:58

Is there a good reason why the bottom right button on SDK manager says "Install packages" and yet it does not install HAXM - just download ? I'd like to learn what reason could be behind.

@Periata Breatta 2016-09-04 14:56:05

@Peter - I believe the reasoning is that the SDK manager is designed to run as a regular user but installing HAXM requires admin access. It should, however, have a popup message when it has downloaded HAXM telling you what you need to do to get it working.

@Sold Out 2016-09-05 07:23:51

@PeriataBreatta Thank you - good and quite obvious guess :) If you are rignt, may it become an improvement point for google team..

@vida 2017-02-22 06:59:25

Is this possible using command line? I am having this issue in a remote jenkins.

@Caltor 2018-07-17 10:12:46

My SDK directory is C:\Program Files (x86)\Android\android-sdk\extras\intel\Hardware_Accelerated_‌​Execution_Manager

@M.suleman Khan 2018-07-29 05:42:15

I tTRIED these steps Intel HAXM and intelhaxm-android.exe both were already installed but still showing this error: ERROR: x86 emulation currently requires hardware acceleration!

@Vignesh Paramasivam 2019-01-24 06:22:50

On executing the exe, first I did remove/ unistall, and then rerun to install it. Worked now!

@technoman23 2019-04-30 19:35:23

A more detailed answer for dummies like me:

  1. Open the SDK manager open sdk
  2. Select the SDK Tools tab. SDK tools tab
  3. Download – Make sure that intel x86 Emulator Accelerator (HAXM) is downloaded. haxm download
  4. Install – Now that HAXM is downloaded, make sure it is installed. In the SDK window it will show you where the SDK is located on your computer: get SDK location Click/tap 3 times quickly to highlight this text and copy the folder location. Open the file explorer and paste in the file location. From here you can search “hax” to find the folder location for HAXM stuff. Once a file comes up in the search results, right click and select “open file location”. For me the location was C:\Users\Datu1\AppData\Local\Android\Sdk\extras\intel\Hardware_Accelerated_Execution_Manager . Find the file intelhaxm-android.exe and open/run it. haxm-android.exe file Follow the instructions when it runs. You may wish to run haxm_check as an administrator (it’s in this same folder), but it may or may not work for you. The surefire way to tell if you can run hardware acceleration and if it’s enabled is to go to your computer’s bios settings from the startup menu.
  5. BIOS settings – Make sure hardware acceleration is enabled in your BIOS settings. The way to do this may vary a bit from system to system. You may need to press f10 or esc on startup. But with most (updated) Windows 10 computers you can access the BIOS settings by doing the following: type “advanced startup” in the Windows search bar; click on “change advanced startup uptions:” when it comes up. Click “Restart now”. After your computer restarts click on Troubleshoot. Troubleshoot Windows startup Click advanced options >firmware settings, then restart to change EUFI firmware settings. Wait for the restart then select the menu option for bios settings. With Intel processors the steps will be as follows or similar: Press the right arrow to go to the Configuration tab. Arrow down to Intel Virtual/Virtualizaion Technology and turn it on (should say Enabled). Enable virtualization in bios Exit and save changes.

  6. If Virtual Technology was previously disabled in your bios settings You will need to run the intelhaxm-android.exe file now to install haxm.

  7. Try restarting Android Studio and running your emulator again. If it’s still not working, restart your computer and try again, it should work.

NOTE: if you have Windows Hyper-V turned on this will cause you to not be able to run haxm. If you are having an issue with Hyper-V, make sure it is turned off in your settings: search in the Windows bar for “hyper”; the search result should take you to “Turn Windows features on or off”. Then make sure all the Hyper-V boxes are unchecked.
disable hyper-v

@Tejas Katakdhond 2019-04-21 09:51:05

For me the following solution worked:

1] Going to BIOS setting and enabling Virtualization.

enter image description here

@Emen 2019-04-16 13:22:18

For those who still have problems with this, you can try using an alternative Android emulator such as Genymotion.

I'm using Ryzen 5 processor with latest Windows 10 update installed (1809), but still can't install HAXM. So, what I did to resolve this was:

  1. Enable Hardware Virtualization in BIOS settings
  2. Enable Hypervisor Platform in Windows Feature
  3. Install Genymotion with Virtual Box -- select for personal use
  4. Install Genymotion Android Studio plugin -- find this in Android Studio plugins settings

You're good to go from here.

cpu screenshot

@Jibin 2019-03-27 05:10:08

Enable virtualization Technology

This is worked in my case

Restart Computer Continuously press Esc and then F10 to enter BIOS setup configuration Check Virtualization technology

My PC is HP Zbook 1. Boot the unit to BIOS (Reboot the unit and keep tapping on F10).

  1. Navigate to Advanced>Device or System Configuration> Click on the check box Virtualization Technology (VTx) and Virtualization Technology for Directed I/O (VTd)

  2. Save changes and Exit.

@Krishan Liyanaarachchi 2019-03-22 04:28:15

I had the same issue even when hardware acceleration installed. My solutions was uninstalling and reinstalling it using SDK Manager. Make sure you restart the Android studio after then.

@JanLeeYu 2019-03-07 13:16:31

Windows Users Only

This is a bit late but just figured that some answers are to go to the bios settings but for me, I was able to resolve this by just disabling the hyper-v feature. We do this by following these steps:

enter image description here

@Cevin Ways 2019-02-08 09:40:18

You should install the intel hardware acceleration first on sdk manager than you can start to create your virtual device on AVD manager

@Lakshay Sharma 2019-02-07 03:45:53

Open Android SDK manager,"intelhaxm-86 emulator" install that

@codegidi 2019-01-23 13:48:04

I experienced the same issue, but after turning off Hyper-V and enabling VT-x on my BIOS I still couldn't install the intelhaxm-android.exe program.

To fix my issue I had to turn off Windows defender Memory integrity

enter image description here

check here for steps -> https://github.com/intel/haxm/issues/105

@Sam Patirage 2018-11-17 09:12:27

I had the same issue. In my case I found two issues causing the problem

  1. I had Hyper-V running, I think if any Virtualization programs running you need to uninstall
  2. I was running under Standard Account / Not Administrator

@user8276908 2018-08-31 12:37:19

I was able to resolve my problem of the missing acceleration with the following workflow on Windows 10, Lenovo, Intel Core i7 CPU:

Changed to the HAXM setup folder: C:\Users\\AppData\Local\Android\Sdk\extras\intel\Hardware_Accelerated_Execution_Manager

Opened a cmd (MS-DOS) shell Window and executed haxm_check.exe to check whether CPU supports HAXM - it outputs in my case:

VT support -- yes
NX support -- yes

So, I knew this most be a setup problem. So, I started the setup program intelhaxm-android.exe in the same folder with Admin account and removed the installed components. After that, I've attempted to re-install with the same setup program and got this output:

HAXM Supported but not turned on So, I went into the CPU section of the BIOS and turned on acceleration/Virtualization - went back to the setup program and re-ran it, this time I was pleased to see this output:

enter image description here

After that, I restarted Android Studio and used Tools>AVD Manager to define a new image for an emulator. I was then able to see the emulator starting up succesfully by clicking the play button in the list of emulators in the AVD Manager's list:

enter image description here

or by - Opening a sample project that compiles OK - using File > Sync Project with Gradle Files (to build all artifacts) - Select the app item in the Android (TW) and click Run > Run 'app' - Select the previously configured Emaulator showed me this :-)

Hope this helps to troubleshoot others with their problems that are really caused by a bad setup implementation since the missing acceleration option was silently swallowed by the Android Studio setup program ... :-(

enter image description here

@Stephen McCormick 2018-12-18 22:52:50

Thx. This helped me get the Emulator running, but now I can't get the App to install on my chosen device.

@Juozas 2018-09-11 07:19:22

One more possible reason: you installed HAXM and then updated BIOS settings by disabling virtualization. Or, updated BIOS version. Please check BIOS settings again, and be sure virtualization enabled.

@Peter Cordes 2018-09-11 07:23:52

How is this different from the multiple other answers that mention BIOS settings? This isn't another possible reason, it's the same one again.

@Juozas 2018-09-11 07:39:14

Please keep attention on mentioned specific case: BIOS settings updated/reset after successful HAXM install and usage. F.e. by other users using machine or BIOS update. Many of us knows about BIOS settings was, and looks for problems in another places. I failed in same way.

@Serguei Fedorov 2018-08-12 02:55:48

If you are using an AMD CPU, AMD Virtualization (CPUs such as Ryzen) is now officially supported. Make sure you have virtualization switched on in the BIOS.

In "Turn Windows Features On or Off" (you can find it through Windows Search), you'll need to enable

Once you restart and start up the emulator (an x86 build), it should start booting up without the mentioned error.

@XP1 2018-08-25 20:28:26

Is this support retroactive or only Ryzen and newer?

@XP1 2018-08-25 21:46:06

I could not find the Windows Hypervisor Platform setting, but I figured it out. In order to enable Windows Hypervisor Platform, you must install Windows 10 17134.1 (1803) April 2018 update or newer. It should work on AMD older than Ryzen.

@reVerse 2018-12-29 09:44:43

One thing worth mentioning: Sometimes you can't enable Hyper-V right away because it is disabled via the BIOS settings of your mainboard. Unfortunately it's called differently in the BIOS settings depending on your manufacturer.

@Isuru Nuwanthilaka 2018-08-04 17:16:08

In the android sdk manager it says that it has hardware accelerator already installed but I think it is only downloaded not installed.I just manually installed the intelhaxm-android.exe and it worked for me.

plus I had docker installed , there were some answers to disable Hyper-V features, therefore I did that too, but not sure whether it helped or not.

@M.suleman Khan 2018-07-29 07:23:43

I solved this Issue by enabling virtualization technology from system Settings.

Just followed these steps

  • Restart my Computer
  • Continuously press Esc and then F10 to enter BIOS setup
  • configuration
  • Check Virtualization technology

Your system settings may be changed According to your Computer. You can google (how to enable virtualizatino for YOUR_PC_NAME).

I hope it helps.

@binaryfunt 2018-09-10 16:09:06

This thread has some potentially useful info: github.com/intel/haxm/issues/77#issuecomment-405943152

@Joonsoo 2018-06-06 14:23:24

If you recently installed Docker on Windows OS, you need to turn off the Hyper-V feature. See the top answer of VT Not Supported when Installing HAXM

@KompjoeFriek 2015-03-19 02:30:44

Install the Intel x86 Emulator Accelerator using the Android SDK Manager

Android SDK Manager

If you have Android Studio installed, you can start the SDK manager via Tools -> Android -> SDK Manager.

The Android SDK Manager does not actually install HAXM, it just downloads it. In the top of the Android SDK manager window, you can find where the installer is located on your PC. Please open the subfolder extras\intel\Hardware_Accelerated_Execution_Manager, and run the installer manually: intelhaxm-android.exe.

To use the intel HAXM, you need to have a CPU with virtualization support:

Before attempting to use this type of acceleration, you should first determine if your development system’s CPU supports one of the following virtualization extensions technologies:

  • Intel Virtualization Technology (VT, VT-x, vmx) extensions
  • AMD Virtualization (AMD-V, SVM) extensions (only supported for Linux)

If your CPU does not have virtualization support, you could use an ARM emulator instead:

You can edit an existing, or add a new Virtual Device in the Android Virtual device Manager, and change CPU/ABI to ARM. If that option is not available, you may need to change the target API of the Virtual Device, or download an ARM system image for the API version you want using the Android SDK manager.

@Mark wealse 2015-03-19 02:40:32

Hi, Thank you so much for your quickly response! Do you think I have got Android SDK Manager? If, I install the Intel x86 Emulator Accelerator, will this change something in my computer?

@KompjoeFriek 2015-03-19 03:05:02

You should be able to access the SDK manager from Android studio: lirent.net/wp-content/uploads/2013/12/… What do you mean with: will this change something in my computer

@Mark wealse 2015-03-19 03:06:55

Hi, I have found my Android SDK Manager and the Intel x86 Emulator Accelerator (HAXM installer) was installed

@KompjoeFriek 2015-03-19 03:09:12

Ok, that probably means ShiDoiSi is right. To verify this, please check what kind of CPU you have and post the name and type number here.

@Mark wealse 2015-03-19 03:17:57

I am so sorry, how can I find what kind of CPU I have and what is the name and type number?

@KompjoeFriek 2015-03-19 03:25:25

That is hard to say without knowing what Operating System you use (Like: Windows, or OSX). You could use software like this to help: cpuid.com/softwares/cpu-z.html The name we are looking for is something like: Intel I5 4460 or AMD FX 6300

@Mark wealse 2015-03-19 03:42:47

Hi, I have just found: Processor: Intel(R) Core(TM)2 Duo CPU E4400 @ 2.00GHz 2.00 GHz System type: 32-bit Operating Sytem

@Mark wealse 2015-03-19 03:45:28

And my system is Windows Vista Home Premium

@KompjoeFriek 2015-03-19 19:14:36

I happen to have a CPU with the same feature set (E8400). The Android SDK Manager did not actually install HAXM on my machine, just downloaded it. In the top of the Android SDK manager window, you can find where it is located on your PC. Please open the subfolder extras\intel\Hardware_Accelerated_Execution_Manager, and run the installer manually: intelhaxm-android.exe. I got the x86 emulator running after that.

@Mark wealse 2015-03-20 21:46:03

Hi thanks a lot, When try to install as you suggested, I got information: VT not supported This computer does not support Intel Virtualization Thchnologe (VT-x). HAXM cannot be installed. Please refer to the Intel HAXM documentation for more information.

@KompjoeFriek 2015-03-20 22:14:23

For reference, this is the feature specification of your CPU: ark.intel.com/products/29753/… I'm sorry, but that means you cannot run and Android x86 emulator on that machine. However, you could use the Android ARM emulator instead, i think that one does not require VT-x

@Mark wealse 2015-03-20 22:57:47

OK, I agree that my computer is not good enough to run the Android x86 emulator. Can you tell me how can I use the Android ARM emulator instead?

@KompjoeFriek 2015-03-21 03:16:30

You can edit an existing, or add a new Virtual Device in the Android Virtual device Manager, and set it to use the ARM cpu: i61.tinypic.com/2vwa8fk.jpg If that option is not available, you may need to change the target API of the Virtual Device, or download an ARM system image for the API version you want using the Android SDK manager.

@Periata Breatta 2016-09-04 14:58:24

@KompjoeFriek - you should edit your answer to include the information that you need to run the installer after downloading it. It really isn't clear from any of the information in the SDK manager's user interface that this extra step is required.

@Li3ro 2019-02-09 07:31:30

Missed your very important comment: (only supported for Linux) 1 hour wasted :(

@oabarca 2016-07-08 20:40:12

On Mac, the Android SDK gets installed at: /Users/username/Library/Android/sdk/, therefore, you will need to run the script as sudo, as follows:

sudo sh /Users/username/Library/Android/sdk/extras/intel/Hardware_Accelerated_Execution_Manager/silent_install.sh

If all goes well, the script prints the message: "Silent installation Pass!"

Then, restart Android Studio and run your app with the desired AVD.

@Devstr 2018-05-24 15:24:33

And if you get "HAXM silent installation only support mac OS X from 10.8 to 10.10 !", see stackoverflow.com/questions/32924736/…

@Rahul Sonone 2016-02-01 17:30:35

Simple Solution :

Open Android SDK manager, on top side you can see the "Android SDK Location" go to that location and follow this path

\extras\intel\Hardware_Accelerated_Execution_Manager

here you will get "intelhaxm-android.exe" install this setup.

@Joseph 2015-10-23 17:33:51

I wasted too much time on this, I find that the AVAST is the issue!!! If you have AVAST installed in you system, you have to:

Go to settings tab --> troubleshooting, then you should UNCHECK the "enable hardware-assisted virtualization"

Restart your PC, the install the intelhaxm-android.exe if it is not installed. You can find it:

C:\Users\{YOURUSERNAME}\AppData\Local\Android\sdk\extras\intel\Hardware_Accelerated_Execution_Manager

@Sold Out 2016-07-22 14:19:22

I don't see such item "enable hardware-assisted virtualization" there.. Could it be they removed it - in the mean time ?

@Eduardo Viccari 2015-09-29 11:05:52

This steps worked on Mint 17.2 Rafaela:

  1. Open a terminal and input this: sudo apt-get install qemu-kvm
  2. Restart your pc and enable virtualization technology on your BIOS setup
  3. In terminal again, insert this: sudo kvm-ok

@codecats 2015-03-19 05:54:17

Right click on your my computer icon and the CPU will be listed on the properties page. Or open device manager and look at the CPU. It must be an Intel processor that supports VT and NX bit (XD) - you can check your CPU # at http://ark.intel.com
Also make sure hyperV off bcdedit /set hypervisorlaunchtype off
XD bit is on bcdedit /set nx AlwaysOn
Use the installer from https://software.intel.com/en-us/android/articles/intel-hardware-accelerated-execution-manager
If you're using Avast, disable "Enable hardware-assisted virtualization" under: Settings > Troubleshooting. Restart the PC and try to run the HAXM installation again

@CandleCoder 2015-12-15 09:26:41

Better ans with 0 complications :)

Related Questions

Sponsored Content

1 Answered Questions

19 Answered Questions

[SOLVED] Error in launching AVD with AMD processor

  • 2014-10-14 08:03:28
  • Jitesh Gaikwad
  • 850561 View
  • 676 Score
  • 19 Answer
  • Tags:   android intel avd haxm

1 Answered Questions

how to fix emulator error : x86 emulation?

  • 2015-11-12 08:08:34
  • zeineb
  • 209 View
  • 1 Score
  • 1 Answer
  • Tags:   android

2 Answered Questions

[SOLVED] Will Android studio HAXM support for this PC specification?

1 Answered Questions

2 Answered Questions

[SOLVED] Emulator in android studio not working..it shows this error..What should i do?

  • 2015-01-11 03:41:10
  • Disha Bhatnagar
  • 342 View
  • 1 Score
  • 2 Answer
  • Tags:   android

Sponsored Content