By fathurzero


2015-09-11 08:43:32 8 Comments

Why is it that every time I create a new project in Android Studio, it always comes up with:

Error:(23, 17) Failed to resolve: junit:junit:4.12?

When I remove testCompile 'junit:junit:4.12' in dependencies it is not a problem anymore.

build.gradle

apply plugin: 'com.android.application'

android {
    compileSdkVersion 23
    buildToolsVersion "23.0.1"

    defaultConfig {
        applicationId "com.okedroid.myapplication"
        minSdkVersion 17
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'
    compile 'com.android.support:appcompat-v7:23.0.1'
}

30 comments

@mehmet veysel Yağcı 2019-01-23 21:21:03

Before:

testImplementation 'junit:junit:4.12'
androidTestImplementation 'com.android.support.test:runner:1.0.2'
androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'

After:

testİmplementation 'junit:junit:4.12' 
androidTestİmplementation 'com.android.support.test:runner:1.0.2' 
androidTestİmplementation 'com.android.support.test.espresso:espresso-core:3.0.2'  

Worked for me.

@Project 2019-02-19 20:33:26

The two code blocks are identical. Please fix this to what you meant it to be.

@garritfra 2018-02-13 12:33:14

This answer might be a bit late, but after spending a few hours working through the answers nothing worked for me. After reading the error log patiently i realized that android studio tried to use a cached version of JUnit with a wrong hash code. The solution to this was to delete the C:\Android\caches\modules-2 directory and restart the build.

Hope this helps!

@Elliot ChingLee 2019-03-21 10:14:41

I believe your given path is different to others since it is C:\Android..., can you tell what is that path actually? for example installation path? SDK path? JDK path? Project path?

@Fityan Aula 2017-10-29 12:55:56

In my case, it's just because internet connection. Maybe some proxy or wifi firewall or other things which is probably disturb the connection (Because when I visit the link manually here chrome said the file may harm your computer). So I tried using another connection such tethering hotspot from my phone.

@Arthur Zakharov 2016-09-13 08:28:04

Look through for many answers but nothing works. Fortunately had found the easy solution. No need to comment junit4.12 or delete it. The problem is here:

- androidTestCompile files('libs/junit-4.12.jar')

This part shows us the path to look for the file in the library in your's project. No idea why but for some reason by the default it is empty. In my case the path is:

C:\Users\arzakhar\AndroidStudioProjects\MyApp\app\libs

Sure you can delete this line in code build.grandle(Module.app) but you may need it later. Here is the solution:

1 - download junit-4.12.jar or copy it from you Android Studio folder, normally it should be there. In my case, it was here:

C:\Program Files\Android\Android Studio\lib

to the directory mentioned above(to your project)

2 - delete & add

here you should re-enter the root to your junit-4.12.jar

3 - rebuild

4 - work hard

@Catluc 2016-04-16 15:33:36

  1. Be sure you are not behind a proxy!
  2. If you configured your Android Strudio to work with proxy be sure to disable that option under the Android Studio preferences
  3. Go to gradle.properties under Android view in Android Studio and delete all proxy configuration
  4. Sync your gradle now
  5. Enjoy coding!

@Anton Vaysberg 2017-10-02 13:13:37

In my case the solution was to add

repositories {
    mavenCentral()
}

to module-level build-gradle inside buildTypes{ }

Suppose that without it AndroidStudio can't download junit from maven.

@jafarmlp 2016-06-06 15:19:05

It happens because HTTPS is blocked by Proxy. Try to change from default jcenter (which uses HTTPS) into HTTP.

Before

repositories {
     jcenter()
}

After

repositories {
    jcenter {
        //Default one is HTTPS
        url "http://jcenter.bintray.com/"
    }
}

Repeat the above step for allprojects.

allprojects {
  repositories {
    jcenter {
        url "http://jcenter.bintray.com/"
    }
  }
}

@Diti 2016-06-21 14:55:31

Doesn't work when proxied, HTTP traffic works, and HTTPS traffic is forbidden.

@jafarmlp 2016-06-22 09:01:51

Hmm.. This is what I tried to explain in my post. By default it uses HTTPS which is blocked. See Before and After

@amin 2017-06-29 18:19:04

You should to address Java to windows.

  1. Open this address: 'control panel\system and security\system'
  2. From left side choose 'Advanced system settings'
  3. In the advanced tab, choose 'Environment Variables'
  4. In opened window, below "system variables", choose 'New'.
  5. Set variable name to JAVA_HOME, and the variable value to the address you installed Java. For example, for me it is C:\ProgramFiles\Java\jdk1.8.0_66. After that, click the okay button.
  6. Restart Android Studio

@Mandi Eaton 2017-06-28 19:28:38

If none of these answers for you, try clearing the Android Studio cache/restart. That was the only thing that worked for me:

From the file menu option, I selected "invalidate caches/restart".

https://teamtreehouse.com/community/gradle-project-sync-failed-7

@Shrinivasa manjithaya 2017-03-04 08:23:42

I had same problem, but when I open my project with an Internet connection on,i got everything cleared when the gradle build a syncing it automatically downloaded the relevant files and the J Unit plugin is required for testing

@Umair 2016-12-30 05:09:07

If any one get error "failed-to-resolve-junitjunit4-12" then go to HTTP PRoxy setting check your internet connection. if you are using any proxy server at school / college then set your proxy setting and test connect if it successful then apply setting and run again gradle you will get resolve all error. I try this and i resolve all errors. Note : no need to remove Junit....!! Umair

@Gaurav 2015-10-29 11:32:09

add repository in your build.gradle file

repositories {
    maven { url 'http://repo1.maven.org/maven2' }
}

@Boshra N 2016-11-22 18:20:33

In my case was it was very wired! Besides adding a correct proxy (I'm working within a company), I needed to add the other two libraries in the dependencies:

compile 'com.android.support:appcompat-v7:25.0.1'
compile 'com.android.support:design:25.0.1'

then the error for "junit:junit:4.12" was resolved. Make sure that all of the dependencies in build.gradle match what you import in project structure

@user7123375 2016-11-06 19:19:18

Change repository to mavenCentral() except jcenter() everything will be Ok

@Naveed Jamali 2015-10-03 18:11:07

Just remove the "testCompile 'junit:junit:4.12'" from build.gradle file:

dependencies {
compile fileTree(dir: 'libs', include: ['*.jar'])
testCompile 'junit:junit:4.12'//remove this line and sync again... worked for me

androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
    exclude group: 'com.android.support', module: 'support-annotations'}) //if available, also delete these two lines

compile 'com.android.support:appcompat-v7:23.0.1'
 }

worked for me and I am Happy! :)

Remember that this is not the actual answer of this question. I mentioned this because it works when you remove above lines.

@mrmailperson 2016-10-31 09:59:15

I would love to suggest the solution, which perfects suitable for my situation:

  • at first, make sure add

    repositories {
        maven { url 'http://repo1.maven.org/maven2' }
    }
    

    to project-level build.gradle file inside the buildscript {} block

  • then add

    allprojects {
        repositories {
            maven { url 'http://repo1.maven.org/maven2' }
        }
    

    to project-level build.gradle file

  • the next point is adding

    repositories {
        jcenter()
        mavenCentral()
    }
    

    to module-level build-gradle inside buildTypes{ }

@Roy Selim 2016-10-24 08:08:39

When you are not behind a company firewall, using the Android Studio will resolve that issue naturally. But if you are behind a company firewall, this problem will occur. So downloading the files will be a workaround. On your own home network, updating Android Studio will resolve the issue and will ask you to delete those files that you have manually created. Just press OK as it is safe to remove them.

@Rupanshu Raman 2016-10-24 05:06:48

Just connect to Internet and start Android Studio and open your project. While Gradle Sync it will download the dependencies from Internet(All JAR Files). This solved it for me. No Editing in Gradle file ,all was done by Android Studio Automatically. Using Android Studio 2.2 :)

Also don't forget to install Java JDK 1.x(7 or 8 all works fine).

@M.M 2016-10-12 14:57:03

Go to Go to "File" -> "Project Structure" -> "App" In the tab "properties". In "Library Repository" field put 'http://repo1.maven.org/maven2' then press Ok. It was fixed like that for me. Now the project is compiling.

@Roy Selim 2016-10-10 17:40:03

The error is caused by missing jar files. My simple solution is just by copying all the files that does not resolve to the C:\Program Files\Android\Android Studio\gradle\m2repository... (your file path may be different). I got around 6 dependencies that cannot be resolved, junit is one of them and the others are com and org and javax. Since I am behind a firewall, even if I added the code for the repository, the Android Studio doesn't seem to access it. I went to the maven repository and downloaded all the files that will not resolve. Problem solved and the Gradle sync without error. But I am a certified newbie with only 1 day experience so I do not not if this is the proper way to do it.

Example error: Cannot resolve com:squareup:javawriter:2.1.1

Step 1: I created a path C:\Program Files\Android\Android Studio\gradle\m2repository\com\squareup\javawriter\2.1.1\

Step 2: I downloaded all the jar files from the maven repository: http://repo1.maven.org/maven2/com/squareup/javawriter/2.1.1/

Step 3: I manually downloaded all the .jar files from this directory

Step 4: I copied them to C:\Program Files\Android\Android Studio\gradle\m2repository\com\squareup\javawriter\2.1.1\

I repeated this to all the files that did not resolve including the junit.

For junit, here is the directory I created: C:\Program Files\Android\Android Studio\gradle\m2repository\junit\junit\4.12 and then I copied the junit-4.12.jar inside this directory and the junit error disappeared.

@mdew 2015-09-14 13:26:02

I had the same problem. Solved by adding url for missing repository in the build.gradle file:

android {
    [...]
    repositories {
        maven { url 'http://repo1.maven.org/maven2' }
    }
    [...]
}

That's it.

@revolutionary 2015-09-24 13:55:19

That definitely solved the issue for me, so atleast i can gradle-sync now

@Raulp 2015-10-05 08:37:53

what was the root cause for this?

@Sithu 2016-02-18 03:49:43

This did solve the problem, but what is that maven?

@Sithu 2016-02-18 04:46:30

It should be added above buildTypes, otherwise the error buildTypes cannot be applied to groovy.lang.Closure will occur.

@H. Aqjn 2016-07-03 11:19:37

What about jcenter() ? Is it necessary to eliminate jcenter() from repositories?

@HPbyP 2016-09-06 13:33:35

@guru_001 2016-11-25 14:05:02

where junit.jar is present ,gimme the dir where junit.jar is saved

@Christian Schulzendorff 2017-11-06 15:20:00

For me, worked only with https.

@Ben 2016-09-21 00:10:04

I couldn't work out why Android Studio was not syncing with gradle. It turned out that it didn't like my VPN, so watch for that!

@Akash Jaiswal 2016-08-30 10:55:34

I was having same problem.

  • 1 option: Download junit 4.12.jar and copy it in your lib folder and restart android studio. Benefit u don't have to create any new project

  • 2 option: Create a new project having a internet connections and copy all the java and XML code in the newly created project. Benefit this problem will be solved permantly

@Display name 2016-08-21 01:27:01

I had the same problem, but with another problem.

My other problem was that the Gradle build was too slow!

I resolved my problem by doing thisL

If you do like mdew you need to this any time you're creating your project to do this

So if you want to set default option to maven

Do this:

Go to the folder:

C:\Program Files\Android\Android Studio\plugins\android\lib\templates\gradle-projects\NewAndroidProject\root

Then open the build.gradle.ftl file with notepad++ or notepad and replace all jcenter() with mavenCentral().

EDIT: Why its going down voted? you don't like it?

@saibaba vali 2016-08-18 19:19:24

Mostly this issue will come when ever you update your SDK, at the time of project creation Gradle build fails. If you add the maven and jcenter repositories to your build.gradle(Module:app) your problem will solved.

repositories {
    maven { url 'http://repo1.maven.org/maven2' }
    jcenter { url "http://jcenter.bintray.com/" }
}

These are the two line you have to add after

apply plugin: 'com.android.application' 

This is how your code look like after adding those two lines

apply plugin: 'com.android.application'

 repositories {
        maven { url 'http://repo1.maven.org/maven2' }
        jcenter { url "http://jcenter.bintray.com/" }
    }

android {
    compileSdkVersion 23
    buildToolsVersion "23.0.1"

    defaultConfig {
        applicationId "com.okedroid.myapplication"
        minSdkVersion 17
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

@Štarke 2016-08-16 07:13:03

Are you using proxy? If so, the problem can be in missing network configuration for https in your gradle.properties file.

AndroidStudio puts automatically your default proxy settings to gradle.properties file in your project, but only for http and forgets https.

So basically your gradle.properties file needs to contain both http and https config:

systemProp.http.proxyPassword=xxx
systemProp.http.proxyHost=xxx
systemProp.http.nonProxyHosts=xxx
systemProp.http.proxyUser=xxx
systemProp.http.proxyPort=xxx

systemProp.https.proxyPassword=xxx
systemProp.https.proxyHost=xxx
systemProp.https.nonProxyHosts=xxx
systemProp.https.proxyUser=xxx
systemProp.https.proxyPort=xxx

@Ortal D 2016-07-06 04:46:51

I'll tryed everithing, but the only thing that helps me resolve the problem was delete the line

testCompile 'junit:junit:4.12'

from the app gradel.

@HPbyP 2016-07-01 18:20:41

if you faced this problem you can completely resolve it by changing :

build.gradle(project: ...)

replace this

    buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.0.0'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        mavenCentral()

    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

@Tasko 2016-06-29 21:47:01

My installation of Android Studio is completely offline. To resolve these kind of problems I have used the Process Monitor. It showed that a few files are missing within "Android Studio\gradle\m2repository". I have downloaded all files from

  1. http://repo1.maven.org/maven2/junit/junit/4.12/
  2. http://repo1.maven.org/maven2/org/hamcrest/hamcrest-core/
  3. repo1.maven.org/maven2/org/hamcrest/hamcrest-parent/1.3/ (I can only post two links...;-))

and copied these files in "Android Studio\gradle\m2repository". You have to create the structure below "m2repository" as it is below "maven2". Maybe there are more missing files, but at this time at least Gradle build is finished without errors.

@Lord Sepid 2017-09-19 18:23:33

in all these answers, this was the only one which actually solved my problem (I tested them all !). of course for me it needed more repositories to be added but the solution was the same. the only one which didn't work was "javax.annotation-api/1.2" that after a few tests I had to remove it from dependencies. thanks @Tasko

@Murtuza K 2016-05-27 12:03:10

Here is what I did to solve the same problem. I am behind a firewall, which is same issue as yours I suppose. So I had tried removing the

testCompile 'junit:junit:4.12' line 

but that didnt work for me. I tried adding below lines of code:

repositories {
    maven { url 'http://repo1.maven.org/maven2' }
}

Even that did not work for me.

I tried removing (-) and readding (+) Junit4.12 from the library dependencies under Module Settings. Still that did not work for me.

Tried syncing and rebuilding project several times. Still did not work for me.

Finally what I did was to manually download the Junit4.12.jar file from mvnrepository website. I put this jar file in the Androids Workspace under the Project folder inside libs folder. Then go to Module Settings > Dependencies Tab > (+) > File Dependency > under Sleect path window, expand the 'libs' folder and you will find the Jar file you copied inside there. Select the File and click 'OK' Now remove the previous version of junit4.12 from the list of dependencies.

You should have one entry "libs\junit-4.12.jar" in the Dependencies list. Now click 'OK'.

Now Gradle will rebuild the project and you should be good to go.

Hope this helps!

@Mohammedsalim Shivani 2018-03-27 09:33:43

I just invalidated cache and restarted the Android Studio.

Related Questions

Sponsored Content

4 Answered Questions

[SOLVED] Cannot open layout in Android Studio

0 Answered Questions

Powermock is not working in Android Studio

1 Answered Questions

com.google.protobuf.AbstractMessageLite$Builder$LimitedInputStream

1 Answered Questions

notification manager doesn't work in Kitkat

  • 2017-08-03 19:12:01
  • Ibrahim Magdy
  • 250 View
  • 0 Score
  • 1 Answer
  • Tags:   android

1 Answered Questions

[SOLVED] Kotlin fails to compile a library

1 Answered Questions

[SOLVED] How to display Map on emulator

2 Answered Questions

[SOLVED] Google mobile vision library 11.8.0 is not recognized

Sponsored Content