By edosoft


2008-12-09 13:06:41 8 Comments

I've added a proxy to a webservice to a VS2008/.NET 3.5 solution. When constructing the client .NET throws this error:

Could not find default endpoint element that references contract 'IMySOAPWebService' in the ServiceModel client configuration section. This might be because no configuaration file was found for your application or because no endpoint element matching this contract could be found in the client element.

Searching for this error tells me to use the full namespace in the contract. Here's my app.config with full namespace:

<client>
  <endpoint address="http://192.168.100.87:7001/soap/IMySOAPWebService"
            binding="basicHttpBinding" bindingConfiguration="IMySOAPWebServicebinding"
            contract="Fusion.DataExchange.Workflows.IMySOAPWebService" name="IMySOAPWebServicePort" />
</client>

I'm running XP local (I mention this because a number of Google hits mention win2k3) The app.config is copied to app.exe.config, so that is also not the problem.

Any clues?

30 comments

@Nikhil Dinesh 2018-04-10 09:31:00

In my case, I was referring to this service from a library project, not a startup Project. Once I copied <system.serviceModel> section to the configuration of the main startup project, The issue got resolved.

During running stage of any application, the configuration will be read from the startup/parent project instead of reading its own configurations mentioned in separate subprojects.

@Tom Haigh 2011-06-16 08:57:00

I solved this (I think as others may have suggested) by creating the binding and endpoint address instances myself - because I did not want to add new settings to the config files (this is a replacement for some existing library code which is used widely, and previously used an older Web Service Reference etc.), and so I wanted to be able to drop this in without having add new config settings everywhere.

var remoteAddress = new System.ServiceModel.EndpointAddress(_webServiceUrl);

using (var productService = new ProductClient(new System.ServiceModel.BasicHttpBinding(), remoteAddress))
{
    //set timeout
    productService.Endpoint.Binding.SendTimeout = new TimeSpan(0,0,0,_webServiceTimeout);

    //call web service method
    productResponse = productService.GetProducts();
} 

Edit

If you are using https then you need to use BasicHttpsBinding rather than BasicHttpBinding.

@Paul Morel 2012-04-03 22:33:17

This is a helpful answer. On a web service I am using, the custom endpoint had to be bound in the object's initial declaration. It wouldn't work if I tried to do it later.

@Sam I am says Reinstate Monica 2012-10-15 23:05:29

As much as I suspect that the top answer might have done the trick too, your solution worked, and it seems preferable to me hacking together my own config files.

@Daniel Gee 2013-10-06 23:44:03

Works a charm! I much prefer being able to set the Endpoint in code rather than distributing an "app.config" file with my app.

@Anthony 2013-11-06 15:33:09

If it's an Https web service remember to change BasicHttpBinding() to BasicHttpsBinding()

@user781700 2014-05-07 15:48:01

This solution is best for applications like EXCEL-DNA which does not have app.config or web.config.

@VictorEspina 2016-05-18 22:58:14

This worked for me like a charm. Thanks a lot.

@Luca 2016-09-29 13:40:22

with this solution I can deploy only the .exe without the .exe.config!

@Tahir Khalid 2017-04-07 16:12:02

Good answer I wanted to create a proxy API using a Web API 2 solution but not have to put anything in the Web.Config this answer allowed me to keep the communcation close to the actual service method. Good work!

@markaaronky 2017-07-05 20:11:01

Several responses here hit upon the correct solution when you're facing the mind-numbingly obscure error of referencing the service from a class file: copy service config info into your app.config web.config of your console or windows app. None of those answers seem to show you what to copy though. Let's try and correct that.

Here's what I copied out of my class library's config file, into my console app's config file, in order to get around this crazy error for a service I write called "TranslationServiceOutbound".

You basically want everything inside the system.serviceModel section:

  <system.serviceModel>
<bindings>
  <basicHttpBinding>
    <binding name="BasicHttpBinding_ITranslationServiceOutbound" />
  </basicHttpBinding>
</bindings>
<client>
  <endpoint address="http://MyHostName/TranslationServiceOutbound/TranslationServiceOutbound.svc"
    binding="basicHttpBinding" bindingConfiguration="BasicHttpBinding_ITranslationServiceOutbound"
    contract="TranslationService.ITranslationServiceOutbound" name="BasicHttpBinding_ITranslationServiceOutbound" />
</client>

@nzrytmn 2016-09-21 09:58:58

I got same error and i try some many thing but didn't work, than i noticed that my "contract" was not same for whole projects, i changed the contract as would be same for all projects inside solution and than it worked. This is project A

<client>
    <endpoint address="https://xxxxxxxx" binding="basicHttpBinding" bindingConfiguration="basic" contract="ServiceReference.IIntegrationService" name="basic" />
</client>

Project B :

<client>
    <endpoint address="xxxxxxxxxxxxx" binding="basicHttpBinding" bindingConfiguration="basic" contract="ServiceReference1.IIntegrationService" name="basic" />
</client>

Finally I changed for both as :

<client>
    <endpoint address="https://xxxxxxxxxxx" binding="basicHttpBinding" bindingConfiguration="basic" contract="MyServiceReferrence.IIntegrationService" name="basic" />
</client>

@silver 2016-08-24 09:10:05

I had the same issue and it was solved only when the host application and the dll that used that endpoint had the same service reference name.

@Waldemar Gałęzinowski 2016-05-31 17:35:58

When you are adding a service reference

enter image description here

beware of namespace you are typing in:

enter image description here

You should append it to the name of your interface:

<client>
  <endpoint address="http://192.168.100.87:7001/soap/IMySOAPWebService"
            binding="basicHttpBinding" 
            contract="MyNamespace.IMySOAPWebService" />
</client>

@user1108948 2015-09-23 13:16:45

I have a situation which in the Unit test. I copied the app.config file to the unit test project. So the unit test project also contains endpoint information.

@kwrl 2015-10-30 10:23:26

I didn't copy the complete app.config, but the system.serviceModel section. That's all!

@AlbatrossCafe 2017-03-06 23:40:30

Same, except I copied the system.serviceModel to the app.config of a console application

@melvas 2014-12-05 07:06:57

"This error can arise if you are calling the service in a class library and calling the class library from another project."

"In this case you will need to include the WS configuration settings into the main projects app.config if its a winapp or web.config if its a web app. This is the way to go even with PRISM and WPF/Silverlight."

Yes, but if you can't change main project (Orchard CMS for example), you can keep WCF service config in your project.

You need to create a service helper with client generation method:

public static class ServiceClientHelper
{
    public static T GetClient<T>(string moduleName) where T : IClientChannel
    {
        var channelType = typeof(T);
        var contractType = channelType.GetInterfaces().First(i => i.Namespace == channelType.Namespace);
        var contractAttribute = contractType.GetCustomAttributes(typeof(ServiceContractAttribute), false).First() as ServiceContractAttribute;

        if (contractAttribute == null)
            throw new Exception("contractAttribute not configured");

        //path to your lib app.config (mark as "Copy Always" in properties)
        var configPath = HostingEnvironment.MapPath(String.Format("~/Modules/{0}/bin/{0}.dll.config", moduleName)); 

        var configuration = ConfigurationManager.OpenMappedExeConfiguration(new ExeConfigurationFileMap { ExeConfigFilename = configPath }, ConfigurationUserLevel.None);
        var serviceModelSectionGroup = ServiceModelSectionGroup.GetSectionGroup(configuration);

        if (serviceModelSectionGroup == null)
            throw new Exception("serviceModelSectionGroup not configured");

        var endpoint = serviceModelSectionGroup.Client.Endpoints.OfType<ChannelEndpointElement>().First(e => e.Contract == contractAttribute.ConfigurationName);
        var channelFactory = new ConfigurationChannelFactory<T>(endpoint.Name, configuration, null);
        var client = channelFactory.CreateChannel();
        return client;
    }
}

and use it:

using (var client = ServiceClientHelper.GetClient<IDefaultNameServiceChannel>(yourLibName)) {
                ... get data from service ...
            }

See details in this article.

@saille 2014-10-29 23:07:43

I had this error when I was referencing the Contract in the configuration file element without the global scope operator.

i.e.

<endpoint contract="global::MyNamepsace.IMyContract" .../>

works, but

<endpoint contract="MyNamepsace.IMyContract" .../>

gives the "Could not find default endpoint element that references contract" error.

The assembly containing MyNamepsace.IMyContract is in a different assembly to the main application, so this may explain the need to use the global scope resolution.

@zanderwel 2014-08-29 10:27:54

I was getting this error within an ASP.NET application where the WCF service had been added to a class library which is being added to the ASP.NET application as a referenced .dll file in the bin folder. To resolve the error, the config settings in the app.config file within the class library referencing the WCF service needed to be copied into the web.config settings for the ASP.NET site/app.

@Wouter Vanherck 2018-06-27 09:22:54

While other answers might've described the same problem. This answer described my exact situation and I finally understood the issue. Thank you for saving my day

@David 2014-05-13 20:06:15

Allow me to add one more thing to look for. (Tom Haigh's answer already alludes to it, but I want to be explicit)

My web.config file had the following defined:

<protocolMapping>
    <add binding="basicHttpsBinding" scheme="https" />
</protocolMapping>

I was already using basicHttpsBinding for one reference, but then I added a new reference which required basicHttpBinding (no s). All I had to do was add that to my protocolMapping as follows:

<protocolMapping>
    <add binding="basicHttpBinding" scheme="http" />
    <add binding="basicHttpsBinding" scheme="https" />
</protocolMapping>

As L.R. correctly points out, this needs to be defined in the right places. For me, that meant one in my Unit Test project's app.config as well as one in the main service project's web.config.

@Jeff Moeller 2009-10-15 18:57:48

This one drove me crazy.

I'm using Silverlight 3 Prism (CAB) with WCF

When I call a WCF service in a Prism module, I get the same error:

Could not find default endpoint element that references contract 'IMyService' in the service model client configuaration section. This might be because no configuaration file was found for your application or because no end point element matching this contract could be found in the client element

It turns out that its looking in the Shell's .xap file for a ServiceReferences.ClientConfig file, not in the module's ServiceReferences.ClientConfig file. I added my endpoint and binding to the existing ServiceReferences.ClientConfig file in my Silverlight Shell application (it calls it's own WCF services).

Then I had to rebuild the Shell app to generate the new .xap file for my Web project's ClientBin folder.

Now this line of code finally works:

MyServiceClient myService = new MyServiceClient();

@vardars 2012-09-22 12:25:58

I faced this problem once. It was because i was still developing the interface that uses WCF service. I configured test application and continued development. Then in development, i changed some of the services' namespaces. So i double checked "system.serviceModel -> client -> endpoint -> contract" in web.config to match WCF class. Then problem is solved.

@VRK 2012-08-29 20:49:34

In case if you are using WPF application using PRISM framework then configuration should exist in your start up project (i.e. in the project where your bootstrapper resides.)

@PatrickV 2012-02-14 23:31:27

Unit testing a non-library application that consumes a service can cause this problem.

The information that others have entered addresses the root cause of this. If you are trying to write automated test cases and the unit you are testing will actually invoke the service interface, you need to add the service reference to the test project. This is a flavor of the application using library type of error. I did not immediately realize this though because my code that consumes the interface is not in a library. However, when the test actually runs it will be running from the test assembly, not the assembly under test.

Adding a service reference to the unit test project resolved my issue.

@Mücahid Uslu 2011-07-11 14:16:40

Do not put service client declaration line as class field, instead of this, create instance at each method that used in. So problem will be fixed. If you create service client instance as class field, then design time error occurs !

@rob 2011-12-23 09:37:28

Solution for me was to remove the endpoint name from the Endpoint Name attribute in client web.config this allowed the proxy to use

ChannelFactory<TService> _channelFactory = new ChannelFactory<TService>("");

only took all day to work out. Also the contract name was wrong once this fix was in place although it had been wrong when the initial error appear. Double then triple check for contract name strings people !! attrib: Ian

@Kamran Akhter 2011-11-04 12:58:29

I had the same Issue
I was using desktop app and using Global Weather Web service

I deleted the service reference and added the web reference and problem solved Thanks

@L.R. 2010-04-29 13:18:41

"This error can arise if you are calling the service in a class library and calling the class library from another project."

In this case you will need to include the WS configuration settings into the main projects app.config if its a winapp or web.config if its a web app. This is the way to go even with PRISM and WPF/Silverlight.

@edosoft 2010-07-05 11:46:28

This wasn't the cause for my specific problem, but I'm sure this will help others. Thanks

@Sean Hanley 2010-11-05 13:30:14

Is there any way to automatically merge the two? What if the class library updates its configuration? Are you just stuck remembering to update the copied config info in all projects that are referencing it? This fix seems to rely too much on the developer's vigilance...

@David Mason 2011-04-06 03:10:57

I'm getting the same error for a WP7 app (Silverlight I believe) and it took me far too long to notice that ServiceReferences.ClientConfig is generated in the project directory. Copying the <bindings> and <client> elements from the file in my library to my main app (which were previously empty) got things working.

@Rod 2011-08-25 16:32:48

OK, I did this too, and it worked, but I sure as heck would like to understand WHY it worked! It doesn't make sense to me that it would.

@Aardvark 2011-08-30 15:51:08

For Silverlight 4 I include the .ClientConfig file (from my library) to the main project as a link. This makes editing the settings of the file easier (vs. multiple copies in different projects).

@BobC 2011-09-28 21:03:06

What if the project that's calling it is a MSTest project? i.e. no app.config or web.config

@Ciaran Bruen 2011-12-05 16:35:39

The reason this happens (as I understand it) is that config values are read from the main project in a solution, be that web, winforms, wpf etc. Say for example you have a class library project to access a database, the connectionString entry will need to be in the main project config rather than the class library config.

@Youngjae 2012-01-08 09:28:20

So we can conclude that, if we use WCF in a library, it would be better to code settings directly like the link stackoverflow.com/questions/7688798/… shown.

@Stephen Holt 2012-03-08 16:24:12

Weird coincidence of the reputations here: twitpic.com/8tmfmq/full

@Saher Ahwal 2012-07-19 21:05:54

I have even tried to add reference to Service from new project but I get same error

@cihata87 2014-04-18 13:50:06

Saved my life! Thank you.

@Jad Chahine 2018-02-18 21:19:39

This is the best answer

@Bravo 2011-08-11 05:03:32

I had a situation like this, where i had

  • WCF Service Hosted somewhere
  • Main Project
  • Consumer Project of type 'class Library' which has Service reference to a WCF Service
  • Main project calls methods from consumer project

Now the Consumer project had all the related configuration setting in <system.serviceModel> Tag of my app.config, its was still throwing the same error as the above.

All i did is added the same tag <system.serviceModel> to my main project's app.config file, and finally we were good to go.

The Real problem, as far as in my case was, it was reading the wrong configuration file. Instead of consumer's app.config, it was referring main proj's config. it took me two hours to figure that out.

@SteveCinq 2017-08-22 22:02:29

Same. Search for <system.serviceModel> in your library, then copy it to your main application's app.config. Just another symptom of class library app.configs not being read at run time. I spend sooooo much time compensating for this oversight (imo). If I want the library to read it's config from it's app.config, let it. Otherwise, why have an app.config for class libraries in the first place??

@Joey 2011-07-31 22:04:01

Hi I've encountered the same problem but the best solution is to let the .NET to configure your client side configuration. What I discover is this when I add a service reference with a query string of http:/namespace/service.svc?wsdl=wsdl0 it does NOT create a configuration endpoints at the client side. But when I remove the ?wsdl-wsdl0 and only use the url http:/namespace/service.svc, it create the endpoint configuration at the client configuration file. for short remoe the " ?WSDL=WSDL0" .

@Roshan 2010-10-25 00:48:12

If you reference the web service in your class library then you have to copy app.config to your windows application or console application

solution: change Configuration of outer project same the class library's wcf configuration.

Worked for me

@Matt Mitchell 2010-10-30 11:14:43

I found (as well as copying to the client UI's App.config as I was using a Class Library interface) I had to prefix the name of the binding with the name of the Service Reference (mine is ServiceReference in the below).

e.g.:

<endpoint address="http://localhost:4000/ServiceName" binding="basicHttpBinding"
      bindingConfiguration="BasicHttpBinding_ISchedulerService"
      contract="ServiceReference.ISchedulerService" 
      name="BasicHttpBinding_ISchedulerService" />

instead of the default generated:

<endpoint address="http://localhost:4000/ServiceName" binding="basicHttpBinding"
      bindingConfiguration="BasicHttpBinding_ISchedulerService"
      contract="ISchedulerService" 
      name="BasicHttpBinding_ISchedulerService" />

@Brig 2011-05-11 20:46:32

I had to do the same thing. I really don't understand why.

@PhilG 2010-10-14 11:23:30

Just for anyone else with the same problem; I wrote a unit test for my method that tried to connect to my service. It failed with this same exception every time - I have no idea why. When I ran it from a winform it works fine.

@PatrickV 2012-02-14 23:32:57

See my answer to this question - the problem is that when unit test runs it doesn't inherit the app.config from the assembly under test. Add a service reference to the test project.

@edosoft 2008-12-10 13:19:45

Having tested several options, I finally solved this by using

contract="IMySOAPWebService"

i.e. without the full namespace in the config. For some reason the full name didn't resolve properly

@Anatoly Mironov 2012-04-16 11:37:23

It seems, that contract name has to be written exactly in the same way as the client. In my case, I had var proxy = new ExternalServices.ServiceClient("MyServiceEndpoint"); It worked when the I added the namespace to contract: contract="ExternalServices.IMyService"

@albatross 2016-02-22 15:34:49

This didnt work for me. My problem might be a little bit different . I get this error time to time not always. What might be the issue. Could error mighht be at service side?_Thanks

@Teoman shipahi 2017-03-17 20:08:04

@AnatolyMironov thanks a lot!

@Itay Levin 2010-07-08 09:37:44

Ok. My case was a little diffrent but finally i have found the fix for it: I have a Console.EXE -> DLL -> Invoking WS1 -> DLL -> Invoking WS2

I have had both the configurations of the service model of WS1, and WS2 in the Console.EXE.config as recommended. - didnt solve the issue.

But it still didn't work, until i have added the WebReference of WS2 to WS1 also and not only to the DLL that actually creating and invoking the proxy of WS2.

@sAeid mOhammad hAshem 2010-06-14 13:16:52

I Have a same Problem.I'm Used the WCF Service in class library and calling the class library from windows Application project.but I'm Forget Change <system.serviceModel> In Config File of windows application Project same the <system.serviceModel> of Class Library's app.Config file.
solution: change Configuration of outer project same the class library's wcf configuration.

@Andomar 2010-06-10 17:44:39

I've had this same issue. It turns out that for a web REFERENCE, you have to supply the URL as the first parameter to the constructor:

new WebService.WebServiceSoapClient("http://myservice.com/moo.aspx");

For a new style web SERVICE REFERENCE, you have to supply a name that refers to an endpoint entry in the configuration:

new WebService.WebServiceSoapClient("WebServiceEndpoint");

With a corresponding entry in Web.config or App.config:

<client>
      <endpoint address="http://myservice.com/moo.aspx"
        binding="basicHttpBinding" 
        bindingConfiguration="WebService"
        contract="WebService.WebServiceSoap"
        name="WebServiceEndpoint" />
    </client>
  </system.serviceModel>

Pretty damn hard to remove the tunnel vision on "it worked in an older program"...

@travis 2010-12-07 17:21:11

Ah ha! This fixed it for me, I was just using an empty constructor before, which kept failing: new WebService.WebServiceSoapClient(); //fail

@Dipti Mehta 2011-05-24 05:35:49

This solutin did work !!! but, i am really curious as to why the default end point was not loaded ? any ideas to what could be the reasons ?

@Kev 2013-01-11 17:36:00

@Andomar sorry to bring up an old thread. Does one have any advantage over another - WebReference and ServiceReference? I think the former would be more convenient for me but ServiceReference is the cool new thing I guess...

@Gaspa79 2018-02-20 20:45:23

Jesus, nice parameter names....

@TPaul 2010-05-06 21:14:47

There seem to be several ways to create/fix this issue. For me, the CRM product I am using was written in native code and is able to call my .NET dll, but I run into the configuration information needing to be at/above the main application. For me, the CRM application isn't .NET, so I ended up having to put it in my machine.config file (not where I want it). In addition, since my company uses Websense I had a hard time even adding the Service Reference due to a 407 Proxy Authentication Required issue, that to required a modification to the machine.cong.

Proxy solution:

To get the WCF Service Reference to work I had to copy the information from the app.config of my DLL to the main application config (but for me that was machine.config). And I also had to copy the endpoint information to that same file. Once I did that it starting working for me.

@Manuel Alves 2010-04-15 12:10:06

This error can arise if you are calling the service in a class library and calling the class library from another project.

Related Questions

Sponsored Content

2 Answered Questions

[SOLVED] Could not find default endpoint element .NET 4.0

2 Answered Questions

13 Answered Questions

1 Answered Questions

Could not find default endpoint element while acessing WCF service

1 Answered Questions

2 Answered Questions

1 Answered Questions

[SOLVED] WCF, ChannelFactory, "Could not find endpoint element..."

1 Answered Questions

WCF could not find default endpoint

  • 2010-09-10 12:25:14
  • Rise_against
  • 497 View
  • 1 Score
  • 1 Answer
  • Tags:   wcf web-services

Sponsored Content