By Johnny


2016-02-18 08:21:04 8 Comments

I have gone through many questions like this on Google Play, I am using Android 4.2.2 API 17.

My app requires Google play services 8.1 , It compiles fine and when it runs on emulator it shows message that 'You need to update your Google play services ' ,

When I click on update nothing happens,

How can I update the Google Play services without downloading any latest API version ?

11 comments

@Bogdan M 2020-06-05 23:20:35

2020 , the error Google Play services out of date. Requires 12451000 but found 11743470

just update Google Play services from the Google Play after you sing-in with a valid account.

PS: I've tried different Emulator versions, but all required to update google play services.

@Ban Markovic 2019-10-17 12:45:18

I know it's late answer but I had same problem for last two days, and none of the above solutions worked for me. My app supports min sdk 16, Jelly Bean 4.1.x, so I wanted to test my app on emulator with 16 android api version and I needed Google Play Services.

In short, solution that worked for me is:

  • make new emulator Nexus 5X (with Play Store support) - Jelly Bean 4.1.x, 16 API level (WITHOUT Google APIs)
  • manually download apks of Google Play Store and Google Play Services (it is necessary that both apks have similar version, they need to start with same number, for example 17.x)
  • drag and drop those apks into new emulator
  • congratulations you have updated Google Play Services on your 4.1.x emulator

Here are the steps and errors I have encountered during the problem.

So I have made new emulator in my AVD. I picked Nexus 5X (with Play Store support). After that I picked Jelly Bean 16 api level (with Google APIs). When I opened my app dialog pop up with message You need to update your Google play services. When I clicked on Update button, nothing happened. I did update everything necessary in SDK manager, but nothing worked. I didn't have installed Google Play Store on my emulator, even tho I picked Nexus 5X which comes with preinstalled Play Store. So I couldn't find Google Play Store tab in Extended Controls (tree dots next to my emulator).

Because nothings worked, I decided to try to install Google Play Services manually, by downloading APK and dragging it into emulator. When I tried this, I encountered problem The APK failed to install. Error: INSTALL_PARSE_FAILED_INCONSISTENT_CERTIFICATES. I figured that this was the problem because I picked Jelly Bean 16 api level (with Google APIs). So I made new emulator

Nexus 5X (with Play Store support) - Jelly Bean 16 api level (WITHOUT Google APIs)

This allowed me to install my Google Play Service manually. But when I run my app, it still didn't want to open it. Problem was that my emulator was missing Google Play Store. So I installed it manually like Google Play Service. But when it was successfully installed, dialog started popping out every second with message Unfortunately Google Play Services has stopped. Problem was that version of my Google Play Store was 17.x and Google Play Service was 19.x. So at the end I installed Google Play Service with version 17.x, and everything worked.

@CoolMind 2019-12-12 14:19:06

How did you download and install apks?

@Ban Markovic 2019-12-17 07:48:10

@CoolMind just download them from apkmirror.com (search in google google play services apk apkmirror). When you download them, just drag and drop apk files into your emulator.

@CoolMind 2019-12-17 08:23:27

Thanks! I also thought of that, but was not sure. I will try. Did you use version 17 or more?

@Ban Markovic 2019-12-17 08:30:26

No problem, hope you will solve your problem. I used 17 version of GPS, but I think you can use any newer version you want. Here is the article with a little more information regarding my solution medium.com/@banmarkovic/…

@CoolMind 2019-12-17 09:44:46

Hm, I found that 17 version is for Android 5+, so downloaded 16.8 (16.8 for x86. Android 5.0 version will write that an old SDK found). Play Market.apk installed, and GPS.apk 16.8 for armeabi-v7a installed too, but after running Play Market it writes: "Unfortunately Google Play services has stopped". Then I downloaded apks 15.1 version for x86, and after running PM nothing happened. I created an armeabi-v7a emulator and installed 16.8 versions, it was very slow. After running PM it showed white screen and closed. On x86 emulator with 17.1 versions (armeabi-v7a) PM also didn't run.

@Ban Markovic 2019-12-17 11:24:48

I'm not sure if I did understand everything u said. But I would avoid armeabi-v7a versions of apks and emulators, and will try everything with only x86 architecture (apks and emulator).

@CoolMind 2019-12-17 11:36:50

Yes, x86 are better, armeabi-v7a were very slow. If you have spare time, could you update the article with the links to apks and chosen architecture/dpi? Thank you.

@abbood 2018-06-28 04:30:56

the answers on this page eluded me until i found the show package details option

enter image description here

@Houssin Boulla 2018-04-10 10:59:43

You need install Google play image, Android SDK -> SDK platforms --> check show Package details --> install Google play. enter image description here

@Estevão Lucas 2018-02-12 21:08:25

I was having the same issue. Just avoid using an emulator with SDK 27. SDK 26 works fine!

@Amit Vaghela 2016-02-19 05:56:07

Update On 18-Dec-2017

You can update Google Play Services via the Play Store app in your emulator just as you would on a physical Android device from API 24.

check Emulator new features added with stable update from Android Studio v 3.0

Google Play Support - From Google : We know that many app developers use Google Play Services, and it can be difficult to keep the service up to date in the Android Emulator system images. To solve this problem, we now offer versions of Android System Images that include the Play Store app. The Google Play images are available starting with Android Nougat (API 24). With these new emulator images, you can update Google Play Services via the Play Store app in your emulator just as you would on a physical Android device. Plus, you can now test end-to-end install, update, and purchase flows with the Google Play Store.


Quick Boot - Quick Boot allows you to resume your Android Emulator session in under 6 seconds

Android CTS Compatibility

Performance Improvements - With the latest versions of the Android Emulator, we now allocate RAM on demand, instead of allocating and pinning the memory to the max RAM size defined in your AVD.

Virtual sensors

Wi-Fi support

GPS location and Many more...

OR

Update this SDK Build-Tools and Android Emulator to latest and this alert message will not come again,

Settings --> Android SDK --> SDK Tools(tab) --> Android SDK Build-Tools

enter image description here

@FRR 2017-02-20 14:05:36

this just doesn't work, freshly downloaded images come with out of data google play services

@Amit Vaghela 2017-02-21 04:41:47

check stackoverflow.com/a/41803959/2826147 which is fullly reversed to your [email protected]

@FRR 2017-02-21 14:31:36

Just deleted all my system images and downloaded a fresh x86_64 API 25 and still comes with google play services 9.8.79, latest one is 10.2.98

@FRR 2017-02-21 15:14:25

Ok, just re checked the linked answer.. it suggests that you download API 24 instead of 25... Which in deed comes with a somewhat "newer" google play services (10.0.84) but it's still not the latest...

@Amit Vaghela 2017-02-23 05:10:40

it comes with google play services so no need to worry about it. please remove your unnecessary comments so it will not confuse [email protected]

@FRR 2017-02-23 23:51:17

? All emulators (with google APIs) come with a version google play services, the question is about how to update it to the latest version. Downloading an older API gets you a somewhat newer version, but still not the latest. (something you failed to mention on your answer)

@meagar 2017-07-04 21:26:33

Please stop posting links to your answer below other people's posts.

@34m0 2017-07-30 16:41:45

I had the same problem and this answer was not the solution; keep scrolling down to see one of the correct answers specifying that you must choose an image that supports Google Play - there are only 2 devices possible: Nexus5 and Nexus5X

@JPM 2017-12-22 17:41:14

Seems its missing in the latest API 27

@Liron Yahdav 2018-02-09 23:26:51

Doesn't seem this answer is relevant to the question as they are asking about "Android 4.2.2 API 17" but the updated answer is only relevant for API >= 24.

@szaske 2018-04-22 07:05:37

Like others have mentioned this answer does not work for me. I'm using the latest Build Tools as of 4/22/2018 Build Tools 28-RC1 and latest emulator 27.1.12. My emulator complains that I need to update Google Play Services, but does not give me a way to do it. I'm using API 27 and Android 8.1

@Leo supports Monica Cellio 2018-07-13 03:02:40

the question is for API 17, not 24. This is notthe right answer

@Amit Vaghela 2018-07-13 05:30:10

@LeonardoAcevedo but this is one of the solution which can resolve issue and i have given two solutions. please check secondone. hope that helps.

@Leo 2018-09-04 10:10:23

I'm sorry, but this is not the solution.

@André Luiz Reis 2018-09-25 19:42:10

It doesn't work for API 16. I cannot create an image with Google Play Store.

@Michel 2017-06-24 07:18:53

Running the app on a virtual device with system image, 'Google Play API' instead of 'Google API' will solve your issue smoothly..

  • Virtual devices Nexus 5x and Nexus 5 supports 'Google Play API' image.

  • Google Play API comes with Nougat 7.1.1 and O 8.0.

Just follow the below simple steps and make sure your pc is connected to internet.

  1. Create a new virtual device by selecting Create Virtual Device(left-bottom corner) from Android Virtual Devices Manager.

  2. Select the Hardware 'Nexus 5x' or 'Nexus 5'.

  3. Download the system image 'Nougat' with Google Play or 'O' with Google Play. 'O' is the latest Android 8.0 version.

  4. Click on Next and Finish.

  5. Run your app again on the new virtual device and click on the 'Upgrade now ' option that shows along with the warning message.

  6. You will be directed to the Play Store and you can update your Google Play services easily.

See your app runs smoothly!

  • Note: If you plan to use APIs from Google Play services, you must use the Google APIs System Image.

@jlively 2017-08-15 10:57:55

Hmm there are no Google Play API's.

@pvella 2017-12-13 02:47:28

Thanks so much. This worked for me. I had not been able to get a login to work since upgrading to Android Studio 3.0.

@Liron Yahdav 2018-02-09 23:29:20

Doesn't seem this answer is relevant to the question as they are asking about "Android 4.2.2 API 17" but this answer is only relevant for API >= 24.

@user345280 2017-06-18 11:05:04

Use emulator that has Play Store installed. Updating play services would be as easy as in real device.

Since Google introduced Google Play Store images in Android SDK Tools 26.0.0 now emulators comes with installed Google Play Store.

enter image description here

From 26.0.3

  • Adds a new tab in the extended window for Google Play Store images that displays the Play Services version and a button to check for updates to Play Services.

emulator settings

@K.Os 2017-06-20 12:03:48

I dont' have this "Google Play" tab in my extended window. What could be the issue?

@K.Os 2017-06-20 13:00:07

Okey, it seems that it is only in Android Studio 3.0 version

@K.Os 2017-06-20 14:18:41

My emulator version is 26.0.3

@user345280 2017-06-20 15:06:08

Do you use emulator with playstore installed? Check if you have sdk manager -> sdk platforms -> Android 8 -> Google Play ... system image installed. Download it. Create new emulator using that image.

@K.Os 2017-06-21 08:53:22

Yes, i was not having that part installed, but now i don't have the ability to set the emulated graphics to "Software" which i need to run the emulator. It is a common problem with "waiting for device to come online". Do you have any idea how i can enable this Emulated Performance option to choose something?

@K.Os 2017-06-21 09:24:33

Ok, this answer has resolved my issue stackoverflow.com/questions/42757928/…

@Rafael Oliveira 2017-06-21 22:46:29

It works on Android Studio 2.3.3. Create a New AVD, choose Nexus 5 or Nexus 5X (rows with Google Play icon), press next and then Download Android 8.0 (Google Play) or Android 7.0 (Google Play). Note the (Google Play) present at the SDK name. @user345280 might want to edit the answer and add this info.

@K.Sopheak 2017-06-28 04:03:55

I cannot download any app from playstore of emulator. When I click install any app, play store stop responding.

@hughjdavey 2017-12-25 11:50:45

Thanks @RafaelOliveira I was trying for ages to use a Pixel and wondering why it couldn't see my Google Play image... must be a Nexus 5 or 5X!

@Liron Yahdav 2018-02-09 23:27:28

Doesn't seem this answer is relevant to the question as they are asking about "Android 4.2.2 API 17" but this answer is only relevant for API >= 24.

@CoolMind 2019-12-12 14:39:18

@hughjdavey, it didn't help for 16-18 API. Probably stackoverflow.com/a/58433003/2914140 will help, I don't know.

@Mahesh N 2017-03-11 15:14:48

I faced the same issue. I updated my Android studio and used API 25 target as Android 7.1.1 and X86 and everything worked fine. I use Google play services and firebase for my project

@Ganesh Kanna 2016-12-22 05:10:26

My answer is not to update the Google play service but work around. Get the play service version of the emulator by using the following code

getPackageManager().getPackageInfo("com.google.android.gms", 0 ).versionName);

For example if the value is "9.8.79" then use the nearest lesser version available com.google.android.gms:play-services:9.8.0'

This will resolve your problem. Get the release history from https://developers.google.com/android/guides/releases#november_2016_-_v100

@Marc 2017-02-03 05:10:04

Can you please elaborate on what you mean by "use the nearest lesser version"? How do I "use" this? If I know that my Android Studio emulator uses version 8.0.87, then what exactly do I do with this information? Is there something in the manifest or gradle files I must set?

@Ganesh Kanna 2017-02-03 05:15:06

you can use 7.8

@abielita 2016-02-19 02:18:23

Based from Google documentation,

If you want to test your app on the emulator, expand the directory for Android 4.2.2 (API 17) or a higher version, select Google APIs, and install it. Then create a new AVD with Google APIs as the platform target.

Try to navigate to settings--> apps in your emulator and then find Google Play Services. Check the version number and use it in you build.gradle. To update it with the latest version, you can see it in these documentation and SO question.

@andreszs 2018-07-01 22:34:15

Nice advice, but anyway you cannot use an old Play Services version to test features that require a newer version.

Related Questions

Sponsored Content

62 Answered Questions

[SOLVED] 'App not Installed' Error on Android

8 Answered Questions

[SOLVED] Is Google Play Store supported in avd emulators?

9 Answered Questions

[SOLVED] Where do alpha testers download Google Play Android apps?

16 Answered Questions

26 Answered Questions

12 Answered Questions

43 Answered Questions

[SOLVED] Update Eclipse with Android development tools v. 23

Sponsored Content