By astiefel


2016-05-26 13:03:36 8 Comments

When I run react-native run-ios the build succeeds but I get the error below. I've checked all over the place but nothing seems to be working. Using sudo in front of the command does not help either. I am using Xcode 7.3, react-native-cli: 0.2.0, react-native: 0.24.1, node v5.11.0.

=== BUILD TARGET mobileTests OF PROJECT mobile WITH CONFIGURATION Release ===

Check dependencies

** BUILD SUCCEEDED **

Installing build/Build/Products/Debug-iphonesimulator/mobile.app
An error was encountered processing the command (domain=NSPOSIXErrorDomain, code=2):
Failed to install the requested application
An application bundle was not found at the provided path.
Provide a valid path to the desired application bundle.
Print: Entry, ":CFBundleIdentifier", Does Not Exist
/Users/astiefel/workspace/bosspayments/mobile/node_modules/promise/lib/done.js:10
      throw err;
      ^

Error: Command failed: /usr/libexec/PlistBuddy -c Print:CFBundleIdentifier build/Build/Products/Debug-iphonesimulator/mobile.app/Info.plist
Print: Entry, ":CFBundleIdentifier", Does Not Exist

    at checkExecSyncError (child_process.js:470:13)
    at Object.execFileSync (child_process.js:490:13)
    at _runIOS (runIOS.js:91:34)
    at runIOS.js:24:5
    at tryCallTwo (/Users/astiefel/workspace/bosspayments/mobile/node_modules/promise/lib/core.js:45:5)
    at doResolve (/Users/astiefel/workspace/bosspayments/mobile/node_modules/promise/lib/core.js:200:13)
    at new Promise (/Users/astiefel/workspace/bosspayments/mobile/node_modules/promise/lib/core.js:66:3)
    at Array.runIOS (runIOS.js:23:10)
    at Object.run (/Users/astiefel/workspace/bosspayments/mobile/node_modules/react-native/local-cli/cli.js:86:13)
    at Object.<anonymous> (/usr/local/lib/node_modules/react-native-cli/index.js:88:7)

30 comments

@base64k 2019-07-06 17:33:27

Try to look into previous error message happened before current error i.e., "CFBundleIdentifier”, Does Not Exist.

Fix previous error then this error should disappear.

I fixed previous duplicate symbols for architecture error when run react-native run-ios --simulator="iPad Pro (9.7-inch), then the problem gone.

@basbase 2019-04-30 20:30:22

I got this error when I ran react-native run-ios --scheme="customscheme" and the name of customscheme was misspelled.

@ChrisBorg 2018-11-06 19:34:30

If you're using Xcode 10, it may be due to an incompatibility with the latest build system of Xcode. Try switching to the legacy build system.

Open Xcode 10, File > Project Settings > Build System > switch dropdown to Legacy Build System.

Screenshot

@ibiren 2018-11-13 16:17:27

Thanks.. this worked for me.

@Brian 2018-11-24 19:45:03

This worked for me.

@Dwill 2018-12-13 15:36:22

Thanks, this worked for me!

@user710907 2019-03-07 06:48:29

For me It was ios dependencies managed by cocoapods.

Had to do this:

$ cd ToProject/ios

$ pod install

$ react-native run-ios

This worked for me

https://shift.infinite.red/beginner-s-guide-to-using-cocoapods-with-react-native-46cb4d372995

PS: Was trying to figure out work done by somebody else

@Mohammad Mirzaeyan 2019-03-24 10:44:44

running pod install said : [!] No `Podfile' found in the project directory.

@user710907 2019-03-27 11:41:18

@MohammadMirzaeyan assumption was you have done pod init and you have valid Podfile. Please do not downvote If you have don't have enough knowledge to counter your claims. Since It was somebody else's project as I mentioned I already had the PodFile. I have removed pod setup completely for folks like you.

@agenc 2019-02-22 08:28:58

All these solution suggests have not worked for me. I have just create a rn 0.58.5 project. And compared with my project. I saw there is no JavaScriptCore.framework under the Build Phasess > Link Binary With Libraries. After drag and drop JavaScriptCore react-native run-ios build succeeded.

JavaScriptCore.framework location: ‎⁨Macintosh HD⁩ ▸ ⁨Applications⁩ ▸ ⁨Xcode⁩ ▸ ⁨Contents⁩ ▸ ⁨Developer⁩ ▸ ⁨Platforms⁩ ▸ ⁨iPhoneOS.platform⁩ ▸ ⁨Developer⁩ ▸ ⁨SDKs⁩ ▸ ⁨iPhoneOS.sdk⁩ ▸ ⁨System⁩ ▸ ⁨Library⁩ ▸ ⁨Frameworks⁩

JavaScriptCore.framework

@Eli 2019-02-11 11:59:07

I'v tried all of these solutions but the one that has worked for me is:

  1. run react-native upgrade
  2. open xcode
  3. run the application in xCode
  4. works fine!

@javeedishaq 2019-03-27 11:33:04

thanks Eli, i have solved this issue by simply running "react-native upgrade"

@Rishav Kumar 2018-12-21 15:40:55

Just open the project in xcode app and it will automatically do all the imports and resolve issues. Worked for me, Xcode 10+

Edit 1: Open the iOS folder of your app not your global folder.

@codemt 2019-01-03 18:31:22

no it doesnt work , with RN 0.57 and Xcode 10.1 , for a brand new react native init app

@Katta Nagarjuna 2017-01-25 14:28:58

Open Project in Xcode

If Xcode > 9 run command react-native upgrade (this overwrites all your iOS configurations, use with caution!)

then

1.Go to File -> Project settings

2.Click the Advanced button

3.Select "Custom" and select "Relative to Workspace" in the pull down

4.Change "Build/Products" to "build/Build/Products"

Add package

5.click done, done

@KrakenDev 2017-02-17 19:37:27

This worked for me on xcode 8.2, fixed my problem thanks!

@holographix 2017-10-05 20:24:24

not working any longer in xcode 9.0 :(

@Dave Chambers 2017-10-10 09:00:24

For me it did work with Xcode 9, thankfully.

@Suraj Shingade 2018-01-09 20:52:05

Working on xcode 9+ too

@Pat Needham 2018-08-27 15:10:27

@SurajShingade I have Xcode 9.4 on my machine and can't find the "Project Settings" option within "Files". I only see "Workspace Settings...". Do you know where to access Project Settings? - imgur.com/a/SqAemnL - holding down the option key with File menu open doesn't show it either

@Toby Caulk 2018-09-02 01:14:44

@PatNeedham "Project Settings" was renamed to "Workspace Settings"

@Victor 2018-09-04 17:55:15

Can you please explain a little why this solution works ?

@Harry Moreno 2018-09-13 20:59:59

didn't work for me

@ChouW 2018-09-29 11:17:54

Works with xcode 10.0 : )

@jacurtis 2018-10-06 23:52:33

This is still the way to fix it as of xCode 10

@GeraltDieSocke 2018-10-24 17:06:11

It worked but why do I have to do this now for every single new Project I'm creating? Do you have an idea?

@Andrew Koster 2019-02-27 21:40:07

Doesn't work on Xcode 10.

@omarjebari 2019-05-07 16:04:32

If you dont want to have to do this for every new project in xcode you can go into Xcode->Preferences->(Locations Tab)->click Advanced then make the same change there.

@Dmitriy 2019-05-25 22:01:26

I saw that path was wrong in the output, but didn't know where I can fix that, thanks a lot for this comment, works even for the latest Xcode :)

@Ananda Bayu Putra Yudhistira 2018-11-15 18:44:58

Using this version is work for me with xcode 10.1

"react": "16.6.0-alpha.8af6728",
"react-native": "0.57.4"

@Daniel 2019-05-30 21:03:45

I honestly thought the above would be my savior and even that did not work. So upgrading, nah I am not convinced.

@Ibrahim Azhar Armar 2018-11-14 09:02:14

I am on XCode 10 with RN version 0.5.7, I tried almost all solutions and nothing worked.

After loosing a lot of time, finally the way I got it to working by doing the following

  1. Install previous version of react-native by running react-native init project --version [email protected]
  2. Open project/ios/project.xcodeproj and select Debug for command line builds
  3. Make sure to select the correct development certificate
  4. Run react-native run-ios once again, this time it must work.

@user3196599 2018-11-12 21:09:18

I fixed this by deleting /build/ and running react-native run-ios again

@Eran Or 2018-12-21 14:33:35

doesn't work for me

@user3196599 2018-12-22 03:31:22

@EranOr do you see Provide a valid path to the desired application bundle. in your console? Try the following xcode settings file => project settings, build system: legacy, derived data: project-relative, DerivedData in the input => advanced, custom, relative to workspace, build/Build/ in the first 2 inputs

@Mahesh Gaikwad 2018-12-28 13:37:10

@Mintberry It worked for me. Thanks

@Dheeraj D 2018-11-12 13:28:54

You can follow below steps to resolve this error:

Step 1

Open terminal

Step 2

cd node_modules/react-native/third-party

Step 3

ls

Copy or identify glog-{version}

Step 4

cd ../../../

Step 5

cd node_modules/react-native/third-party/glog-{version}

Step 6

./configure

I hope this will work !!!

@Lijith Vipin 2018-07-27 07:05:55

This is may occurs if you are missing config.h file,

For update config.h file,

1) Close your Xcode.

2) Open Terminal, go to your project's root folder and do:

cd node_modules/react-native/third-party/glog-{X}.{X}.{X}/

3) Run the configure script:

./configure

4) Open Xcode and try to run your app.

{X}: version number glog

@GSK 2018-09-07 14:50:57

Thanks!! this saved my time.

@Sergi Mansilla 2018-09-25 10:12:27

This worked for me.

@Dileepa Chandima 2018-10-11 05:29:49

:( not working for me

@Antonio 2018-10-18 09:05:17

I installed react-native from scratch, created my first project, but couldn't get that to work. This answer fixed my problem. I wonder why this happens, since it's a fresh and new installation

@Patrick Bassut 2018-10-21 01:07:46

Mind to explain why this is happening?

@Chandni 2018-10-22 12:18:33

Not working for me

@hxin 2018-11-12 16:49:14

This worked for me :)

@qasimalbaqali 2018-11-14 12:16:27

I'll pray for you day and night, thank you

@mat 2018-12-03 02:49:02

This worked for me. Fresh install of react-native 0.55, Xcode version 10

@nikhilgohil11 2019-01-18 09:13:21

works for me 👍🏻

@Scott Skiles 2019-02-15 22:53:59

... what if there is no configure script, as in 0.58?

@Bomber 2019-05-03 10:04:03

Get the error : checking whether we are cross compiling... configure: error: in /Users/macbookpro2018/sites/calendar/node_modules/react-nati‌​ve/third-party/glog-‌​0.3.5 configure: error: cannot run C compiled programs.

@Héctor Ramos 2018-09-24 22:53:18

The Print: Entry, ":CFBundleIdentifier", Does Not Exist message just indicates your project failed to compile or link. You'll need to go back through your output in order to find a hint about the actual root cause.

If you're having problems, look at the full build output, not just the last few lines. You may want to open the project in Xcode and hit ⌘B to build it. The build errors in Xcode should help you find the root cause of the failure.

@Mohammad Abbas 2019-03-07 13:15:10

Life savior. It was another issue indeed. Had my Schema renamed and the problem was solved.

@Serdar Değirmenci 2018-09-22 17:55:31

First run your project from Xcode then try to run from command line. That was the issue for me.

@Gururaj Jeerge 2018-09-20 14:48:31

The basic reason is deploying port is not free. Either you restart the device and get all ports free else run $ lsof -i :8081 and find the process which occupied port 8081. Kill the process which is using port 8081 by running $ kill -9 {process_which_is_running_under_8081}

@Ahmet Oğuz Koruyucu 2018-09-18 06:26:34

In my case, I pull project from git and it also includes the ios folder.

First i remove ios folder rm -rf ios then, react-native upgrade

@n13 2018-08-31 18:08:58

Adding one to the list of possible causes: xcodebuild could be corrupted.

In my case xcodebuild didn't do anything, so it never generated the ios/build/ directory, and the above error resulted.

I used 'which xcodebuild' on the command line, deleted it, and the error was gone

Just took me a while to realize that xcodebuild was bad - I looked at log messages and manually ran the xcodebuild command with the react native parameters - no output of any kind. No build messages, no error messages, nothing. Ran with no params - same....

Leaving this here as one more thing to check if this error message appears. Is your xcodebuild working?

@Vijay Dokrimare 2018-08-20 06:40:09

Delete the node modules and run 'npm install' in your project directory. Now you can able to run the project.

@Mike S. 2018-12-10 15:03:23

Just reinstalling node is not a solution

@raja 2018-07-18 10:07:49

For me it's due react-native compatibility issue with Xcode9.4. I resolved using the following steps. on my project /ROOT

  1. rm -rf node_modules
  2. react-native upgrade
  3. npm install
  4. react-native run-ios

SOLVES the issue, this thread helped me to understand the issue.

@sbastidasr 2016-11-30 13:56:21

Update React using react-native upgrade did it for me.

Disclaimer: this overwrites all your iOS configurations, use with caution!

@AlxVallejo 2017-06-29 16:09:37

overwriting all iOS files will overwrite any configurations you have made to your project. lol. use at your own risk disclaimer is the least you could do.

@Andrew Koster 2019-02-27 21:41:05

Would be helpful if someone could explain what "all your iOS configurations" means.

@ether_joe 2018-06-08 08:43:28

FIX FOR OSX EL CAPITAN

I'm still on OSX 10.11.6 with XCode 8.2.1 ... will upgrade someday but not today. I was able to get past the :CFBundleIdentifier error by downgrading react native to 52.0

yarn upgrade [email protected]

Got me a successful build on the simulator. Cheers!

@Flo 2018-05-22 21:17:20

Unfortunately, none of the mentioned solutions worked for me.

After trying out some of the answers from this issue, the following finally did work:

As one or more of the required iOS third-party libraries were not properly downloaded to ~/.rncache (meaning the files in there were corrupted and could not be unzipped), I removed the content of this folder, ran react-native run-ios again, and this eventually did the trick.

@Lindoélio Lázaro 2018-04-11 17:55:49

Adding, it works for me, when nothing above fixes:

  1. Install react-native-git-upgrade and update your project. npm i -g react-native-git-upgrade && react-native-git-upgrade
  2. Open Xcode -> File -> Project settings -> Advanced.
  3. Select "Custom", then select "Relative to Workspace" and then click done, done.
  4. Update your CLI. npm i -g react-native-cli
  5. Update your Nodejs 8 and NPM. nvm install --lts and nvm install-latest-npm
  6. Remove ios/build and node_modules (in your project root path)
  7. Proceed again with npm install and react-native run-ios, and give me a hug :-)

It finally works here.

  • Mac OS High Sierra 10.13.4
  • Xcode 9.3
  • NPM 5.8.0
  • Node 8.11.1
  • RN 0.55.2

@Oleg 2018-04-04 07:39:10

For me it was a problem with accidently setting up modules using Cocoapods & react-native link at the same time.

Don't mix those two for same modules!

@Isaac 2018-12-21 08:26:14

So how to go around with this?

@Buruiană Cătălin 2018-12-22 14:15:18

@Isaac nuke cache and install with either cocoapods / react-native link, depending on how is your project set up

@damianfabian 2018-03-24 07:23:58

After a couple of months trying all the answers, I finally update my OS to Sierra, Update XCode to the latest version and with that all the errors disappear. Hope this could help some folks out there!

@Tim 2018-01-19 16:29:24

For [email protected] the following did the trick for me:

1) Check your paths, open your .xcodeproj (not .xcworkspace) file and:

  • go to File > Project Settings > Advanced

  • custom > Relative to workspace

  • set the products path to 'build/Build/Products'
  • set the intermediates path to 'build/Build/Intermediates'
  • press done and save your changes

2) Run rm -rf ios/build in your project's root directory

3) Close your react packager

4) Run react-native run-ios again

@Raju yourPepe 2018-03-19 13:55:30

Also works on : "react": "16.2.0", "react-native": "0.52.0",

@cayleyh 2018-09-20 18:59:56

This solved issue for me after adding dependencies via Pods to the iOS part of our RN project. Except: I made this change in the .xcworkspace config.

@Frank Goortani 2019-03-30 18:22:15

Removing the build folder did the trick for me

@Daniel 2019-05-30 20:37:45

@cayleyh, this did not for me exactly but it did remove the Splashscreen error, so are you saying you followed Tims step except you did it inside of xcworkspace?

@Usman Awan 2017-08-26 09:04:13

I also came across this issue as well and I found a way to fix it

Here is what i did:

1) Make sure there is no white spaces in the file directory.

2) cd project directory

3) run command react-native upgrade

4) Go to native ios folder and open xcode project.

5) Go to File > Project Settings > Advanced...

6) select custom > Relative to workspace

7) products path should be 'build/Build/Products'

8) intermediates path should be 'build/Build/Intermediates'

9) now try running command in your terminal react-native run-ios

I hope that this solutions will help some of us facing this issue.

@Lingbo Tang 2017-12-12 19:03:15

Good work, I solved my problem on react native 0.51

@MH-Li 2018-03-22 12:07:31

not worked for me still i have this error :Entry, ":CFBundleIdentifier", Does Not Exist

@lutakyn 2019-03-25 14:08:22

this worked for me but I get no bundle url present

@Nisarg Thakkar 2017-08-11 13:25:56

When you run npm install command some time internet issue problem, Files in node_modules\react-native\third-party is not properly downloaded so please check this is properly downloaded or not if no please remove node_modules and install it again

then run react-native run-ios command

@PDM 2017-07-06 13:21:58

This worked for me. Follow steps https://facebook.github.io/react-native/docs/getting-started.html (Building Projects with Native Code).

Before running react-native run-ios command, download boost node module from https://sourceforge.net/projects/boost/files/boost/1.63.0/ and replace node_modules/react-native/third-party/boost_1_63_0

Now run react-native run-ios command

Related Questions

Sponsored Content

0 Answered Questions

How to resolve CFBundleIdentifier Does Not Exist error?

0 Answered Questions

'cfbundleidentifier", does not exist Ofter Updating Xcode 10.1

  • 2018-12-01 09:21:26
  • Peymam Hosseini
  • 166 View
  • 0 Score
  • 0 Answer
  • Tags:   react-native

2 Answered Questions

2 Answered Questions

0 Answered Questions

React native for iOS - CFBundleIdentifier does not exist

  • 2018-10-10 14:45:00
  • Lucas Navarro
  • 619 View
  • 2 Score
  • 0 Answer
  • Tags:   ios react-native nem

0 Answered Questions

react-native iOS CFBundleIdentifier

  • 2018-09-11 10:04:10
  • GI HYUN NAM
  • 173 View
  • 0 Score
  • 0 Answer
  • Tags:   ios react-native

1 Answered Questions

React Native iOS -- CFBundleIdentifier", Does Not Exist

  • 2017-08-31 13:29:14
  • Hemant Solanki
  • 928 View
  • 2 Score
  • 1 Answer
  • Tags:   react-native

1 Answered Questions

[SOLVED] App is not running on iOS for latest version of react-native

  • 2017-07-31 06:28:11
  • Ashish-Systematix
  • 1724 View
  • 2 Score
  • 1 Answer
  • Tags:   react-native

0 Answered Questions

No devices are booted. Print: Entry, ":CFBundleIdentifier", Does Not Exist

  • 2017-06-14 07:48:18
  • huangxbd1990
  • 718 View
  • 3 Score
  • 0 Answer
  • Tags:   ios react-native

Sponsored Content