By P_M


2018-08-10 11:52:52 8 Comments

I am trying to run heroku on my terminal with heroku login command but everytime it show me this message

Install the Heroku CLI from https://cli.heroku.com

If i do heroku -v , heroku run rails c in all command it show me this same error

i did Gem install heroku it id done successfully.

than after same error everytime

Please help me to find solution about it.

2 comments

@Vishal 2018-08-10 13:20:23

If you want to run Heroku CLI, you need to install heroku in your ubuntu system. on ubuntu 16+ versions you can install heroku cli with below command.

sudo snap install heroku --classic

you can't use any heroku command until its installed in your system

@P_M 2018-08-13 06:02:06

I did this already it show me that heroku is already installed but after then i am facing same error as above in the question.

@Vishal 2018-08-13 06:10:02

@P_M uninstall gem heroku gem uninstall heroku with this command. then check the version of heroku.

@P_M 2018-08-13 06:15:11

again getting the same error like it show that it is uninstalled but it fills it is still there ?

@Vishal 2018-08-13 06:16:44

can you please add the log of gem uninstall heroku ? with this command you installed heroku gem in your whole system

@P_M 2018-08-20 10:46:54

I used curl cli-assets.heroku.com/install-ubuntu.sh | sh command and it says eroku installed succesfully, After that i did herou -v again it show me "Install the Heroku CLI from cli.heroku.com"

@Vishal 2018-08-20 10:48:25

try this line sudo wget -qO- https://toolbelt.heroku.com/install-ubuntu.sh | sh and then fire heroku apps command

@1533805338 2018-08-10 12:10:44

You can't install the heroku CLI through rubygems (gem install).

You have to install following the guide here: https://devcenter.heroku.com/articles/heroku-cli#download-and-install

On Ubuntu install it with the following command: sudo snap install heroku --classic

On MacOS, if you have Homebrew installed, run brew install heroku/brew/heroku, otherwise download an installer and install Heroku using it.

@P_M 2018-08-20 09:59:40

i did it still getting same msg => Install the Heroku CLI from cli.heroku.com

Related Questions

Sponsored Content

15 Answered Questions

11 Answered Questions

[SOLVED] Should I check in node_modules to git when creating a node.js app on Heroku?

1 Answered Questions

[SOLVED] Heroku CLI unresponsive on Ubuntu 16.04

0 Answered Questions

Error in Bash when installing Heroku gem

3 Answered Questions

[SOLVED] Deploy ember-cli + rails app in heroku?

1 Answered Questions

[SOLVED] Heroku Authentication Faulure in rails system call

1 Answered Questions

Installing rails 3 in ubuntu 11.04

4 Answered Questions

2 Answered Questions

3 Answered Questions

[SOLVED] Installing Heroku on Ubuntu Lucid Lynx is broken

Sponsored Content