By Jack A


2019-03-13 00:27:41 8 Comments

I've tried all the other questions and searched everything on this that I could already, a lot of the other questions involved existing apps that were being updated or people with developer accounts but this is like my second time using Xcode and it has worked before.

This just happened out of nowhere. I keep getting these two errors and it allows me to run simulators but not build onto my iPhone:

  1. Automatic signing is unable to resolve an issue with the "LearningSpriteKit" target's entitlements. Automatic signing can't add the application-identifier and keychain-access-groups entitlements to your provisioning profile. Switch to manual signing and resolve the issue by downloading a matching provisioning profile from the developer website. Alternatively, to continue using automatic signing, remove these entitlements from your entitlements file and their associated functionality from your code.

  2. Provisioning profile "iOS Team Provisioning Profile: #####.LearningSpriteKit" doesn't include the application-identifier and keychain-access-groups entitlements.

13 comments

@ScottishUser 2019-03-18 22:06:40

One other potential source of this error, if you do not have a valid signed development certificate setup within your Xcode environment it will through similar errors as posted by OP.

you can check out your development certs status following the apple link here

@Renan Aguiar 2019-03-19 01:47:05

i use the free account.. by following whatever people say, now i get a error about waiting 7 days..... im not going to pay for testing it on my device.

@CodeChanger 2019-03-13 10:36:01

EDIT

As per latest update Apple successfully resolved Automatically Code Sign with Free Account issue.

I tried it and I can confirm its resolved.

Please try at your end.

I am also facing the same issue while I am creating a new Profile from XCode and if I go to other projects and check over there also I am facing the same issue as below.

enter image description here

Due to this issue none of my project able to build with old profile & certificate.

The strange issue so I checked newly created Profile and compare with old one and I found that App ID is unknown as well as there are no Entitlement details in newly created profile.

Check below screenshots of Old and New profile comparison:

Old Profile:

enter image description here

New Profile:

enter image description here

So means it's not able to set App Id and Entitlements in the new profile. Which will result to not work all old profile and giving the same error in all projects.

Temporary Workaround:

Step1: Go to Provisioning Profile folder (path: ~⁨Library⁩ ▸ ⁨MobileDevice⁩ ▸ ⁨Provisioning Profiles⁩).

or use a shortcut to jump directly into this folder like CMD + SHIFT + G and enter ~/Library/MobileDevice/Provisioning Profiles it will redirect your finder directly on Provisioning Profiles folder.

Step2: Short folder by Date Modified.

Step3: Check profile with Unknown App Id and delete all unknown profile.

Step4: Come back on XCode and check all old project will work as expected.

Note: Make sure new app which causing this problem keep that project closed otherwise it will create a new profile with Unknown App Id.

Hope this will helps and apple will solve this bug soon!

@Franky 2019-03-13 20:39:45

Where is that ~Library path, please?

@Bilfred 2019-03-13 21:52:28

@Franky ~/Library⁩/⁨MobileDevice⁩/⁨Provisioning Profiles. Although this fix does not work for me (and others, as seen in other answers). Your mileage may vary.

@Franky 2019-03-13 21:58:48

@Bilfred My macOS X is Sierra 10.13.6 and there isn't such a path in ~Library!

@Bilfred 2019-03-13 22:01:39

I'm on Mojave, so I'm not sure if the path changes on Sierra...

@CodeChanger 2019-03-14 05:03:08

@Franky Use shortcut CMD+SHIFT+G (go to directly on folder) and enter ~/Library/MobileDevice/Provisioning Profiles this path you will directly jump to that location and delete profile with unknown appid.

@Franky 2019-03-14 08:07:30

Thank you, please note that, there is only one ..mobileprovision file in that folder and that file contains three sections: iOS TEAM PROVISIONING PROFILE, CERTIFICATES and PROVISION DEVICES. In the iOS TEAM PROVISIONING PROFILE there is a line with App Unknown ID: as in this image. Now should I delete the file?

@CodeChanger 2019-03-14 08:48:21

yes delete that file and one more thing try again apple resolved above mention issue.

@Franky 2019-03-14 11:02:51

Thank you, but I still have that issue. :(

@CodeChanger 2019-03-14 12:02:23

Its clearly says that provided bundle identifier already created so you need to create new bundle id to resolve this issue.

@Mitch Wolfe 2019-03-15 23:47:47

Here is a temporary workaround

  1. Change Bundle Identifier : Target > General > Identity > Bundle Identifier (Set this to a different value than it is right now)
  2. Change Version : Target > General > Identity > Version
  3. Disable debug executable : Product > Scheme > Edit Scheme, (Uncheck the box that says "debug executable")
  4. Delete Provisioning Profiles: ~/Library/MobileDevice/Provisioning Profiles delete everything in this folder

You now should be able to build and run projects on simulators and devices.

@Renan Aguiar 2019-03-16 09:35:17

now i get it: Unable to launch /private/var/containers/Bundle/Application/52553D96-4B6A-468‌​0-B77C-C04895B7759C/‌​dois.app

@yeralin 2019-03-13 23:35:11

This issue is related to https://bugzilla.mozilla.org/show_bug.cgi?id=1534145

A representative from Apple estimated 558000 certificates to become invalidated: https://bugzilla.mozilla.org/show_bug.cgi?id=1533655

GoDaddy, Google, Apple and Facebook (that would explain why FB was glitchy today) are affected.

They are working on resolving the issue right now.

That would explain our problems, folks!

UPD: Issue has been resolved. Try to refresh your projects.

@Jake 2019-03-13 23:39:39

Glad to hear Apple is dealing with this/has spoken out about the issue

@Tanner H. 2019-03-13 23:46:19

How long should this take? I'm looking to deploy my app to my watch as soon as I can.

@David Gish 2019-03-14 00:01:36

Invalidated certs don't explain why new ones Apple is issuing are missing the necessary entitlements.

@Bilfred 2019-03-14 00:30:41

@DavidGish from what I can gather from the report, they're actually not issuing any certificates at the moment. On 2019-03-7 they stopped issuance of TLS certs, unsure if or how that applies.

@Linus 2019-03-14 14:12:14

Are there any updates to this? I feel like this should have highest priority. Any new ideas for workarounds?

@Mr Heelis 2019-03-14 15:02:09

this is the biggest cluster fumble I've ever come across in my life... to deliberately destroy $80+ million worth of certificates over some pedantic nonsense is joke... I just hope this is a lie and they were actually hacked and shut the whole thing off

@Jack A 2019-03-14 20:39:26

Apple fixed it.

@bezoadam 2019-03-14 22:56:36

Right now I am not getting this error but instead I am getting "iPhone has denied the launch request".. any ideas?

@Qbyte 2019-03-14 23:58:38

@bezoadam I'm also having this problem. Unfortunately I have no fix but just a workaround: Edit Scheme... -> Run -> Info -> "disable" Debug executable. This means e.g. that you cannot use breakpoints. Hope this helps!

@Fabio Felici 2019-03-15 14:40:04

By looking at the phone logs I see these messages when debug executable is selected: SpringBoard [bundleidentifier] Provision violated for watchdog process-exit: <FBSProcessResourceProvision: 0x2812ee680; allowance: <; FBSProcessResourceAllowance; type: realTime; timeValue: 5.0s>; violated: YES> SpringBoard Not terminating "bundleidentifier" for violated provision because: "process is being debugged"

@karabara 2019-03-15 20:03:37

how to refresh project? still getting error

@yeralin 2019-03-15 20:05:14

@bezoadam I also started getting "iPhone has denied the launch request" Idk what exactly helped, but I tried (1) restarting laptop, (2) restarting iphone, (3) deleting app from iphone and reinstalling it again, and then eventually error went away

@N. Der 2019-03-16 00:53:37

@karabara any luck finding on how to do it?

@Q The Great 2019-03-16 21:57:01

I continue to have this problem.. What do I do I have tried deleting world wide developer certificate and changing bundle identifier. Nothing is working

@Qbyte 2019-03-17 21:54:51

@FabioFelici Hello everyone, I've created a StackOverflow room to chat about the "iPhone has denied launch request" issue: chat.stackoverflow.com/rooms/190218/…

@Alirezak 2019-03-14 19:54:02

Here is the solution:

  1. let xCode be open.

  2. select your developer account and let the error appears again.

  3. Go to keychain App

4.a) Goto certificate section

4.b) remove All (valid and invalids) certificates ( I have 3 valid and many invalid!)

remove certificates

  1. After removing the last certificate, mac os will recreate a new certificate for the active developer account automatically

  2. Run your app in your iDevice. You need to enter your system password to add newly created certificate into the Keychain.

If in second run it says

Your iPhone has denied the launch request

just goto:

Product > scheme > edit scheme: uncheck "debug executable"

I hope it solves your problem.

@Renan Aguiar 2019-03-14 21:40:40

it doesnt! i cant debug or use location on the device

@Franky 2019-03-15 00:35:26

Hi, thanks. How to go to "keychain App" please? What path?

@David Gish 2019-03-15 05:00:21

You've probably found it by now, but the Keychain Access app is in Applications->Utilities

@Renan Aguiar 2019-03-15 15:26:50

i still cant debug using iphone with those answers

@Aaron T 2019-03-14 16:29:11

I am finally able to deploy to our iOS devices again. Here are the steps I took to make it work.

First, I followed all 10 steps in Zameer's answer here. I have copied them below:

  1. Open your project in XCode.
  2. Select your project from the project navigator and then select your target from the column.
  3. Click on the General tab and under the Signing section, make sure "Automatically manage signing" is enabled.
  4. Click on the Capabilities tab and turn On both the "App Groups" and "Keychain Sharing" settings. This might raise an "Automatic signing failed" popup error, just click cancel to make it go away.
  5. This should generate a entitlements file for you named nameProject.entitlements in the project folder of your project navigator.
  6. Move this entitlements file outside of the folder, just below your project file.
  7. Select your target again and return to the Capabilities tab to turn Off both the "App Groups" and "Keychain Sharing" settings. This again might raise an "Automatic signing failed" popup error, just click cancel to make it go away.
  8. Now select your project above the target and go to Building Settings tab.
  9. Scroll down to the Code Signing Identity setting under the Signing header and select iOS Developer from each drop down.
  10. Under the above Signing header, double click the text field beside the Code Signing Entitlements and enter the name of your entitlements file, nameProject.entitlements.

After completing those 10 steps, the 2 red entitlement error messages in XCode went away and I was able to build and deploy the XCode test app to the iPhone and run it.

Although that XCode test app could build and deploy, I develop on a PC using Xamarin and I was unable to deploy my Xamarin.iOS application to my iOS devices and kept getting an error in Visual Studio: the executable was signed with invalid entitlements. I did the following things and now I can deploy my Xamarin app and run it on my iOS devices:

  1. I deleted the provisioning profile from the Mac in the ~/Library/MobileDevice/Provisioning Profiles directory. XCode immediately generated a new provisioining profile (I'm not sure if this step was necessary but I'm just writing it because that's what I did).
  2. I changed my Xamarin.iOS.csproj file and removed Entitlements.plist from the CodesignEntitlements element so it now just looks like <CodesignEntitlements></CodesignEntitlements>. Visual Studio automatically added two elements to the same propertygroup in the project which are probably not necessary but I thought I'd mention: <CodesignExtraArgs /> and <CodesignResourceRules />.

@Fedorov7890 2019-03-14 10:33:56

NOTE: This solution still works as on 2019/Mar/14 15:00 UTC+0
SOLUTION: no XCode reinstallation required. I used a brand new free AppleId, but later checked with my old AppleID and it also works. Remove old iOS developer certificates by hand in macos using Launchpad->Other->Keychain Access,

Remove certificates

and purge old XCode build data and profiles:

mkdir -p ~/ProvisioningProfileBackup
cp -R ~/Library/MobileDevice/Provisioning\ Profiles ~/ProvisioningProfileBackup
cd ~/Library/MobileDevice/Provisioning\ Profiles
rm -rf *
cd ~/Library/Developer/Xcode/DerivedData
rm -rf *

Also I removed and then added back AppleIDs in XCode: menu XCode->Preferences->Accounts and rebooted both Mac and iPhone.

If you have a “iPhone has denied the launch request” problem, the solution is https://stackoverflow.com/a/54990369/3824328. In short, you need in XCode to go to menu Product->Scheme->Edit Scheme... and select Executable: ask on launch

@Renan Aguiar 2019-03-14 15:42:38

for denied lunch if i remove the debugger option, i cant debug while using the device. only simulator

@Fedorov7890 2019-03-14 15:54:18

@RenanAguiar you don't need to remove debugger option, just change 'Executable' from the drop-down list to "ask on launch". See link in my post that shows how to do that in pictures.

@Renan Aguiar 2019-03-14 16:19:50

when i do that, same thing happens. i cant see the debugger icons like step and location. only on the simulator

@Renan Aguiar 2019-03-14 16:34:18

now i always get unable to launch...

@Fedorov7890 2019-03-14 17:36:42

It looks like debugger is not fully functional. I can get console output from device, but breakpoints don't work; neither do step over / step into commands

@FractalSpace 2019-03-14 23:56:22

I can confirm that the above answer worked for me. Specifically, the app is built, singed and downloaded to my iPhone. I am using free developer's account. (March 14, 2019)

@FractalSpace 2019-03-14 23:59:16

I did have this “iPhone has denied the launch request” issue, which went away with the above "ask to launch" workaround, but it is still annoying.

@Husein Behboodi Rad 2019-03-14 07:33:17

It seems that this problem has been resolved now and the personal accounts can resign their apps automatically again.

Regarding to @Paul answer, it is not related to uninstalling Xcode. Its is fixed from server side.

The only thing that is required is removing Apple Developer Certificate (for the personal account) from your keychain, so that Xcode retry to generate and download new one.

@Fedorov7890 2019-03-14 08:57:01

Still can not install on the device. Even with new free appleid and certificate

@Husein Behboodi Rad 2019-03-14 09:03:57

Did you removed all certificates?

@Fedorov7890 2019-03-14 09:05:32

Yes I did, besides I purged ~/Library/MobileDevice/Provisioning\ Profiles and ~/Library/Developer/Xcode/DerivedData and restarted iPhone

@Fedorov7890 2019-03-14 10:27:23

Finally it works with this workaround stackoverflow.com/a/54990369/3824328

@Franky 2019-03-14 14:28:34

Where to remove certificates? What path?

@Fedorov7890 2019-03-14 15:36:14

@yycking 2019-03-14 03:25:43

Workaround: change Bundle Identifier and/or Version.

@Chase Patterson 2019-03-14 05:52:07

Works here. If it doesn't, try disabling "Automatically manage signing," delete the offending provisioning profile, change Bundle Identifier, enable auto signing, then add your team.

@Fedorov7890 2019-03-14 08:24:41

Does not work. It gives no errors or warnings, but the app refuses to launch on the device, like described here stackoverflow.com/questions/45421179/…

@Franky 2019-03-14 14:27:48

What to write for Bundle Identifier and Version, please? I'm self-employed developer working at my own office. I wrote two a string and a number respectively for them and the sign errors are vanished, but I think can't run my app using the iOS kit (on Qt Creator)!

@david 2019-03-14 15:56:56

@Fedorov7890 To get the app launching on the device, you need to disable the debug executable checkbox in the scheme as explained in this comment iPhone has denied the launch request. This work around works for me after removing my dev account, cleaning up ~/Library/MobileDevice/Provisioning Profiles and changing the bundle identifier.

@Fedorov7890 2019-03-14 16:00:51

@david Thank you, I've already found an alternative solution without disable debug executable, stackoverflow.com/a/55160300/3824328

@Paul 2019-03-14 05:45:44

For me, it finally works again. Either they just fixed it or any of my other steps helped:

  1. Uninstall Xcode and all related files (using AppCleaner)
  2. Install Xcode via the App Store
  3. Change the Bundle Identifier of the App
  4. Remove all "iOS Developer" Keys from Keychain

@Ava 2019-03-14 13:46:21

This fixed the problem for me at first, but then it came back again a few minutes later

@Jake 2019-03-13 19:19:00

Maybe this might help? Apple Developer Forums

Talks about Apple refusing to build iOS applications under SDK 12 as of March 2019 (OP from Dec 2018).

I've not yet tried this but it may be linked to the issue, I have a free developer account and am also experiencing this bug.

Here's a screenshot incase the link changes (screenshot 1 below).

Edit: this is the link from the first screenshot (screenshot 2 below)

1sdk_12_issue

2iphone_xs_max_support_image

@Ali Beadle 2019-03-13 19:34:38

Interesting, but we have XCode 10.1 showing this problem and 10.1 does support SDK 12.

@Jake 2019-03-13 19:38:43

Okay sure thing, I've managed to get a temp workaround by cleaning the project in Xcode and only running in debug via my IDE (I'm using VSC) through a simulator.

@Ali Beadle 2019-03-13 20:07:46

As the OP said, simulators seem unaffected by the problem. It appears to only affect real devices.

@Jake 2019-03-13 21:54:33

Yeah I haven't been able to load on a physical device. Hope Apple fixes this soon.

@Oleh Zayats 2019-03-13 12:32:35

Seems Apple broke the automatic signing system. I was playing around with a few projects and Xcode just fetches the incorrect profile

This worked for me:

  1. Turn off "Automatically manage signing" in project target
  2. Go to ~/Library⁩/⁨MobileDevice⁩/⁨Provisioning Profiles⁩
  3. Remove previously downloaded profiles
  4. Turn on "Automatically manage signing" again

@Fedorov7890 2019-03-13 13:09:07

For me that does not work. Also I think you mean ~/Library⁩/⁨MobileDevice⁩/⁨Provisioning Profiles⁩

@Oleh Zayats 2019-03-13 18:30:20

@Fedorov7890 Yep, corrected. What message do you see?

@Fedorov7890 2019-03-13 19:04:27

Remark: looks like it works for projects created yesterday and earlier, but not for today's project

@Chase Patterson 2019-03-13 21:30:08

Didn't work for me, even for old projects.

@N. Der 2019-03-13 23:02:55

Tired that, not working.

@arvnq 2019-03-14 00:13:36

Try quitting xcode after turning off the signing

@Ahamed Abdul Rahman 2019-03-14 03:37:03

For me, its worked. I was building 'Integration App' for Appium.Thanks for the solution, Oleh Zayats.

@Bold Lion 2019-03-14 13:46:12

This worked for me, for now.

@David Gish 2019-03-13 16:19:51

I restored a profile from Time Machine when this was working and upon launch, Xcode immediately deletes and replaces it with a new one. The key difference seems to be the old profile has the get-task-allow entitlement while the new one has NO entitlements. This is definitely broken at Apple's end.

Edit: The entitlements should also include a keychain access group, but again, no entitlements at all. Should look like:

Good entitlements

Related Questions

Sponsored Content

0 Answered Questions

0 Answered Questions

Unity Xcode Build "Automatic signing is unable to resolve an issue"

18 Answered Questions

40 Answered Questions

[SOLVED] dyld: Library not loaded: @rpath/libswiftCore.dylib

  • 2014-09-24 18:40:24
  • user3751185
  • 162554 View
  • 360 Score
  • 40 Answer
  • Tags:   ios xcode swift

23 Answered Questions

[SOLVED] Xcode 7.2 no matching provisioning profiles found

18 Answered Questions

21 Answered Questions

[SOLVED] Xcode 5: Code signing entitlement errors

Sponsored Content