By ctrl-alt-delor


2015-04-18 18:43:07 8 Comments

I have a laptop with wifi not working: I can detect hardware with lshw and lspci, but that is it. network-manager is not showing it.

lshw -numeric -C network reports

*-network UNCLAMED
description: Network contriller
product: Intel corporation [8086:8B4]
vendor: Intel corporation [8086]
physical id:0
bus info: [email protected]:02:00.0
version: 93
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: latency=0
resources: memory: c1000000-c1001fff

From here http://linux-wless.passys.nl/query_chipset.php?chipset=Intel I see that it needs driver iwlwifi. I have installed firmware-iwlwifi.

lspci shows

…
00:16.0 Communication controller: Intel Corporation Device 9cb1
…
02:00.0 Network controller: Intel Corporation Device 08b4 (rev 93)

(apology for the truncation, it is on another device, with no network)

If I do rfkill list all I get

0: hci0: Bluetooth
    SoftBlocked: no
    HardBlocked: no
1: ideapad_wlan: Wireless LAN
    SoftBlocked: no
    HardBlocked: no
3: ideapad_bluetooth: Bluetooth
    SoftBlocked: no
    HardBlocked: no

If I press the airplane button then id 1 goes to SoftBlocked: yes, then back to no, on next press.


Output of uname -srmo

Linux 3.2.0-4-amd64 x86_64 GNU/Linux

Distro: Debian wheezy (7)

1 comments

@ctrl-alt-delor 2015-04-18 22:09:15

I fixed it by upgrading the kernel to 3.16, it is in wheezy-backports, it is also in jessie, expected to be released on 25 Apr 2015 (latter this month).

Thanks to @Nasha 's comment, I followed your support link to intel's site, and found the driver (7260 ac), it says there, that I need a newer kernel, at least 3.10, so I found that there is a 3.16 in wheezy-backports. I installed it, and rebooted, it now works. No need to manually download firmware as well.

Related Questions

Sponsored Content

2 Answered Questions

Wifi drivers not installing

1 Answered Questions

1 Answered Questions

[SOLVED] How to install network drivers for Void Linux on a x200 thinkpad?

  • 2018-05-29 23:39:30
  • digitalXmage
  • 131 View
  • 0 Score
  • 1 Answer
  • Tags:   wifi

3 Answered Questions

wifi not working, lenovo G50-70

  • 2018-05-05 23:14:15
  • supermario
  • 311 View
  • 0 Score
  • 3 Answer
  • Tags:   linux wifi

1 Answered Questions

[SOLVED] Lubuntu 16.04 Wifi not working

  • 2018-04-04 16:53:06
  • ZaZen
  • 684 View
  • -2 Score
  • 1 Answer
  • Tags:   wifi lubuntu

1 Answered Questions

[SOLVED] Debian wifi not working

  • 2017-10-15 12:42:28
  • Marko vlaić
  • 497 View
  • 0 Score
  • 1 Answer
  • Tags:   debian wifi

0 Answered Questions

WiFi Drivers Not Working

0 Answered Questions

Broadcom BCM94352HMB wifi card not working

1 Answered Questions

[SOLVED] USB wifi not working

1 Answered Questions

[SOLVED] Wifi not working

Sponsored Content