By SpecialBomb

2015-12-29 18:46:22 8 Comments

I have recently bought an ASUS Wi-Fi adapter (USB-N13), and I seem to be having some trouble with it. Every so often, the Wi-Fi connection just stops working, but the indicator says that I'm still connected. I am using the firmware-realtek drivers for the adapter, and not the official ones, as they are difficult to install. I am also using Debian 8 Jessie, if you need to know my OS.


Bus 004 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 002: ID 0b05:17ab ASUSTek Computer, Inc. USB-N13 802.11n Network Adapter (rev. B1) [Realtek RTL8192CU]
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0738:1705 Mad Catz, Inc. 
Bus 001 Device 005: ID 04b3:301b IBM Corp. SK-8815 Keyboard
Bus 001 Device 003: ID 04b3:301a IBM Corp. 
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


@Rui F Ribeiro 2015-12-29 19:17:25

Important note: wifi chipset/USB sticks and internal wifi chipsets should be evaluated concerning their Linux compatibility and not needing to compile things before buying them.


For creating an wifi AP, the most cost wise path is buying an openWRT compatible AP.

For having a more stable wifi connection, choose a notebook/iOT/router device where the WiFi chipset is not internally connected to the USB controller. Avoid realtek.

If having an internal realtek card, try to buy an internal replacement card compatible with the model of your machine based in atheros, broadcom, ralink or Intel, in that order of preference - I suspect Broadcom has the better quality/cost ratio, your mileage may vary. (Important note: your vendor might whitelist wifi card models, in which case you are at mercy of compatible models - HP, Dell and Lenovo are known for this, so check the brand/model of the notebook if you already own it)

Adenda: Usually users report the realtek chipsets work "well" in Windows because Windows drivers have nasty hacks to work around some of the bugs.

However, while they work "better", they usually work at much reduced speed/ranges and still have got problems, and in many realtek implementations, some of the more serious hardware bugs cannot be worked around.

Concerning realtek Chipsets

The ID 0b05:17ab and the string [Realtek RTL8192CU] in your lspci output, confirms your wifi device is indeed a rebranding of the Realtek RTL8192CU 802.11n model.

I also had the Realtek RTL8192 in my ARM server/Lamobo R1 at home, which is the same chipset as your ASUS USB-N13. (or put it other way, ASUS USB-N13 rev B is an ASUS rebranded RTL8192CU).

Believe me that I have tried to do something with it for quite a while as you can see in post #23 of this thread

The chipset is junk. People who own the Lamobo R1 have totally given up in doing something useful with it.

Firmware bugs, drivers bugs, bugs in energy management that are prevalent and ubiquitous across most of the cheap Realtek chipsets revisions/models, that oblige you to use it at slower performances than the allowed by the protocols.

Even after trying to work around the bugs, you have frequent and inexplicable crashes - or more exactly, the wifi module misbehaves and then you are left with the filesystem in read only mode wondering what happened.

I also bought 5dB antennas to try to improve it.

I even also bought again a realtek nano USB wifi that proved to be even more disastrous; it started heating and stopped dead in it´s tracks for a few seconds at a time both in Windows and Linux systems.

The efforts and hassle to make realtek wifi cards working "properly" are not worth the trouble.

I gave up on trying to use my R1 with a realtek as an AP and bought instead an AP from TP-LINK - an Archer C7 v2 which I flashed with OpenWRT. (

If you still want to have a go at the Realtek/ASUS, if in hostapd mode, in /etc/hostapd.conf you have to use


which makes you lose some speed.

Using it either as hostap or as client, you also have to configure the loading of the module in /etc/modprobe.d/rtl8192cu.conf to work around some of the bugs:

options rtl8192cu  rtw_power_mgnt=0 rtw_enusbss=1 rtw_ips_mode=1

Reboot then the device for the options to take effect.

General advice about WiFi technology

As last comments, specially in WiFi, you have to pay good money to have good chipsets that work as promised.

Normally it is a requirement to have external antennas, especially to use the chipset in AP mode.

Please do take note this chipset only supports the 2GHz band. As in most parts of the civilised world the 2GHz band is pretty crowded, either you have a good signal, or you are pretty much in trouble. So this reinforces the need for external antennas.

Even if using 5GHz, as the 5GHz protocol was designed to travel smaller distances, external antennas are a must.

Also beware that whilst you might got away with only one antenna in the 2.4GHz band, you need at least two antennas when dealing with 5GHz.

I have good experiences using Ralink and Atheros based chipsets, realtek ones not so much.

UPDATE: I used to have a realtek without shielding in my iOT device, that was not used because it was so bad. I also had crashes almost every week even with the thing blacklisted by software.

Cut it physically from the board, the board can go for months up without misbehaving, and RF interference at home is also lower.

I also bought a very good 10€ no-brand ralink wifi chipset dual frequency stick in aliexpress "300Mbps Dual Band 2.4GHz / 5.8GHz Ralink RT5572N WiFi USB Adapter" so much better, but ended up buying a TP-Link router with OpenWRT and connecting it via Ethernet .

To finish my "rant" about Realtek; while deciding what 5GHz AC AP to buy, I looked at one rather cheap AP, the ASUS EA-N66 which is entirely based in realtek chipset(s). The forums are full of complaints of it locking up misteriously a couple of times PER WEEK at least.

I would not buy ASUS or Realtek any time soon. IMO they are focused in selling cheap junk that does not work.

REVISITING this answer: in the meanwhile I learnt that there are more deep settled reasons than I knew/suspected, at the kernel/USB level, that give very plausible answers that explain the stability of wifi adapters working better via PCI/card sockets vs the instability of USB-based chipset wifis.

I also learnt that the market of USB wifis is mostly dominated nowadays by realtek vs ralink, and most of the other brands are just rebrands.

The USB Ralink adapter I bought in AliExpress unfortunately is also an old chipset model with its set of bugs, however between two evils, it works consistently better than a Realtek. OpenBSD manages to work quite well using this Ralink, FreeBSD still has some nasty bugs using it.

PS: I was suggested to buy a USB->PCIe adapter to be able to use better brands of Wifi cards externally. If and when I try/test it, will revisit this answer.

See related question Why do WiFi routers do such a bad job of channel selection?

@SpecialBomb 2015-12-29 19:28:37

I paid $20 for the thing, pretty disappointed. Many people on forums were saying that this specific Wi-Fi adapter was the best for Linux. I feel pretty cheated now.

@Rui F Ribeiro 2015-12-29 19:33:08

In aliexpress you can buy this chipset for peanuts, from many chinese wifi manufacturers. The chipset itself apparently costs cents to them, it is fairly easy to find wifi USBs in the range of 3USD-10USD there. They are all junk.

@Rui F Ribeiro 2015-12-29 19:41:20

I returned to add something more to the answer about the dynamics of 2.4GHz. As I said I ended up buying a TP-LINK router, and using the ARM only as router to the Internet. The TP-LINK Archer C7 v2 with 5 gibabit ports, 802.11 for AC, 2 internals antenas for 2.4GHz, 3 external for 5GHz, and the change to put Linux/OpenWrt there for 100USD is a pretty good deal.

@SpecialBomb 2015-12-29 19:43:49

Guess I was a little late figuring things out. Could you find a specific chipset or something I could use on Amazon and post it in a comment? I think I can try to complain to Amazon and get my money back, and hopefully buy a better one. (I bought the one I'm using on Amazon.)

@Rui F Ribeiro 2015-12-29 19:52:31

Have a look at those. It will be up to you to do some research about Linux compatibility, I wont have got the time in the next few days.… and… and…

@Faheem Mitha 2017-12-28 17:44:58

@SpecialBomb I agree with Rui that Realtek is junk. It's not that hard to find good quality hardware; but you have to spend a little time reading reviews and so forth. You could also search on to see if that question has already been covered, and ask one if not. In general Intel makes decent hardware, I think, and they always seem to cooperate with the community, so generally they have free drivers for their hardware.

@Faheem Mitha 2017-12-28 17:53:44

The answer to recommends and that certainly gets good reviews on Amazon and other places, and has multiple reports that it works out of the box on Linux. One review said it has an Atheros chipset.

@Faheem Mitha 2017-12-28 19:06:32

And this answer suggests a Gigabyte card with somewhat more mixed reviews. This one has an Intel chipset.

@SpecialBomb 2017-12-29 18:09:44

Hoo boy, its been a while. Since this, I got a PCIe wifi card that uses an atheros chipset. Everything is pretty much fine now. That lsusb output looks absolutely nostalgic to me. I was still using my shitty R.A.T. 5 mouse, and god knows what keyboard I was using, lol. This post pretty much marked my initial transition to GNU/Linux, so thank you all!

@Rui F Ribeiro 2018-02-17 16:40:01

@SpecialBomb if you do not mind, I have been using/abusing this post as a placeholder about realtek vs other wifi chipsets.

@SpecialBomb 2018-02-22 02:41:14

@RuiFRibeiro go the heck ahead, realtek needs to just stop making chips and drivers.

@Mike Seeds 2020-01-22 12:03:12

There are a couple of different drivers for the 8192cu. The built in kernel drivers do not support AP mode. My 8192 came with a disk with the source code. I built it and it works perfectly including AP mode. If you do lsmod the bad driver is "rtl8xxx" the good driver is 8192cu".

@Rui F Ribeiro 2020-01-22 12:45:00

@MikeSeeds The 8192cu already existed by the time I wrote this answer...the hw is quite bad, it is not a driver problem per se.

Related Questions

Sponsored Content

2 Answered Questions

8821ce Realtek WiFi card errors

1 Answered Questions

2 Answered Questions

[SOLVED] network connection on kali

1 Answered Questions

[SOLVED] USB WiFi on CentOS7

  • 2015-06-15 06:26:46
  • tesseract
  • 8100 View
  • 2 Score
  • 1 Answer
  • Tags:   centos wifi usb

1 Answered Questions

[SOLVED] TL-WN722N not usable by kali

Sponsored Content