By Drake


2010-08-11 19:45:52 8 Comments

OpenID is a standard commonly used nowadays. I am trying to implement OpenID on my blog, but I have many difficulties.

I tried OpenID plugin but it seems to be incompatible with Wordpress 3.0.

I tried also Janrain plugin but the free version is too limited. I would like to integrate the login screen into my blog theme style.

Do you have any suggestions how to proceed? Any other plugins? Or any PHP library that can be adapted to an easy integration with Wordpress?

4 comments

@ripper234 2011-06-07 22:21:10

A couple of notes regarding OpenID plugin:

  1. I recommend changing the plugin's version number so it never upgrades to the broken 3.3.3.
  2. Three things I did now that helped me fix a broken plugin: Revert to 3.3.2, change my Reading Settings and making sure XRDS-simple is activated.

@rds 2010-12-11 23:58:05

Why do you say Janrain is to limited? just call the javascript showRPX() anywhere you want.

For instance, in my theme, I had

$u=get_login_url();
printf("<a href='$u'>login</a>);

Just use instead

$u=get_login_url();
printf("<a href='$u' onclick='javascript:showRPX();return false;'>login</a>);

It's not free as in free speech, but I think you have enough freedom with their solution

@Viper007Bond 2010-08-11 21:27:06

The OpenID plugin you linked is the best one, but it has a minor bug preventing it from working with WordPress 3.0, at least when combined with PHP 5.3.

The fix can be found here: http://code.google.com/p/diso/issues/detail?id=161

@ripper234 2011-02-04 07:01:07

If anyone cares to fork that project and release it with the bugfix, please tell us here.

@James 2010-08-11 21:22:56

I use OpenID 3.3.2 (from the same link) and it works fine as far as I can tell. I have the latest version of WordPress and the Plugin. I have full control on the server if that makes any difference.

If you can tell specifically what the problem is, I can check how I have configured.

Related Questions

Sponsored Content

1 Answered Questions

2 Answered Questions

[SOLVED] Upgrade not working & themes not supporting

  • 2011-01-27 10:48:19
  • Niraj Chauhan
  • 1487 View
  • 0 Score
  • 2 Answer
  • Tags:   plugins themes

1 Answered Questions

2 Answered Questions

2 Answered Questions

Using Vagrant for customizable Wordpress Multi-sites

3 Answered Questions

[SOLVED] Separating Search Results By Post Type

3 Answered Questions

[SOLVED] replace html entities in posts between pre tags

5 Answered Questions

[SOLVED] Login with OpenID, similar to Stack Exchange sites?

3 Answered Questions

[SOLVED] What's the recommended process for organising collaborative posting?

2 Answered Questions

[SOLVED] OpenID for WordPress 3.x?

Sponsored Content