By Chris


2018-02-20 15:27:34 8 Comments

We have two identical sites (one is a staging site) hosted on different servers. Both are running the same WordPress version 4.8.5.

On one of these sites Vimeo videos are failing to load (previously these were working fine at some point in the past couple weeks). This has been tested using the default unmodified Seventeen theme to rule out any theme-related issues and the problem is the same.

For example, when I insert a Vimeo video link on the faulty site it just returns the URL for the video in the page eg:

https://vimeo.com/44633289

Yet on the working site, with exactly the same page content the video URL above is automatically replaced with the Vimeo video player.

Screenshot from faulty site:

enter image description here

Screenshot from working site:

enter image description here

For testing we tried a Youtube video and this is displayed fine on the faulty site.

How can I troubleshoot this and work out what is causing the problem?

1 comments

@Chris 2018-02-22 13:10:41

After further investigation this appears to be Vimeo blocking the requests.

We have two sites (one where Vimeo videos work and one where they don't). When testing the retrieval of content via PHP we get "HTTP request failed! HTTP/1.1 403 Forbidden" on the faulty site.

Anyone else reading this thread can run the same test with this script:

https://pastebin.com/szRfKbRv

This will identify if Vimeo is blocked on your hosting server - if it is you should contact your hosting provider and/or Vimeo to get the IP block removed.

Not a WordPress problem per se, but hopefully this diagnostic test helps someone else in the future.

Related Questions

Sponsored Content

0 Answered Questions

oEmbed not working in WordPress

0 Answered Questions

Revolution slider video doesn't play

  • 2018-07-03 08:27:09
  • Roberto Meijide
  • 380 View
  • 0 Score
  • 0 Answer
  • Tags:   plugins html5 vimeo

0 Answered Questions

Wordpress vimeo embed not working with https

  • 2017-02-06 13:16:39
  • Girish
  • 543 View
  • 0 Score
  • 0 Answer
  • Tags:   vimeo

3 Answered Questions

[SOLVED] Add parameters vimeo videos using wordpress embeds

  • 2013-08-19 06:26:16
  • Andy M
  • 2211 View
  • 1 Score
  • 3 Answer
  • Tags:   oembed vimeo

2 Answered Questions

0 Answered Questions

How can I remove the first video from a post and feature it?

2 Answered Questions

[SOLVED] Generating Thumbnails for video

3 Answered Questions

[SOLVED] Protecting HTML5 video

1 Answered Questions

[SOLVED] Are self-hosted videos a good idea?

  • 2013-07-17 23:08:09
  • Silouane Gerin
  • 194 View
  • 0 Score
  • 1 Answer
  • Tags:   videos vimeo

1 Answered Questions

Sponsored Content